sed in unpack; IUSE; virtual/x11
authorMichael Sterrett <mr_bones_@gentoo.org>
Wed, 31 Mar 2004 03:33:36 +0000 (03:33 +0000)
committerMichael Sterrett <mr_bones_@gentoo.org>
Wed, 31 Mar 2004 03:33:36 +0000 (03:33 +0000)
games-action/xpilot/ChangeLog
games-action/xpilot/xpilot-4.5.4.ebuild

index 9bfc374490632f121c8304c63eb1ab15b2a6b9d4..42b4a327274606e8ebbb16f847e7d1955951690e 100644 (file)
@@ -1,6 +1,9 @@
 # ChangeLog for games-action/xpilot
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.2 2003/09/10 20:31:35 vapier Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/ChangeLog,v 1.3 2004/03/31 03:33:36 mr_bones_ Exp $
+
+  30 Mar 2004; Michael Sterrett <mr_bones_@gentoo.org> xpilot-4.5.4.ebuild:
+  sed in unpack; IUSE; virtual/x11
 
   17 Jun 2003; msterret xpilot-4.5.4.ebuild:
   use sed -i and emake
index bf9bbb588f06096486fbe6f5904f77c6b65fdc40..75adc91134fa3d1f403a4c215b4f2580c48270dd 100644 (file)
@@ -1,24 +1,30 @@
 # Copyright 1999-2004 Gentoo Technologies, Inc.
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.2 2004/02/20 06:13:57 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xpilot/xpilot-4.5.4.ebuild,v 1.3 2004/03/31 03:33:36 mr_bones_ Exp $
 
 DESCRIPTION="A multi-player 2D client/server space game"
 HOMEPAGE="http://www.xpilot.org/"
 SRC_URI="http://xpilot.org/pub/xpilot/${P}.tar.gz"
 
-KEYWORDS="x86 ppc"
 LICENSE="GPL-2"
 SLOT="0"
+KEYWORDS="x86 ppc"
+IUSE=""
 
-DEPEND="x11-base/xfree
+RDEPEND="virtual/x11"
+DEPEND="${RDEPEND}
        >=sys-apps/sed-4"
 
-src_compile() {
+src_unpack() {
+       unpack ${A}
+       cd ${S}
        sed -i \
                -e "s:/usr/local:/usr:" \
                -e "s:/man/man:/share/man/man:" \
                Local.config || die "sed Local.config failed"
+}
 
+src_compile() {
        # the stuff xpilot puts it /usr/lib should go
        # in /usr/share , but I'm leaving it for now.
 
@@ -31,10 +37,10 @@ src_compile() {
        done
        make includes || die "includes problem"
        make depend || die "depend problem"
-       emake || die "compile problem"
+       emake || die "emake failed"
 }
 
 src_install() {
-       make DESTDIR=${D} install || die "install problem"
-       make DESTDIR=${D} install.man || die "install.man problem"
+       make DESTDIR="${D}" install || die "install problem"
+       make DESTDIR="${D}" install.man || die "install.man problem"
 }