dev-util/yacc: quote variables correctly.
authorPatrice Clement <monsieurp@gentoo.org>
Wed, 19 Apr 2017 23:12:43 +0000 (01:12 +0200)
committerPatrice Clement <monsieurp@gentoo.org>
Thu, 20 Apr 2017 21:02:31 +0000 (23:02 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-util/yacc/yacc-1.9.1-r6.ebuild

index 4d0ba31f56e85e798e2dd121ff66b1f481de44b3..0462eee56053d54fc0a8a951bad415442e7c5705 100644 (file)
@@ -15,14 +15,14 @@ KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~mips ppc ppc64 s390 sh sparc x86"
 
 PATCHES=(
        # mkstemp patch from byacc ebuild.
-       "${FILESDIR}"/${P}-mkstemp.patch
+       "${FILESDIR}/${P}-mkstemp.patch"
 
        # The following patch fixes yacc to run correctly on ia64 (and
        # other 64-bit arches). See bug 46233.
-       "${FILESDIR}"/${P}-ia64.patch
+       "${FILESDIR}/${P}-ia64.patch"
 
        # Avoid stack access error. See bug 232005.
-       "${FILESDIR}"/${P}-CVE-2008-3196.patch
+       "${FILESDIR}/${P}-CVE-2008-3196.patch"
 )
 
 src_prepare() {
@@ -47,15 +47,15 @@ pkg_preinst() {
        # bison installs a /usr/bin/yacc symlink ...
        # we need to remove it to avoid triggering
        # collision-protect errors. See bug 90089.
-       if [[ -L ${ROOT}/usr/bin/yacc ]]; then
-               rm -v "${ROOT}"/usr/bin/yacc || die
+       if [[ -L "${ROOT}/usr/bin/${PN}" ]]; then
+               rm -v "${ROOT}/usr/bin/${PN}" || die
        fi
 }
 
 pkg_postrm() {
        # and if we uninstall yacc but keep bison,
        # let's restore the /usr/bin/yacc symlink.
-       if [[ ! -e ${ROOT}/usr/bin/yacc ]] && [[ -e ${ROOT}/usr/bin/yacc.bison ]]; then
-               ln -s yacc.bison "${ROOT}"/usr/bin/yacc || die
+       if [[ ! -e "${ROOT}/usr/bin/${PN}" ]] && [[ -e "${ROOT}/usr/bin/${PN}.bison" ]]; then
+               ln -s yacc.bison "${ROOT}/usr/bin/${PN}" || die
        fi
 }