dev-python/bicyclerepair: Clean old
authorJustin Lecher <jlec@gentoo.org>
Sun, 20 Sep 2015 10:09:35 +0000 (12:09 +0200)
committerJustin Lecher <jlec@gentoo.org>
Sun, 20 Sep 2015 10:09:35 +0000 (12:09 +0200)
Package-Manager: portage-2.2.20.1
Signed-off-by: Justin Lecher <jlec@gentoo.org>
dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild [deleted file]
dev-python/bicyclerepair/bicyclerepair-0.9-r3.ebuild

diff --git a/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild b/dev-python/bicyclerepair/bicyclerepair-0.9-r2.ebuild
deleted file mode 100644 (file)
index e2b20f4..0000000
+++ /dev/null
@@ -1,63 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="3"
-PYTHON_DEPEND="2"
-SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
-
-inherit distutils elisp-common eutils
-
-DESCRIPTION="Bicycle Repair Man is the Python Refactoring Browser"
-HOMEPAGE="http://bicyclerepair.sourceforge.net/"
-SRC_URI="mirror://sourceforge/bicyclerepair/${P}.tar.gz"
-
-LICENSE="icu GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 ~ia64 ppc ppc64 x86"
-IUSE="emacs"
-
-DEPEND="emacs? (
-               app-emacs/pymacs
-               app-emacs/python-mode
-       )"
-RDEPEND="${DEPEND}"
-
-SITEFILE="50${PN}-gentoo.el"
-PYTHON_MODNAME="BicycleRepairMan_Idle.py bike bikeemacs.py"
-
-src_prepare() {
-       distutils_src_prepare
-
-       # bikeemacs.py contains non-ASCII characters in comments.
-       sed -e '1s/$/\t-*- coding: latin-1 -*-/' -i ide-integration/bikeemacs.py || die "sed failed"
-
-       epatch "${FILESDIR}/${P}-idle.patch"
-       epatch "${FILESDIR}/${P}-invalid-syntax.patch"
-}
-
-src_test() {
-       testing() {
-               "$(PYTHON)" testall.py
-       }
-       python_execute_function testing
-}
-
-src_install() {
-       distutils_src_install
-
-       if use emacs; then
-               elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-       fi
-}
-
-pkg_postinst() {
-       distutils_pkg_postinst
-       use emacs && elisp-site-regen
-}
-
-pkg_postrm() {
-       distutils_pkg_postrm
-       use emacs && elisp-site-regen
-}
index 1174f346a34f016679e86ad3b2890da9b15a2c22..a0fa68d4dd17e37d95856cfd3d5ab1e622465767 100644 (file)
@@ -3,6 +3,7 @@
 # $Id$
 
 EAPI=5
+
 PYTHON_COMPAT=( python2_7 )
 
 inherit distutils-r1 elisp-common
@@ -16,18 +17,23 @@ SLOT="0"
 KEYWORDS="amd64 ~ia64 ppc ppc64 x86"
 IUSE="emacs"
 
-DEPEND="emacs? (
+DEPEND="
+       emacs? (
                app-emacs/pymacs[${PYTHON_USEDEP}]
-               app-emacs/python-mode )"
+               app-emacs/python-mode
+       )"
 RDEPEND="${DEPEND}"
 
 SITEFILE="50${PN}-gentoo.el"
 
+PATCHES=(
+       "${FILESDIR}/${P}-idle.patch"
+       "${FILESDIR}/${P}-invalid-syntax.patch"
+)
+
 python_prepare_all() {
        # bikeemacs.py contains non-ASCII characters in comments.
        sed -e '1s/$/\t-*- coding: latin-1 -*-/' -i ide-integration/bikeemacs.py || die "sed failed"
-       epatch "${FILESDIR}/${P}-idle.patch"
-       epatch "${FILESDIR}/${P}-invalid-syntax.patch"
 
        distutils-r1_python_prepare_all
 }
@@ -39,9 +45,7 @@ python_test() {
 src_install() {
        distutils-r1_src_install
 
-       if use emacs; then
-               elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die "elisp-site-file-install failed"
-       fi
+       use emacs && elisp-site-file-install "${FILESDIR}/${SITEFILE}"
 }
 
 pkg_postinst() {