sys-devel/smatch: bump up to 1.60
authorSergei Trofimovich <slyfox@gentoo.org>
Fri, 18 Jan 2019 08:13:17 +0000 (08:13 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Fri, 18 Jan 2019 08:14:01 +0000 (08:14 +0000)
Package-Manager: Portage-2.3.56, Repoman-2.3.12
Signed-off-by: Sergei Trofimovich <slyfox@gentoo.org>
sys-devel/smatch/Manifest
sys-devel/smatch/smatch-1.60.ebuild [new file with mode: 0644]

index 68f734a52dd8e86a3399b7621220f762e373c620..fae3e61cc1f45e1dd6dab75e60f8f5e46f0accab 100644 (file)
@@ -1,2 +1,3 @@
 DIST smatch-1.57.tar.gz 491677 BLAKE2B 150ba84dc797497b2522d28b443a89fbec221a00fcade85014d434f675ec60908a473770c695dbf65a5ed273c3e665aa9dc4ec9a91bc071651388a9ec90f1bfa SHA512 031f417c97d58b617b2e375a28f509f71eb2735212a98aee0e21880a28842078ad3c24b5375a03f73d75fec582a9d187ed6a00a0512c4792e5ffce82dfd79b99
 DIST smatch-1.59.tar.gz 495530 BLAKE2B 668a050e229cd9b4e5881fe059f5a8654164f5a155c471559ce7a82e66bcb2170f89a25680be7ff867f2765b574f363ef95a15a65ca98d47dbd8aed20f588f9a SHA512 5e18f48dbbe11255a06b427205aefd1f8f5a11bb0b238f9134b89e6f5cb838fcae649a4e87a4a04473a33077c94e88aab46b06e33cc87cfe451fa83b5846ccc7
+DIST smatch-1.60.tar.gz 558479 BLAKE2B d5e564c32e33dc38847f9a258b4b47285f190652181db9b8850c832c0cf4d8a3302d989a7b42592e73a713927a29565565e83a9be1b0a5c9d10869fce278a0be SHA512 2920c9d4c500db36cfa60db5be70d157ed16abd729279462faef6f79e0756bd017ec91b8f857d19fdebd8a9d709b0555635700a2864cf0a84daa61cf2ca3eecd
diff --git a/sys-devel/smatch/smatch-1.60.ebuild b/sys-devel/smatch/smatch-1.60.ebuild
new file mode 100644 (file)
index 0000000..ad8cb59
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="git://repo.or.cz/${PN}.git
+               http://repo.or.cz/r/${PN}.git"
+       inherit git-r3
+else
+       SRC_URI="http://repo.or.cz/w/smatch.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz
+               mirror://gentoo/${P}.tar.gz"
+       KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+       S=${WORKDIR}/${PN}
+fi
+
+DESCRIPTION="static analysis tool for C"
+HOMEPAGE="http://smatch.sourceforge.net/"
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+RDEPEND="dev-db/sqlite"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${P}-7a4fdad
+
+src_prepare() {
+       default
+
+       sed -i \
+               -e '/^CFLAGS =/{s:=:+=:;s:-O2 -finline-functions:${CPPFLAGS}:}' \
+               Makefile || die
+}
+
+_emake() {
+       # gtk/llvm/xml is used by sparse which we don't install
+       emake \
+               PREFIX="${EPREFIX}/usr" \
+               V=1 \
+               AR="$(tc-getAR)" \
+               CC="$(tc-getCC)" \
+               LD='$(CC)' \
+               HAVE_GTK2=no \
+               HAVE_LLVM=no \
+               HAVE_LIBXML=no \
+               "$@"
+}
+
+src_compile() {
+       _emake smatch
+}
+
+src_test() {
+       _emake check
+}
+
+src_install() {
+       # default install target installs a lot of sparse cruft
+       dobin smatch
+       insinto /usr/share/smatch/smatch_data
+       doins smatch_data/*
+       dodoc FAQ README
+}