dev-python/hypothesis: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 06:07:24 +0000 (07:07 +0100)
committerMichał Górny <mgorny@gentoo.org>
Fri, 7 Feb 2020 07:15:03 +0000 (08:15 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/hypothesis/Manifest
dev-python/hypothesis/hypothesis-4.55.4.ebuild [deleted file]
dev-python/hypothesis/hypothesis-5.3.0.ebuild [deleted file]
dev-python/hypothesis/hypothesis-5.4.0.ebuild [deleted file]

index ed5395adc63b786503177cd334f2a8b3fece7d3b..854875549619e170be6b0f86f956681114128a78 100644 (file)
@@ -1,7 +1,4 @@
 DIST hypothesis-python-4.47.5.tar.gz 6805022 BLAKE2B 737a558c794f3ac428bef4b38858d47fddba613ce37eb9a9554afa3c189776e9172965dd31f8497747ac13b2ab1d34ee6de8671646972e71b82c5260db489b9a SHA512 9b6920181dca75b9e551ae5e598101f35cfc26e9e3a1b20cab652c151bc6355413d0c9602d3242fb23f808ab00335793009df938d55ee19a6af1ce2a8b085e3c
 DIST hypothesis-python-4.50.8.tar.gz 6814518 BLAKE2B f2c39cae3708fe88d1854cda97633ba420c32fda38093bb852ef45929762cade0f7f0d1ef696ff96f7ebe7460e8bf53f63de9c959bbbd9e8ec162196d307aac0 SHA512 8c77439fd029e2380afbc059d2edf977414997ba81ecdfde14dfe9dbe9515a92e701751d13879c6b879271f817e01926c2dc66945ae76eb141818da1775bc545
-DIST hypothesis-python-4.55.4.tar.gz 9004357 BLAKE2B 93fe51581f044cf5f416d9b74b82ce2f9b42e7391beae8f67debdf50494e662f07bf109274d4e29fcf3a1c1c944597cde2a4ff9e7ca65a48f1244c3205f365af SHA512 91d7d2cda32fd40d5368fdd1e60b990b8307573782d822113b6817a5c0b670610693a2f2b013f828913549946fa3dc15f45303bf7d3226bdc1e4527bc18981fb
 DIST hypothesis-python-4.57.1.tar.gz 9005030 BLAKE2B 3d318896cbe2d24fa6847e764a109791d3acf3821852f8e170991b0be5b069f166e16bdacf7a82fbe49bd9db5188315cdec7cdb4592647571233949ec5732991 SHA512 28622ce8a1d89d09df65f3fbf7e92a1ad98dac140ab646fe11fcb15e6aa9a9672eb51d459f984384d92b819f902de911b06cec2542582d529dd556d2f99ed952
-DIST hypothesis-python-5.3.0.tar.gz 8991842 BLAKE2B 9bd5124a6a0b07c910aebd5caa3a27d6ee19d307f88438ef097b09108a6c41d4b548c224861b1aed766a84696fe494c3b50f55b0b35bf81563ee62c366a03956 SHA512 d622c6754e6162120e7bdc17f482d64e917042499179668744b26e09ba355d94681b2e1029d786c38af19c4193c41eb5fe3e4a7ecc322acd1895b8f90d2b1f95
-DIST hypothesis-python-5.4.0.tar.gz 8992011 BLAKE2B 0d748429e34360437799d043f75282153687b84c1f0c27f18846c75bf6a801797c460f3e1d22a04d52f1b046cb33d6ac34fcae93c40180e0273957ea81e3fb40 SHA512 9b168f11f9d7e720691ce3fdbff8f97d3fdfff86bdc9ab2683e58ff31dece36d57b468693fcf3b1b7e6cfc16022dd733eacabbf5bd08042ac8cca6c45050c129
 DIST hypothesis-python-5.4.1.tar.gz 8993002 BLAKE2B b96f9080f7a5b307698ee1119495cb5356ccd2836f1d3ae66077bc0be2793d5d62beba09b2a38e5486f6d0d09e95ac85e81511c5ab7434c7285608a0ae62caa7 SHA512 bf01c50ea998aee2a547132806845aa9330a3830ce2b864f0ab9e2d9b9dd7dbdc9ec4db2ef77bfb9a76467b00f3ca1c00acbba7bdea569dab3038914a598d0c0
diff --git a/dev-python/hypothesis/hypothesis-4.55.4.ebuild b/dev-python/hypothesis/hypothesis-4.55.4.ebuild
deleted file mode 100644 (file)
index 996a19c..0000000
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python2_7 python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
-       $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' 'python2*' pypy)
-       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
-               !!<dev-python/typing-3.7.4.1
-       )
-"
-
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-src_prepare() {
-       # avoid pytest-xdist dep for one test
-       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
-               tests/pytest/test_statistics.py || die
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       local pyver=$(python_is_python3 && echo 3 || echo 2)
-       pytest -vv tests/cover tests/pytest tests/py${pyver} ||
-               die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       optfeature "datetime support" dev-python/pytz
-       optfeature "dateutil support" dev-python/python-dateutil
-       optfeature "numpy support" dev-python/numpy
-       optfeature "django support" dev-python/django dev-python/pytz
-       optfeature "pandas support" dev-python/pandas
-       optfeature "pytest support" dev-python/pytest
-}
diff --git a/dev-python/hypothesis/hypothesis-5.3.0.ebuild b/dev-python/hypothesis/hypothesis-5.3.0.ebuild
deleted file mode 100644 (file)
index d1f7fce..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
-       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
-               !!<dev-python/typing-3.7.4.1
-       )
-"
-
-src_prepare() {
-       # avoid pytest-xdist dep for one test
-       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
-               tests/pytest/test_statistics.py || die
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       pytest -vv tests/cover tests/pytest tests/quality ||
-               die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       optfeature "datetime support" dev-python/pytz
-       optfeature "dateutil support" dev-python/python-dateutil
-       optfeature "numpy support" dev-python/numpy
-       optfeature "django support" dev-python/django dev-python/pytz
-       optfeature "pandas support" dev-python/pandas
-       optfeature "pytest support" dev-python/pytest
-}
diff --git a/dev-python/hypothesis/hypothesis-5.4.0.ebuild b/dev-python/hypothesis/hypothesis-5.4.0.ebuild
deleted file mode 100644 (file)
index d1f7fce..0000000
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-PYTHON_REQ_USE="threads(+),sqlite"
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A library for property based testing"
-HOMEPAGE="https://github.com/HypothesisWorks/hypothesis https://pypi.org/project/hypothesis/"
-SRC_URI="https://github.com/HypothesisWorks/${PN}/archive/${PN}-python-${PV}.tar.gz"
-S="${WORKDIR}/${PN}-${PN}-python-${PV}/${PN}-python"
-
-LICENSE="MPL-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~sparc ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
-       >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]
-       >=dev-python/sortedcontainers-2.1.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
-       test? (
-               ${RDEPEND}
-               dev-python/mock[${PYTHON_USEDEP}]
-               dev-python/pexpect[${PYTHON_USEDEP}]
-               >=dev-python/pytest-4.3[${PYTHON_USEDEP}]
-               !!<dev-python/typing-3.7.4.1
-       )
-"
-
-src_prepare() {
-       # avoid pytest-xdist dep for one test
-       sed -i -e 's:test_prints_statistics_given_option_under_xdist:_&:' \
-               tests/pytest/test_statistics.py || die
-       distutils-r1_src_prepare
-}
-
-python_test() {
-       pytest -vv tests/cover tests/pytest tests/quality ||
-               die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
-       optfeature "datetime support" dev-python/pytz
-       optfeature "dateutil support" dev-python/python-dateutil
-       optfeature "numpy support" dev-python/numpy
-       optfeature "django support" dev-python/django dev-python/pytz
-       optfeature "pandas support" dev-python/pandas
-       optfeature "pytest support" dev-python/pytest
-}