dev-haskell/http-attoparsec: tweak for HTTP-4000.3.5
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:30:58 +0000 (21:30 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 21:57:06 +0000 (21:57 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch [new file with mode: 0644]
dev-haskell/http-attoparsec/http-attoparsec-0.1.1-r3.ebuild

diff --git a/dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch b/dev-haskell/http-attoparsec/files/http-attoparsec-0.1.1-http.patch
new file mode 100644 (file)
index 0000000..2de100c
--- /dev/null
@@ -0,0 +1,9 @@
+diff --git a/Network/HTTP/Attoparsec.hs b/Network/HTTP/Attoparsec.hs
+index ec464d0..37f9983 100644
+--- a/Network/HTTP/Attoparsec.hs
++++ b/Network/HTTP/Attoparsec.hs
+@@ -7,3 +7,3 @@ module Network.HTTP.Attoparsec
+ where
+-import Network.HTTP.Types.Header
++import Network.HTTP.Types.Header hiding (parseByteRanges)
index b4090db4a5a919d53e1430ff4ee2220a526fef4a..a1c4de7e8a968a388f53817b263f933696071c8e 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -27,6 +27,8 @@ DEPEND="${RDEPEND}
 "
 
 src_prepare() {
+       epatch "${FILESDIR}"/${P}-http.patch
+
        cabal_chdeps \
                'attoparsec >= 0.10.4.0 && < 0.12' 'attoparsec >= 0.10.4.0' \
                'http-types >= 0.8.0 && < 0.9' 'http-types >= 0.8.0'