dev-libs/libisoburn: Version bump.
authorDaniel Pielmeier <billie@gentoo.org>
Sun, 24 Jan 2016 16:42:02 +0000 (17:42 +0100)
committerDaniel Pielmeier <billie@gentoo.org>
Sun, 24 Jan 2016 16:42:35 +0000 (17:42 +0100)
Package-Manager: portage-2.2.26

dev-libs/libisoburn/Manifest
dev-libs/libisoburn/libisoburn-1.3.8.ebuild
dev-libs/libisoburn/libisoburn-1.4.0.ebuild
dev-libs/libisoburn/libisoburn-1.4.2.ebuild [new file with mode: 0644]

index 5fbcad51f686be89c62c123c788957a7c69ab072..e4867f51667fb7a0556003641ab5fb23fa5c54a3 100644 (file)
@@ -1,2 +1,3 @@
 DIST libisoburn-1.3.8.tar.gz 1429974 SHA256 b75c9a7f17faab5280ddc34ea6610c4e8bcf630762ee386d10bc52c4b50f6806 SHA512 369299e491a379e048038d8a46040feb628b6b9dfb6d6ffac01808b6814e6ca936bb7e4fe75f904ce755e9957011403a5d38bff9f37901086d284f5c1014deb7 WHIRLPOOL 3dc40ab34838bb3d79f0cbb08b16480106de16b2c8401859c52fa139eb8a555f4182402dacf51ee481ec8f490a33a2e09cfc4ec3ba63db9fc876854c80f4dd12
 DIST libisoburn-1.4.0.tar.gz 1453974 SHA256 c1d51ae7e4662f75caae4442071b8e1480efb8e80682a9f82c32a76f30ba6421 SHA512 d9fd1e4a6f8d6ec2dfe2eccdf2ba2e379232d5eb66e25940a8854f160ccd456fa384488acf466af51fb9662ecd5a774dc81fe0fbd03fb8e1b82118ee9d066d1c WHIRLPOOL 3db2740f2ed9dc4b872f0d424a231673a10d0bb8af88ac9cdc1272e3e738d5bdda43b57ac0e0e69a95ad4d73b97947bbb07b360b275ec57a53dbb75d6565004d
+DIST libisoburn-1.4.2.tar.gz 1496784 SHA256 2dfac7312fd136db5c5e1a9738e3a0896bddea2f89621bd071f3b8045aef54d6 SHA512 aaf9d8eee70cbdf2a64315fe68d03c097f26f24f0d21394b7dc1ff1370eed2d21edf54273f2897371b05c9f8772821ae7ba5ea51f52ea43b39538ef64afff555 WHIRLPOOL 0156e5a6da8433c412ea2c6122364937a673ffa961707fa14530eaaeae7e0f960a1a020c0d74ab2202ecbc8f4348c5eec1de32566f01bdfdac0234baa8e30585
index 163d995bba480decf53b570a84bf586992aa747e..e1c4b04366cdfab84654aa1442bdc17c6c60239a 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=5
 
 inherit eutils
 
-DESCRIPTION="Enables creation and expansion of ISO-9660 filesystems on all CD/DVD media supported by libburn"
+DESCRIPTION="Creation/expansion of ISO-9660 filesystems on CD/DVD media supported by libburn"
 HOMEPAGE="http://libburnia-project.org/"
 SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
 
index 750b8f14d59168ee729307290722ec1e3c7a8dec..42abf751badc907558088b14514022e8d8d25ba5 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
 # $Id$
 
@@ -6,7 +6,7 @@ EAPI=5
 
 inherit eutils
 
-DESCRIPTION="Enables creation and expansion of ISO-9660 filesystems on all CD/DVD media supported by libburn"
+DESCRIPTION="Creation/expansion of ISO-9660 filesystems on CD/DVD media supported by libburn"
 HOMEPAGE="http://libburnia-project.org/"
 SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
 
diff --git a/dev-libs/libisoburn/libisoburn-1.4.2.ebuild b/dev-libs/libisoburn/libisoburn-1.4.2.ebuild
new file mode 100644 (file)
index 0000000..27799df
--- /dev/null
@@ -0,0 +1,66 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils
+
+DESCRIPTION="Creation/expansion of ISO-9660 filesystems on CD/DVD media supported by libburn"
+HOMEPAGE="http://libburnia-project.org/"
+SRC_URI="http://files.libburnia-project.org/releases/${P}.tar.gz"
+
+LICENSE="GPL-2 GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE="acl cdio debug external-filters external-filters-setuid frontend-optional
+       launch-frontend launch-frontend-setuid libedit readline static-libs xattr zlib"
+
+REQUIRED_USE="frontend-optional? ( || ( launch-frontend launch-frontend-setuid ) )"
+
+RDEPEND=">=dev-libs/libburn-1.4.2
+       >=dev-libs/libisofs-1.4.2
+       readline? ( sys-libs/readline:0= )
+       !readline? ( libedit? ( dev-libs/libedit ) )
+       acl? ( virtual/acl )
+       xattr? ( sys-apps/attr )
+       zlib? ( sys-libs/zlib )
+       cdio? ( >=dev-libs/libcdio-0.83 )
+       launch-frontend? ( dev-lang/tcl:0 dev-lang/tk:0 )
+       launch-frontend-setuid? ( dev-lang/tcl:0 dev-lang/tk:0 )
+       frontend-optional? ( dev-tcltk/bwidget )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig"
+
+src_configure() {
+       econf \
+       $(use_enable static-libs static) \
+       $(use_enable readline libreadline) \
+       $(usex readline --disable-libedit $(use_enable libedit)) \
+       $(use_enable acl libacl) \
+       $(use_enable xattr) \
+       $(use_enable zlib) \
+       --disable-libjte \
+       $(use_enable cdio libcdio) \
+       $(use_enable external-filters) \
+       $(use_enable external-filters-setuid) \
+       $(use_enable launch-frontend) \
+       $(use_enable launch-frontend-setuid) \
+       --disable-ldconfig-at-install \
+       --enable-pkg-check-modules \
+       $(use_enable debug)
+}
+
+src_install() {
+       default
+
+       dodoc CONTRIBUTORS doc/{comments,*.wiki,startup_file.txt}
+
+       docinto frontend
+       dodoc frontend/README-tcltk
+       docinto xorriso
+       dodoc xorriso/{changelog.txt,README_gnu_xorriso}
+       docinto xorriso/html
+
+       prune_libtool_files --all
+}