sys-libs/libutempter: Drop old versions
authorMatt Turner <mattst88@gentoo.org>
Sun, 12 Mar 2017 03:14:25 +0000 (19:14 -0800)
committerMatt Turner <mattst88@gentoo.org>
Thu, 16 Mar 2017 20:36:43 +0000 (13:36 -0700)
sys-libs/libutempter/Manifest
sys-libs/libutempter/libutempter-1.1.5-r1.ebuild [deleted file]
sys-libs/libutempter/libutempter-1.1.5.ebuild [deleted file]
sys-libs/libutempter/libutempter-1.1.6-r1.ebuild [deleted file]
sys-libs/libutempter/libutempter-1.1.6.ebuild [deleted file]

index e4d64562b59d736ac9d8a25e8557877e01811261..689985867d2bb08fc490ee5d502c5bce63027d5c 100644 (file)
@@ -1,2 +1 @@
-DIST libutempter-1.1.5.tar.bz2 14588 SHA256 73d0576b16caeb22874dc80d0ce7a6aeebb3181b117e95c147cd8d29df99e70e SHA512 12012d2bf3efa40b2afb90525883d2398105d75042cd5eac3091dd0b763107406c549038215747adcb3797edc6b2da1efe4bf31d9ab019d9e205d53a7c36492d WHIRLPOOL b61c1e0c84726e7f824ac83bc195c4d29ac236e2bab5790a559bbcacd75a97429c5458d8ff459f6257959b4f92855402273badaae4f69b9982ac26a72285e029
 DIST libutempter-1.1.6.tar.bz2 15705 SHA256 b898565f31ced7e5c1fa0a2eaa0f6ff0ed862b5fe375d26375b64bfbdfeac397 SHA512 6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede WHIRLPOOL c94d42d6929754608f9504defec3ab5b4c5c61fd0baa373e07508a11167241c07de4ecf26e14271e2c9914b731afba12ff7930e8ecd0126da1f472dccabdea30
diff --git a/sys-libs/libutempter/libutempter-1.1.5-r1.ebuild b/sys-libs/libutempter/libutempter-1.1.5-r1.ebuild
deleted file mode 100644 (file)
index 9ba8f89..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit user multilib flag-o-matic
-
-DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info, which need root access"
-HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="static-libs elibc_FreeBSD"
-
-RDEPEND="!sys-apps/utempter"
-
-pkg_setup() {
-       enewgroup utmp 406
-}
-
-src_prepare() {
-       local args=(
-               -e "/^libdir /s:/lib:/$(get_libdir):"
-               -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
-               -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
-               -e 's:,-stats::'
-       )
-       use static-libs || args+=(
-                       -e '/^STATICLIB/d'
-                       -e '/INSTALL.*STATICLIB/d'
-               )
-       sed -i "${args[@]}" Makefile || die
-}
-
-src_configure() {
-       use elibc_FreeBSD && append-libs -lutil
-       tc-export CC
-}
-
-src_compile() {
-       emake LDLIBS="${LIBS}"
-}
-
-src_install() {
-       default
-
-       fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
-       fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
-       dodir /usr/sbin
-       dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
-}
-
-pkg_postinst() {
-       if [ -f "${ROOT}/var/log/wtmp" ] ; then
-               chown root:utmp "${ROOT}/var/log/wtmp"
-               chmod 664 "${ROOT}/var/log/wtmp"
-       fi
-
-       if [ -f "${ROOT}/var/run/utmp" ] ; then
-               chown root:utmp "${ROOT}/var/run/utmp"
-               chmod 664 "${ROOT}/var/run/utmp"
-       fi
-}
diff --git a/sys-libs/libutempter/libutempter-1.1.5.ebuild b/sys-libs/libutempter/libutempter-1.1.5.ebuild
deleted file mode 100644 (file)
index e09dd2c..0000000
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-inherit user multilib flag-o-matic
-
-DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info, which need root access"
-HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="elibc_FreeBSD"
-
-RDEPEND="!sys-apps/utempter"
-
-pkg_setup() {
-       enewgroup utmp 406
-}
-
-src_compile() {
-       use elibc_FreeBSD && append-flags -lutil
-       emake \
-               CC="$(tc-getCC)" \
-               RPM_OPT_FLAGS="${CFLAGS}" \
-               libdir=/usr/$(get_libdir) \
-               libexecdir=/usr/$(get_libdir)/misc || die
-}
-
-src_install() {
-       make \
-               DESTDIR="${D}" \
-               libdir=/usr/$(get_libdir) \
-               libexecdir=/usr/$(get_libdir)/misc \
-               includedir=/usr/include \
-               install || die
-
-       fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
-       fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
-       dodir /usr/sbin
-       dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
-       dodoc README
-}
-
-pkg_postinst() {
-       if [ -f "${ROOT}/var/log/wtmp" ]
-       then
-               chown root:utmp "${ROOT}/var/log/wtmp"
-               chmod 664 "${ROOT}/var/log/wtmp"
-       fi
-
-       if [ -f "${ROOT}/var/run/utmp" ]
-       then
-               chown root:utmp "${ROOT}/var/run/utmp"
-               chmod 664 "${ROOT}/var/run/utmp"
-       fi
-}
diff --git a/sys-libs/libutempter/libutempter-1.1.6-r1.ebuild b/sys-libs/libutempter/libutempter-1.1.6-r1.ebuild
deleted file mode 100644 (file)
index f13d211..0000000
+++ /dev/null
@@ -1,69 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit user multilib flag-o-matic
-
-DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info, which need root access"
-HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
-IUSE="static-libs elibc_FreeBSD"
-
-RDEPEND="!sys-apps/utempter"
-
-pkg_setup() {
-       enewgroup utmp 406
-}
-
-src_prepare() {
-       local args=(
-               -e "/^libdir /s:/usr/lib:${EPREFIX}/usr/$(get_libdir):"
-               -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
-               -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
-               -e 's:,-stats::'
-               -e "/^includedir /s:/usr/include:${EPREFIX}/usr/include:"
-               -e "/^mandir /s:=.*:= ${EPREFIX}/usr/share/man:"
-       )
-       use static-libs || args+=(
-                       -e '/^STATICLIB/d'
-                       -e '/INSTALL.*STATICLIB/d'
-               )
-       sed -i "${args[@]}" Makefile || die
-}
-
-src_configure() {
-       use elibc_FreeBSD && append-libs -lutil
-       tc-export CC
-}
-
-src_compile() {
-       emake LDLIBS="${LIBS}"
-}
-
-src_install() {
-       default
-
-       if ! use prefix ; then
-               fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
-               fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
-       fi
-       dodir /usr/sbin
-       dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
-}
-
-pkg_postinst() {
-       if [ -f "${EROOT}/var/log/wtmp" ] ; then
-               chown root:utmp "${EROOT}/var/log/wtmp"
-               chmod 664 "${EROOT}/var/log/wtmp"
-       fi
-
-       if [ -f "${EROOT}/var/run/utmp" ] ; then
-               chown root:utmp "${EROOT}/var/run/utmp"
-               chmod 664 "${EROOT}/var/run/utmp"
-       fi
-}
diff --git a/sys-libs/libutempter/libutempter-1.1.6.ebuild b/sys-libs/libutempter/libutempter-1.1.6.ebuild
deleted file mode 100644 (file)
index 9ba8f89..0000000
+++ /dev/null
@@ -1,65 +0,0 @@
-# Copyright 1999-2012 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="4"
-
-inherit user multilib flag-o-matic
-
-DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info, which need root access"
-HOMEPAGE="http://altlinux.org/index.php?module=sisyphus&package=libutempter"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="static-libs elibc_FreeBSD"
-
-RDEPEND="!sys-apps/utempter"
-
-pkg_setup() {
-       enewgroup utmp 406
-}
-
-src_prepare() {
-       local args=(
-               -e "/^libdir /s:/lib:/$(get_libdir):"
-               -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
-               -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
-               -e 's:,-stats::'
-       )
-       use static-libs || args+=(
-                       -e '/^STATICLIB/d'
-                       -e '/INSTALL.*STATICLIB/d'
-               )
-       sed -i "${args[@]}" Makefile || die
-}
-
-src_configure() {
-       use elibc_FreeBSD && append-libs -lutil
-       tc-export CC
-}
-
-src_compile() {
-       emake LDLIBS="${LIBS}"
-}
-
-src_install() {
-       default
-
-       fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
-       fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
-       dodir /usr/sbin
-       dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
-}
-
-pkg_postinst() {
-       if [ -f "${ROOT}/var/log/wtmp" ] ; then
-               chown root:utmp "${ROOT}/var/log/wtmp"
-               chmod 664 "${ROOT}/var/log/wtmp"
-       fi
-
-       if [ -f "${ROOT}/var/run/utmp" ] ; then
-               chown root:utmp "${ROOT}/var/run/utmp"
-               chmod 664 "${ROOT}/var/run/utmp"
-       fi
-}