media-libs/libglvnd: Version bump to 1.1.1
authorMatt Turner <mattst88@gentoo.org>
Tue, 20 Aug 2019 20:48:53 +0000 (13:48 -0700)
committerMatt Turner <mattst88@gentoo.org>
Tue, 20 Aug 2019 20:49:22 +0000 (13:49 -0700)
Signed-off-by: Matt Turner <mattst88@gentoo.org>
media-libs/libglvnd/Manifest
media-libs/libglvnd/libglvnd-1.1.1.ebuild [new file with mode: 0644]

index 2125ebd2dc6d97ba5f650f21aa0e406cab1729bf..e5661b6ca6979ec388ff06299acfb451cd3dc7fa 100644 (file)
@@ -1 +1,2 @@
 DIST libglvnd-1.1.0.20190213.tar.gz 829094 BLAKE2B cf977846693a5de3485e23fe8b4c8e2bc0472d994dc85530ecd85c685d71abd7aa69e815292141f60fd69a299cf39ac16dda5822128295747bfd42db3408df66 SHA512 772445cbb5574c1900109b3e0d8aab442b8c8d9790c4d91e1400fccdff4a53b653b59120e4fb631a45fc47af02949288924e62a22c3d877d4f741d5596736e37
+DIST libglvnd-1.1.1.tar.gz 1851222 BLAKE2B 58a6e997b64bd22c4af0136fb37959f45df4a738bfcff205d7efb7ac08e7897a19164cb36f11d556c5a1bd3d46f0f1df3f89a36b7352b8a880c3570b2cf462cf SHA512 9106ae3cd3bdce8f4def3c7e08645f76e1a65f51e184510088e79b834899061d357422376e0efd56e1bc9dc7d3150f74837f43bd3e6c4c44faa3859844ab21b7
diff --git a/media-libs/libglvnd/libglvnd-1.1.1.ebuild b/media-libs/libglvnd/libglvnd-1.1.1.ebuild
new file mode 100644 (file)
index 0000000..89d1068
--- /dev/null
@@ -0,0 +1,51 @@
+# Copyright 2018-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+EGIT_REPO_URI="https://github.com/NVIDIA/${PN}.git"
+
+if [[ ${PV} = 9999* ]]; then
+       GIT_ECLASS="git-r3"
+fi
+
+PYTHON_COMPAT=( python2_7 )
+inherit autotools ${GIT_ECLASS} multilib-minimal python-any-r1
+
+DESCRIPTION="The GL Vendor-Neutral Dispatch library"
+HOMEPAGE="https://github.com/NVIDIA/libglvnd"
+if [[ ${PV} = 9999* ]]; then
+       SRC_URI=""
+else
+       KEYWORDS="~amd64"
+       SRC_URI="https://github.com/NVIDIA/${PN}/releases/download/v${PV}/${P}.tar.gz"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       !media-libs/mesa[-libglvnd(-)]
+       x11-libs/libX11[${MULTILIB_USEDEP}]
+       "
+DEPEND="${PYTHON_DEPS}
+       ${RDEPEND}"
+
+src_prepare() {
+       default
+       [[ $PV = 9999* ]] && eautoreconf
+}
+
+multilib_src_configure() {
+       ECONF_SOURCE=${S} econf
+}
+
+multilib_src_install() {
+       default
+       find "${D}" -name '*.la' -delete || die
+}
+
+multilib_src_test() {
+       emake check
+}