app-admin/mcelog: version bump to 122
authorJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 23:00:34 +0000 (01:00 +0200)
committerJulian Ospald <hasufell@gentoo.org>
Fri, 14 Aug 2015 23:00:34 +0000 (01:00 +0200)
app-admin/mcelog/Manifest
app-admin/mcelog/mcelog-122.ebuild [new file with mode: 0644]

index 65422f6379be3c83807d62d2334916a50be8593f..0d3a11cd9b532791a90c7b63f207e3a5b9ce315a 100644 (file)
@@ -1,2 +1,3 @@
 DIST mcelog-100.tar.gz 288423 SHA256 b18f029ec9f498b6249b3a3dfef7753ac9d45ebf3382af452cb3e14d49274bab SHA512 efd7864daaafe5d149fc27259d4fa72221372842d41ad57c046c967fd1eb710ef921f45111e95bfe76df119276b3b9af1bf1094a9411037eb1f5ac06e319e87d WHIRLPOOL 9f2f7fdbb3c94b7740f486005641a90529e240c34f3709989e6e0d448c96369f4562408aa678ea992f47f396cdfb60c71eadf75475c52ff0cd6318a99c4ad2eb
 DIST mcelog-117.tar.gz 296068 SHA256 0e0422e8693e4592a85ed344738004dcedcd930234ab862b0bdcb6ae7aa44f2b SHA512 664e4d9224ec1878153561bebdf4f6c58ea44cf0d494a04eb38cdd73cc8158fabdb0b4823f2303e39818f104298208206dfb9ff64ef13654dadfb5e7a4f5e723 WHIRLPOOL 1919bb2069f216d6a649c883bb9a9417edc9b51d639a73a81f5d5a8d06d874447dc839401858b1d402bbed588077dab93273d012768cb5d1b3fff3ec378d662e
+DIST mcelog-122.tar.gz 296366 SHA256 bfdffa82044a4e712ee9570b737169d900bbf53b0a1ea4c9a244b327f8987107 SHA512 895c5263d5632db446edb871d5ec84df75604572c1522f5d457eadaa05edc9a46c761708344a744b460bac5a82f2e52802280c0e6369f34ecd7f50abc6d15c70 WHIRLPOOL e43194b836623fbc268b51494ed3abe9e9cf67e5bd5c1134427f7ae67a30ccb321b971f211b68718a00e85c0c2382b462d59cc598b8c290685708f05b1c631f7
diff --git a/app-admin/mcelog/mcelog-122.ebuild b/app-admin/mcelog/mcelog-122.ebuild
new file mode 100644 (file)
index 0000000..f46ca0c
--- /dev/null
@@ -0,0 +1,53 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit linux-info eutils systemd toolchain-funcs
+
+DESCRIPTION="A tool to log and decode Machine Check Exceptions"
+HOMEPAGE="http://mcelog.org/"
+SRC_URI="https://github.com/andikleen/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="selinux"
+
+RDEPEND="selinux? ( sec-policy/selinux-mcelog )"
+
+CONFIG_CHECK="~X86_MCE"
+
+# TODO: add mce-inject to the tree to support test phase
+RESTRICT="test"
+
+src_prepare() {
+       epatch "${FILESDIR}"/${PN}-0.8_pre1-timestamp-${PN}.patch \
+               "${FILESDIR}"/${PN}-1.0_pre3_p20120918-build.patch \
+               "${FILESDIR}"/${PN}-1.0_pre3_p20120918-bashism.patch
+       tc-export CC
+}
+
+src_install() {
+       default
+
+       insinto /etc/cron.daily
+       newins ${PN}.cron ${PN}
+
+       insinto /etc/logrotate.d/
+       newins ${PN}.logrotate ${PN}
+
+       newinitd "${FILESDIR}"/${PN}.init-r1 ${PN}
+       systemd_dounit "${FILESDIR}"/${PN}.service
+
+       dodoc *.pdf
+}
+
+pkg_postinst() {
+       einfo "The default configuration set is now installed in /etc/${PN}"
+       einfo "you might want to edit those files."
+       einfo
+       einfo "A sample cronjob is installed into /etc/cron.daily"
+       einfo "without executable bit (system service is the preferred method now)"
+}