dev-ml/ppx_enumerate: Bump to 0.9.0
authorAlexis Ballier <aballier@gentoo.org>
Sat, 1 Apr 2017 16:40:47 +0000 (18:40 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Sun, 2 Apr 2017 08:37:58 +0000 (10:37 +0200)
Package-Manager: Portage-2.3.5, Repoman-2.3.2

dev-ml/ppx_enumerate/Manifest
dev-ml/ppx_enumerate/files/oc43.patch [deleted file]
dev-ml/ppx_enumerate/ppx_enumerate-0.9.0.ebuild [new file with mode: 0644]
dev-ml/ppx_enumerate/ppx_enumerate-113.33.00.ebuild [deleted file]

index 0e9288aa18d17411ad48b6ca6996a227eaf9bfdc..d43aff91a37f23eacd320e2f3cf6bce027b41618 100644 (file)
@@ -1 +1 @@
-DIST ppx_enumerate-113.33.00.tar.gz 56173 SHA256 9eaa3804b1553594d3422bc86aecd13b91a69b879b8e2a826a2862beb4e91973 SHA512 9792f991a570a7a636ca528e4ff400cde147a8a034e54dda853b9df677aa3a7e8d2c570045c11d4beb3ce6ef827116a65f8ac0ceda969b53fb99dbba8ce99bf9 WHIRLPOOL 416690f9f7153bacbb086fe1ab3394585b4be878f4be1e706df11bdcfba6471ee6d724b89ba9b2880c1c74a9e3486ff8b5e59d8608e1d445c1b082dd60fbd244
+DIST ppx_enumerate-0.9.0.tar.gz 10967 SHA256 294cf49af97bfae335f7edbe64eb0e97bda736af949ff57ca9c4d195e54e9dfb SHA512 46e979528af75313fcbfee4d1437156ded90d46f7608271a77ad41bb7e087e2ea4f61f534624b23679c4edf812d2fcfe26b9b634c3fcb691e2da2388ae04950c WHIRLPOOL 6c33184295d1f8e4d13dc5d619b3d9df3981e8e7f8042e129b316f4cfab2a0ef8224eca7b716bec68d75bf86bf4027eded73a035c02e2bacc95ec49ea18f1785
diff --git a/dev-ml/ppx_enumerate/files/oc43.patch b/dev-ml/ppx_enumerate/files/oc43.patch
deleted file mode 100644 (file)
index b04635f..0000000
+++ /dev/null
@@ -1,40 +0,0 @@
-diff -uNr ppx_enumerate-113.33.00/_oasis ppx_enumerate-113.33.00+4.03/_oasis
---- ppx_enumerate-113.33.00/_oasis     2016-03-09 16:44:54.000000000 +0100
-+++ ppx_enumerate-113.33.00+4.03/_oasis        2016-03-22 15:13:50.000000000 +0100
-@@ -1,8 +1,8 @@
- OASISFormat:      0.4
--OCamlVersion:     >= 4.02.3
-+OCamlVersion:     >= 4.03.0
- FindlibVersion:   >= 1.3.2
- Name:             ppx_enumerate
--Version:          113.33.00
-+Version:          113.33.00+4.03
- Synopsis:         Generate a list containing all values of a finite type
- Authors:          Jane Street Group, LLC <opensource@janestreet.com>
- Copyrights:       (C) 2015-2016 Jane Street Group LLC <opensource@janestreet.com>
-diff -uNr ppx_enumerate-113.33.00/opam ppx_enumerate-113.33.00+4.03/opam
---- ppx_enumerate-113.33.00/opam       2016-03-18 12:08:01.000000000 +0100
-+++ ppx_enumerate-113.33.00+4.03/opam  2016-03-22 17:51:36.000000000 +0100
-@@ -16,4 +16,4 @@
-   "ppx_tools"     {>= "0.99.3"}
-   "ppx_type_conv"
- ]
--available: [ ocaml-version >= "4.02.3" ]
-+available: [ ocaml-version >= "4.03.0" ]
-diff -uNr ppx_enumerate-113.33.00/src/ppx_enumerate.ml ppx_enumerate-113.33.00+4.03/src/ppx_enumerate.ml
---- ppx_enumerate-113.33.00/src/ppx_enumerate.ml       2016-03-09 16:44:54.000000000 +0100
-+++ ppx_enumerate-113.33.00+4.03/src/ppx_enumerate.ml  2016-03-22 15:13:50.000000000 +0100
-@@ -226,10 +226,11 @@
- and constructor_case loc cd =
-   match cd.pcd_args with
--  | [] -> [%expr [ [%e econstruct cd None ] ] ]
--  | tps ->
-+  | Pcstr_tuple [] -> [%expr [ [%e econstruct cd None ] ] ]
-+  | Pcstr_tuple tps ->
-     product loc tps (fun x ->
-       econstruct cd (Some (pexp_tuple ~loc x)))
-+  | Pcstr_record _ -> failwith "Pcstr_record not supported"
- and product loc tps f =
-     let all = List.map tps ~f:(fun tp -> enum ~main_type:tp tp) in
diff --git a/dev-ml/ppx_enumerate/ppx_enumerate-0.9.0.ebuild b/dev-ml/ppx_enumerate/ppx_enumerate-0.9.0.ebuild
new file mode 100644 (file)
index 0000000..7e943ef
--- /dev/null
@@ -0,0 +1,32 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="Generate a list containing all values of a finite type"
+HOMEPAGE="https://github.com/janestreet/ppx_enumerate"
+SRC_URI="https://github.com/janestreet/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-lang/ocaml:=
+       dev-ml/ppx_core:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_metaquot:=
+       dev-ml/ppx_type_conv:=
+       dev-ml/ocaml-migrate-parsetree:=
+"
+RDEPEND="${DEPEND}"
+DEPEND="${DEPEND} dev-ml/opam dev-ml/jbuilder"
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+}
diff --git a/dev-ml/ppx_enumerate/ppx_enumerate-113.33.00.ebuild b/dev-ml/ppx_enumerate/ppx_enumerate-113.33.00.ebuild
deleted file mode 100644 (file)
index 5f291ae..0000000
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit oasis
-
-DESCRIPTION="Generate a list containing all values of a finite type"
-HOMEPAGE="http://www.janestreet.com/ocaml"
-SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0/${PV}"
-KEYWORDS="~amd64"
-IUSE=""
-
-DEPEND="dev-ml/ppx_tools:=
-       dev-ml/ppx_core:=
-       dev-ml/ppx_type_conv:=
-"
-RDEPEND="${DEPEND}"
-DEPEND="${DEPEND} dev-ml/opam"
-
-src_prepare() {
-       has_version '>=dev-lang/ocaml-4.03' && epatch "${FILESDIR}/oc43.patch"
-}
-
-src_configure() {
-       emake setup.exe
-       OASIS_SETUP_COMMAND="./setup.exe" oasis_src_configure
-}
-
-src_compile() {
-       emake
-}
-
-src_install() {
-       opam-installer -i \
-               --prefix="${ED}/usr" \
-               --libdir="${D}/$(ocamlc -where)" \
-               --docdir="${ED}/usr/share/doc/${PF}" \
-               ${PN}.install || die
-       dodoc CHANGES.md
-}