dev-ruby/actionpack: add fix timezone tests
authorHans de Graaff <graaff@gentoo.org>
Mon, 27 Apr 2020 05:00:56 +0000 (07:00 +0200)
committerHans de Graaff <graaff@gentoo.org>
Mon, 27 Apr 2020 07:15:49 +0000 (09:15 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/actionpack/actionpack-5.2.4.2.ebuild
dev-ruby/actionpack/actionpack-6.0.2.2.ebuild

index 7a0a34f9e5bddd5242b6623b10bdb747b2ec2f2e..92a68b49adb7df604f62217f9169735eb3acacdc 100644 (file)
@@ -57,4 +57,7 @@ all_ruby_prepare() {
                -e '1i gem "actionview", "~> 5.2.0"' \
                -e '1i gem "railties", "~> 5.2.0"' \
                -i test/abstract_unit.rb || die
+
+       # Use different timezone notation, this changed at some point due to an external dependency changing.
+       sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
 }
index f22c41d0d073adc537e610459b2e6fc5ac8f90cf..4de989d426cce1b50fb860cad6f29c3abf56576f 100644 (file)
@@ -52,4 +52,7 @@ all_ruby_prepare() {
                -e '/:job/,/end/ s:^:#:' \
                -e '/group :doc/,/^end/ s:^:#:' ../Gemfile || die
        rm ../Gemfile.lock || die
+
+       # Use different timezone notation, this changed at some point due to an external dependency changing.
+       sed -i -e 's/-0000/GMT/' test/dispatch/response_test.rb test/dispatch/cookies_test.rb test/dispatch/session/cookie_store_test.rb || die
 }