dev-python/mysql-connector-python: remove vulnerable version
authorVirgil Dupras <vdupras@gentoo.org>
Mon, 16 Jul 2018 13:34:27 +0000 (09:34 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Mon, 16 Jul 2018 13:43:18 +0000 (09:43 -0400)
Bug: https://bugs.gentoo.org/635616
Package-Manager: Portage-2.3.40, Repoman-2.3.9

dev-python/mysql-connector-python/Manifest
dev-python/mysql-connector-python/mysql-connector-python-2.1.4.ebuild [deleted file]

index ba2fcc8372cee2863900eae4d81cc60c0993e4f7..8f82b30b7a10b69582d7105f40feb0aa4c79c8f4 100644 (file)
@@ -1,2 +1 @@
-DIST mysql-connector-python-2.1.4.tar.gz 11766506 BLAKE2B 41ba6a4515e20de6cfc876ec770b382347881fbd521ed68f09e287be91ababd06544edde7302fa6ab1e9b0f05dd04d2bfe06c5d2c9cb00c8c2f262a4d73a67e2 SHA512 1071c4b3d0e30dd90cb1ed7d6376a7dd688f16b285ab28c26eccd182a3b3c5bb3c36890aec38b037ccf70e2c2ae24a9013139c7ca71e69ae8e9e29f2c15204d9
 DIST mysql-connector-python-2.1.7.tar.gz 11781659 BLAKE2B 332092059a32249e449f99540beb9eebf80e9381cef4560208412a19385894eb2193f02d5a20aceafe9644b8a225926a02d57c3acc89ba7d321b6d0f9c7c4d76 SHA512 f88c3a6dd3c3c1cd5c16165daef801dbcc7ea9163406273dd751e25687a57dcdf4ffbcdb65bb107e8cd9d7c91029823f625dc19ab34116398263fa074598880a
diff --git a/dev-python/mysql-connector-python/mysql-connector-python-2.1.4.ebuild b/dev-python/mysql-connector-python/mysql-connector-python-2.1.4.ebuild
deleted file mode 100644 (file)
index 06dbeac..0000000
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-inherit distutils-r1
-
-DESCRIPTION="Python client library for MariaDB/MySQL"
-HOMEPAGE="https://dev.mysql.com/downloads/connector/python/"
-SRC_URI="https://dev.mysql.com/get/Downloads/Connector-Python/${P}.tar.gz"
-
-KEYWORDS="~amd64 ~arm ~x86"
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="examples test"
-
-# tests/mysqld.py does not like MariaDB version strings.
-# See the regex MySQLServerBase._get_version.
-DEPEND="test? ( dev-db/mysql[server(+)] )"
-
-# Tests currently fail.
-# mysql.connector.errors.DatabaseError: 1300 (HY000): Invalid utf8 character string: ''
-RESTRICT="test"
-
-DOCS=( README.txt CHANGES.txt docs/README_DOCS.txt )
-
-python_test() {
-       "${EPYTHON}" unittests.py --with-mysql="${EPREFIX}/usr" --unix-socket="${T}"
-}
-
-python_install_all(){
-       distutils-r1_python_install_all
-       if use examples ; then
-               dodoc -r examples
-       fi
-}