app-arch/lzma: verion bump to 19.00
authorHans Fernhout <hfern@fernhout.info>
Sun, 17 May 2020 06:02:33 +0000 (08:02 +0200)
committerAaron Bauman <bman@gentoo.org>
Sun, 17 May 2020 15:48:35 +0000 (11:48 -0400)
Package seems up for grabs; added myself as proxy maintainer

Closes: https://bugs.gentoo.org/708602

Signed-off-by: Johannes Willem Fernhout <hfern@fernhout.info>
Closes: https://github.com/gentoo/gentoo/pull/15845
Signed-off-by: Aaron Bauman <bman@gentoo.org>
app-arch/lzma/Manifest
app-arch/lzma/lzma-19.00.ebuild [new file with mode: 0644]
app-arch/lzma/metadata.xml

index 2afecb38ea1ebbb938d8e2dc5f6002b387cbca0d..c69705b2f6a30e624d9058c9afdf28badfa171ec 100644 (file)
@@ -1 +1,2 @@
+DIST lzma-19.00.7z 1082692 BLAKE2B 88aca3f3225d589c9b1b0fbf4c196db8e6e8df362f926736a45e1f80d302c132b25537203b0a903da9de5f3b0398b10901f126cf6905fcbdf0a57ee894e74b6d SHA512 60532483249d86960d5c481dc88ebeafabb7e435afb6188bc26f38177b8534ef3da83317d6920d99103d4f10a8dcdb624489ea5ddad8e0c8732bab1bb4ebd7eb
 DIST lzma-9.20.tar.bz2 534077 BLAKE2B c1be526d6fb9f68da10b654940a92420b6c708c7aefe213394cf1c7650b3d65c4f54d3ca0663e52be13aa9f996ff9cc87262fac8b76dd0654e839cefc073c374 SHA512 1c495530834107430a675fb48c006093edc301ec7a2c2f273efd62ff260f3056503bb2c3ddef63e82f5ff04b1347381055cf6cacd59eee9d451c4d841c13cd35
diff --git a/app-arch/lzma/lzma-19.00.ebuild b/app-arch/lzma/lzma-19.00.ebuild
new file mode 100644 (file)
index 0000000..491acc8
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}${PV//.}"
+DESCRIPTION="LZMA Stream Compressor from the SDK"
+HOMEPAGE="https://www.7-zip.org/sdk.html"
+SRC_URI="mirror://sourceforge/sevenzip/${MY_P}.7z -> ${P}.7z"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="doc"
+
+BDEPEND="app-arch/p7zip"
+
+S=${WORKDIR}
+
+src_compile() {
+       cd CPP/7zip/Bundles/LzmaCon || die
+       emake -f makefile.gcc \
+               CXX="$(tc-getCXX) ${CXXFLAGS} ${CPPFLAGS}" \
+               CXX_C="$(tc-getCC) ${CFLAGS} ${CPPFLAGS}"
+}
+
+src_install() {
+       newbin CPP/7zip/Bundles/LzmaCon/lzma lzmacon
+       dodoc DOC/lzma.txt DOC/lzma-history.txt
+       use doc && dodoc DOC/7zC.txt \
+               DOC/7zFormat.txt \
+               DOC/Methods.txt  \
+               DOC/lzma-sdk.txt \
+               DOC/lzma-specification.txt
+}
+
+pkg_postinst() {
+       einfo "The lzma binary is now 'lzmacon' to avoid xz-utils conflicts #218459"
+}
index 86f4ac1ea62b35ed1c21bdfad0a14d8480ee8dce..3a5f1e16e76639d55b9e23509ca6d1236148ec1f 100644 (file)
@@ -1,8 +1,15 @@
 <?xml version="1.0" encoding="UTF-8"?>
 <!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
 <pkgmetadata>
-  <!-- maintainer-needed -->
-  <upstream>
-    <remote-id type="sourceforge">sevenzip</remote-id>
-  </upstream>
+       <maintainer type="person">
+               <email>hfern@fernhout.info</email>
+               <name>Hans Fernhout</name>
+       </maintainer>
+       <maintainer type="project">
+               <email>proxy-maint@gentoo.org</email>
+               <name>Proxy Maintainers</name>
+       </maintainer> 
+       <upstream>
+               <remote-id type="sourceforge">sevenzip</remote-id>
+       </upstream>
 </pkgmetadata>