sys-devel/libtool: mark 2.4.6-r2 arm64/m68k/s390/sh stable
authorMike Frysinger <vapier@gentoo.org>
Tue, 21 Feb 2017 22:35:16 +0000 (17:35 -0500)
committerMike Frysinger <vapier@gentoo.org>
Tue, 21 Feb 2017 22:45:17 +0000 (17:45 -0500)
sys-devel/libtool/libtool-2.4.6-r2.ebuild
sys-devel/libtool/libtool-2.4.6.ebuild [deleted file]

index 7f0bb80477247567567d6239811da1a20066678b..6b50e643998a178a75dcadd6aa8afbb7783dce2b 100644 (file)
@@ -14,7 +14,7 @@ if [[ ${PV} == "9999" ]] ; then
        inherit git-2
 else
        SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-       KEYWORDS="alpha amd64 arm ~arm64 hppa ia64 ~m68k ~mips ppc ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+       KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
 fi
 
 DESCRIPTION="A shared library tool for developers"
diff --git a/sys-devel/libtool/libtool-2.4.6.ebuild b/sys-devel/libtool/libtool-2.4.6.ebuild
deleted file mode 100644 (file)
index 71a9b47..0000000
+++ /dev/null
@@ -1,77 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Id$
-
-EAPI="4"
-
-LIBTOOLIZE="true" #225559
-WANT_LIBTOOL="none"
-inherit eutils autotools multilib unpacker
-
-if [[ ${PV} == "9999" ]] ; then
-       EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
-               http://git.savannah.gnu.org/r/${PN}.git"
-       inherit git-2
-else
-       SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
-       KEYWORDS="alpha amd64 arm arm64 hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
-fi
-
-DESCRIPTION="A shared library tool for developers"
-HOMEPAGE="https://www.gnu.org/software/libtool/"
-
-LICENSE="GPL-2"
-SLOT="2"
-IUSE="vanilla"
-
-# Pull in libltdl directly until we convert packages to the new dep.
-RDEPEND="sys-devel/gnuconfig
-       >=sys-devel/autoconf-2.69
-       >=sys-devel/automake-1.13
-       dev-libs/libltdl:0"
-DEPEND="${RDEPEND}
-       app-arch/xz-utils"
-[[ ${PV} == "9999" ]] && DEPEND+=" sys-apps/help2man"
-
-src_unpack() {
-       if [[ ${PV} == "9999" ]] ; then
-               git-2_src_unpack
-               cd "${S}"
-               ./bootstrap || die
-       else
-               unpacker_src_unpack
-       fi
-}
-
-src_prepare() {
-       use vanilla && return 0
-
-       epatch "${FILESDIR}"/${PN}-2.4.3-use-linux-version-in-fbsd.patch #109105
-       pushd libltdl >/dev/null
-       AT_NOELIBTOOLIZE=yes eautoreconf
-       popd >/dev/null
-       AT_NOELIBTOOLIZE=yes eautoreconf
-       epunt_cxx
-}
-
-src_configure() {
-       # the libtool script uses bash code in it and at configure time, tries
-       # to find a bash shell.  if /bin/sh is bash, it uses that.  this can
-       # cause problems for people who switch /bin/sh on the fly to other
-       # shells, so just force libtool to use /bin/bash all the time.
-       export CONFIG_SHELL=/bin/bash
-       ECONF_SOURCE=${S} econf --disable-ltdl-install
-}
-
-src_test() {
-       emake check
-}
-
-src_install() {
-       default
-
-       local x
-       while read -d $'\0' -r x ; do
-               ln -sf "${EPREFIX}"/usr/share/gnuconfig/${x##*/} "${x}" || die
-       done < <(find "${ED}" '(' -name config.guess -o -name config.sub ')' -print0)
-}