app-emulation/fs-uae-launcher: New package for launching fs-uae
authorJames Le Cuirot <chewi@gentoo.org>
Sat, 20 Apr 2019 10:04:28 +0000 (11:04 +0100)
committerJames Le Cuirot <chewi@gentoo.org>
Sat, 20 Apr 2019 10:04:28 +0000 (11:04 +0100)
Closes: https://bugs.gentoo.org/403913
Package-Manager: Portage-2.3.64, Repoman-2.3.12
Signed-off-by: James Le Cuirot <chewi@gentoo.org>
app-emulation/fs-uae-launcher/Manifest [new file with mode: 0644]
app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-German-ROMs.patch [new file with mode: 0644]
app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild [new file with mode: 0644]
app-emulation/fs-uae-launcher/metadata.xml [new file with mode: 0644]

diff --git a/app-emulation/fs-uae-launcher/Manifest b/app-emulation/fs-uae-launcher/Manifest
new file mode 100644 (file)
index 0000000..694c0d6
--- /dev/null
@@ -0,0 +1 @@
+DIST fs-uae-launcher-2.8.3.tar.gz 8784242 BLAKE2B e54f73efde6563d9e4ab6b4f57cc73bca80d72d0ded4db67edc53dc344685889abf485df067541e8d635595ac5457ec456ded0306310b1ad95a3b3ef07e53bc3 SHA512 4eaa5979fe2e8f2c792d4878e9a9ad0a0433206aac42aa380d97aee21e4ba29a54caced2437b83357c2c4d2fab121bfb821fdb8a883ead971766866b02067a2d
diff --git a/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-German-ROMs.patch b/app-emulation/fs-uae-launcher/files/fs-uae-launcher-2.8.3-German-ROMs.patch
new file mode 100644 (file)
index 0000000..41843d5
--- /dev/null
@@ -0,0 +1,21 @@
+--- a/fsgs/amiga/roms.py       2017-07-06 16:50:33.351036624 +0200
++++ b/fsgs/amiga/roms.py       2017-07-06 16:52:58.335040977 +0200
+@@ -11,6 +11,8 @@
+     # Kickstart v1.3 r34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[!]
+     # Kickstart v1.3 r34.5 (1987)(Commodore)(A500-A1000-A2000-CDTV)[o] (patch)
+     "891e9a547772fe0c6c19b610baf8bc4ea7fcb785",
++    # kick13.rom - from Upgrade Commodore Amiga 500 (1989)
++    "90933936cce43ca9bc6bf375662c076b27e3c458",
+ ]
+ A500P_KICKSTARTS = [
+@@ -55,6 +57,9 @@
+     # Kickstart v3.1 r40.68 (1993)(Commodore)(A4000)[h Cloanto]
+     # "c3c481160866e60d085e436a24db3617ff60b5f9",
++
++    # Kickstart v3.1 r40.10 (15.7.93) from german A4000
++    "3b7f1493b27e212830f989f26ca76c02049f09ca",
+ ]
+ CD32_KICKSTARTS = [
diff --git a/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild b/app-emulation/fs-uae-launcher/fs-uae-launcher-2.8.3.ebuild
new file mode 100644 (file)
index 0000000..8a1bab4
--- /dev/null
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="PyQt5-based launcher for FS-UAE"
+HOMEPAGE="https://fs-uae.net/"
+SRC_URI="https://fs-uae.net/stable/${PV}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="lha"
+
+RDEPEND="
+       app-emulation/fs-uae
+       dev-python/pyopengl[${PYTHON_USEDEP}]
+       dev-python/PyQt5[${PYTHON_USEDEP},gui]
+       dev-python/six[${PYTHON_USEDEP}]
+       lha? ( dev-python/python-lhafile[${PYTHON_USEDEP}] )
+"
+
+DEPEND="
+       sys-devel/gettext
+"
+
+PATCHES=(
+       "${FILESDIR}"/${P}-German-ROMs.patch
+)
+
+src_prepare() {
+       default
+
+       # Unbundle some libraries. Keep oyoyo IRC library because upstream
+       # is long dead and it's not worth packaging separately.
+       rm -r {OpenGL,six}/ || die
+       sed -i -r "/OpenGL|six/d" setup.py || die
+}
+
+src_compile() {
+       emake
+}
+
+src_install() {
+       local dir=${EPREFIX}/usr/share/${PN}
+       distutils-r1_python_install --install-lib="${dir}" --install-scripts="${dir}"
+       dosym ../share/${PN}/${PN} /usr/bin/${PN}
+
+       emake install-data DESTDIR="${D}" prefix="${EPREFIX}"/usr
+       mv "${ED}"/usr/share/doc/{${PN},${PF}} || die
+}
+
+pkg_postinst() {
+       elog "Some important information:"
+       elog
+       ewarn " - Do not use QtCurve, it will crash PyQt5!"
+       elog
+       elog " - By default, FS-UAE creates its directories under Documents/FS-UAE."
+       elog "   If your Documents directory is not configured according to the XDG"
+       elog "   user diretory spec, ~/FS-UAE will be used as a fallback."
+       elog
+       elog " - You can override this by putting the path to the desired base"
+       elog "   directory in a special config file. The config file will be read"
+       elog "   from ~/.config/fs-uae/base-dir by both FS-UAE and FS-UAE Launcher"
+       elog "   if it exists."
+       elog
+       elog "   Alternatively, you can start FS-UAE and/or FS-UAE Launcher with"
+       elog "   --base-dir=/path/to/desired/dir"
+}
+
+pkg_postinst() { xdg_icon_cache_update; }
+pkg_postrm() { xdg_icon_cache_update; }
diff --git a/app-emulation/fs-uae-launcher/metadata.xml b/app-emulation/fs-uae-launcher/metadata.xml
new file mode 100644 (file)
index 0000000..84e4eb5
--- /dev/null
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="person">
+               <email>chewi@gentoo.org</email>
+               <name>James Le Cuirot</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">FrodeSolheim/fs-uae-launcher</remote-id>
+       </upstream>
+       <use>
+               <flag name="lha">Enable LHA archive support</flag>
+       </use>
+</pkgmetadata>