dev-python/pytest-timeout: Add missing test-dep on pexpect
authorMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 10:51:04 +0000 (12:51 +0200)
committerMichał Górny <mgorny@gentoo.org>
Wed, 29 Apr 2020 11:02:54 +0000 (13:02 +0200)
Closes: https://bugs.gentoo.org/719998
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/pytest-timeout/pytest-timeout-1.3.4.ebuild

index 1fe275fe54260479850ad8c6b95fd9297e631493..8f63704bdd235eb41397501d600b3e215216da18 100644 (file)
@@ -15,8 +15,15 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
 SLOT="0"
 LICENSE="MIT"
 KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
 
 RDEPEND="dev-python/pytest[${PYTHON_USEDEP}]"
+BDEPEND="
+       test? (
+               ${RDEPEND}
+               dev-python/pexpect[${PYTHON_USEDEP}]
+       )"
 
 python_test() {
        distutils_install_for_testing