(#130590) Ensure that the old XKB directory gets out of the way (Patrick Allaert).
authorDonnie Berkholz <dberkholz@gentoo.org>
Wed, 21 Jun 2006 05:48:51 +0000 (05:48 +0000)
committerDonnie Berkholz <dberkholz@gentoo.org>
Wed, 21 Jun 2006 05:48:51 +0000 (05:48 +0000)
Package-Manager: portage-2.1.1_pre1-r1

x11-misc/xkbdata/ChangeLog
x11-misc/xkbdata/xkbdata-1.0.1.ebuild
x11-misc/xkeyboard-config/ChangeLog
x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild

index 57f459684e9b0a5127a9a703f02f92c68814af03..71b16fdf579bdccfcd042df25fc6e72cdbf33cb5 100644 (file)
@@ -1,6 +1,10 @@
 # ChangeLog for x11-misc/xkbdata
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbdata/ChangeLog,v 1.18 2006/02/14 22:54:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbdata/ChangeLog,v 1.19 2006/06/21 05:48:51 spyderous Exp $
+
+  21 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>; xkbdata-1.0.1.ebuild:
+  (#130590) Ensure that the old XKB directory gets out of the way (Patrick
+  Allaert).
 
   14 Feb 2006; Markus Rothe <corsair@gentoo.org> xkbdata-1.0.1.ebuild:
   Added ~ppc64
index 0e122605aab1db35264471db8aa5b6b63fd9badd..6f8f9f7423c97865bfe4cf832dfb32c075f775f0 100644 (file)
@@ -1,6 +1,6 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbdata/xkbdata-1.0.1.ebuild,v 1.5 2006/02/14 22:54:59 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkbdata/xkbdata-1.0.1.ebuild,v 1.6 2006/06/21 05:48:51 spyderous Exp $
 
 # Must be before x-modular eclass is inherited
 #SNAPSHOT="yes"
@@ -13,6 +13,16 @@ RDEPEND="x11-apps/xkbcomp
        !x11-misc/xkeyboard-config"
 DEPEND="${RDEPEND}"
 
+pkg_setup() {
+       # (#130590) The old XKB directory can screw stuff up
+       local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+       if [[ -d ${DIR} ]] ; then
+               eerror "Directory ${DIR} should be"
+               eerror "manually deleted/renamed/relocated before installing!"
+               die "Manually remove ${DIR}"
+       fi
+}
+
 src_install() {
        x-modular_src_install
        keepdir /var/lib/xkb
index 838c8db9f87facb32ea401acc0c3c57408702e02..5e72fb0e66b0ad018c3d0ec1b276b96ea7d198a6 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for x11-misc/xkeyboard-config
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.11 2006/04/16 20:51:44 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/ChangeLog,v 1.12 2006/06/21 05:47:21 spyderous Exp $
+
+  21 Jun 2006; Donnie Berkholz <spyderous@gentoo.org>;
+  xkeyboard-config-0.8.ebuild:
+  (#130590) Ensure that the old XKB directory gets out of the way (Patrick
+  Allaert).
 
 *xkeyboard-config-0.8 (16 Apr 2006)
 
index 5978beca25864be986866285ba44183fb95047d5..de3c9c680d66a009c64d787b393d23b878f07d36 100644 (file)
@@ -1,8 +1,8 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.1 2006/04/16 20:51:44 spyderous Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xkeyboard-config/xkeyboard-config-0.8.ebuild,v 1.2 2006/06/21 05:47:21 spyderous Exp $
 
-inherit eutils
+inherit eutils multilib
 
 DESCRIPTION="X keyboard configuration database"
 KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
@@ -15,6 +15,16 @@ RDEPEND="x11-apps/xkbcomp
 DEPEND="${RDEPEND}
        dev-perl/XML-Parser"
 
+pkg_setup() {
+       # (#130590) The old XKB directory can screw stuff up
+       local DIR="${ROOT}usr/$(get_libdir)/X11/xkb"
+       if [[ -d ${DIR} ]] ; then
+               eerror "Directory ${DIR} should be"
+               eerror "manually deleted/renamed/relocated before installing!"
+               die "Manually remove ${DIR}"
+       fi
+}
+
 src_compile() {
        econf \
                --with-xkb-base=/usr/share/X11/xkb \