2.1.1_pre1-r1 revbump
authorZac Medico <zmedico@gentoo.org>
Sun, 18 Jun 2006 04:36:01 +0000 (04:36 +0000)
committerZac Medico <zmedico@gentoo.org>
Sun, 18 Jun 2006 04:36:01 +0000 (04:36 +0000)
Package-Manager: portage-2.1.1_pre1-r1

sys-apps/portage/ChangeLog
sys-apps/portage/files/digest-portage-2.1.1_pre1-r1 [new file with mode: 0644]
sys-apps/portage/portage-2.1.1_pre1-r1.ebuild [new file with mode: 0644]

index 86d0e4b833547082ffdb238d60d27511405b9cf3..8523d99582884bfd6b81606555065a7f5f2ac88a 100644 (file)
@@ -1,6 +1,11 @@
 # ChangeLog for sys-apps/portage
 # Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.180 2006/06/16 16:46:28 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/ChangeLog,v 1.181 2006/06/18 04:36:01 zmedico Exp $
+
+*portage-2.1.1_pre1-r1 (18 Jun 2006)
+
+  18 Jun 2006; Zac Medico <zmedico@gentoo.org> +portage-2.1.1_pre1-r1.ebuild:
+  2.1.1_pre1-r1 revbump.  This fixes bugs #136818, #137032, and #137105.
 
 *portage-2.1.1_pre1 (16 Jun 2006)
 
diff --git a/sys-apps/portage/files/digest-portage-2.1.1_pre1-r1 b/sys-apps/portage/files/digest-portage-2.1.1_pre1-r1
new file mode 100644 (file)
index 0000000..5af5672
--- /dev/null
@@ -0,0 +1,9 @@
+MD5 2a040e7312a8bd9393f31cec21859324 portage-2.1.1_pre1-r1.patch.bz2 4452
+RMD160 3970f09512a98808fbd5c683aa339c3901dbb681 portage-2.1.1_pre1-r1.patch.bz2 4452
+SHA256 6e6ca45b448e1852cfd2532d804025a6607abc2c2178b5bd7939c3e79e779490 portage-2.1.1_pre1-r1.patch.bz2 4452
+MD5 3dc4fb1d5bc1aac640b579e82db58dfd portage-2.1.1_pre1.tar.bz2 277982
+RMD160 41fc05479ba8774ad35939b6b5f597e559602f0e portage-2.1.1_pre1.tar.bz2 277982
+SHA256 de7d23e15681a6eff9199a505bc9bdf59a5a43d5c51e6223d6296659c1a0cc3e portage-2.1.1_pre1.tar.bz2 277982
+MD5 3a1c6f874490e12965812fa0920c539f portage-man-pl-2.1.tar.bz2 52425
+RMD160 5fdb898b94b0c6bb23234f0903572675f653ff44 portage-man-pl-2.1.tar.bz2 52425
+SHA256 7e01f6c9c567f81d8e81dfdc26cf04b8d1f9f375090641cb80580986f8ac4817 portage-man-pl-2.1.tar.bz2 52425
diff --git a/sys-apps/portage/portage-2.1.1_pre1-r1.ebuild b/sys-apps/portage/portage-2.1.1_pre1-r1.ebuild
new file mode 100644 (file)
index 0000000..01445a3
--- /dev/null
@@ -0,0 +1,184 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/portage/portage-2.1.1_pre1-r1.ebuild,v 1.1 2006/06/18 04:36:01 zmedico Exp $
+
+inherit toolchain-funcs eutils
+
+DESCRIPTION="The Portage Package Management System. The primary package management and distribution system for Gentoo."
+HOMEPAGE="http://www.gentoo.org/proj/en/portage/index.xml"
+LICENSE="GPL-2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc-macos ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+PROVIDE="virtual/portage"
+SLOT="0"
+# USE_EXPAND_HIDDEN hides ELIBC and USERLAND expansions from emerge output (see make.conf.5).
+IUSE_ELIBC="elibc_glibc elibc_uclibc elibc_FreeBSD"
+IUSE_USERLAND="userland_Darwin userland_GNU"
+IUSE="build doc selinux linguas_pl ${IUSE_ELIBC} ${IUSE_USERLAND}"
+DEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5 )"
+RDEPEND=">=dev-lang/python-2.3
+       !build? ( >=sys-apps/sed-4.0.5
+               dev-python/python-fchksum
+               userland_GNU? ( sys-apps/debianutils )
+               !userland_Darwin? ( >=app-shells/bash-3.0 )
+               userland_Darwin? ( >=app-shells/bash-2.05a ) )
+       elibc_glibc? ( sys-apps/sandbox )
+       elibc_uclibc? ( sys-apps/sandbox )
+       !userland_Darwin? ( >=app-misc/pax-utils-0.1.13 )
+       selinux? ( >=dev-python/python-selinux-2.16 )
+       doc? ( app-portage/portage-manpages )
+       >=dev-python/pycrypto-2.0.1-r5"
+SRC_ARCHIVES="http://dev.gentoo.org/~zmedico/portage/archives"
+PV_PL="2.1"
+SRC_URI="mirror://gentoo/${PN}-${PV}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-${PV}.tar.bz2
+       linguas_pl? ( mirror://gentoo/${PN}-man-pl-${PV_PL}.tar.bz2
+       ${SRC_ARCHIVES}/${PN}-man-pl-${PV_PL}.tar.bz2 )"
+
+if [ "${PR}" != "r0" ]; then
+       PATCHVER="-${PR}"
+       SRC_URI="${SRC_URI} mirror://gentoo/${PN}-${PV}${PATCHVER}.patch.bz2"
+fi
+
+S="${WORKDIR}"/${PN}-${PV}
+S_PL="${WORKDIR}"/${PN}-${PV_PL}
+
+portage_docs() {
+       einfo ""
+       einfo "For help with using portage please consult the Gentoo Handbook"
+       einfo "at http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=3"
+       einfo ""
+}
+
+src_unpack() {
+       unpack ${A}
+       if [ "${PR}" != "r0" ]; then
+               cd "${S}"
+               epatch "${WORKDIR}/${PN}-${PV}${PATCHVER}.patch"
+               einfo "Setting portage.VERSION to ${PVR} ..."
+               sed -i "s/^VERSION=.*/VERSION=\"${PVR}\"/" pym/portage.py || \
+                       die "Failed to patch portage.VERSION"
+               eend 0
+       fi
+}
+
+src_compile() {
+       cd "${S}"/src
+       $(tc-getCC) ${CFLAGS} ${LDFLAGS} -o tbz2tool tbz2tool.c || \
+               die "Failed to build tbz2tool"
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               chmod +x setup.py
+               ./setup.py build || die "Failed to install bsd-chflags module"
+       fi
+}
+
+src_install() {
+       local portage_base="/usr/lib/portage"
+       cd "${S}"/cnf
+       insinto /etc
+       doins etc-update.conf dispatch-conf.conf make.globals
+       if [ -f "make.conf.${ARCH}".diff ]; then
+               patch make.conf "make.conf.${ARCH}".diff || \
+                       die "Failed to patch make.conf.example"
+               newins make.conf make.conf.example
+       else
+               eerror ""
+               eerror "Portage does not have an arch-specific configuration for this arch."
+               eerror "Please notify the arch maintainer about this issue. Using generic."
+               eerror ""
+               newins make.conf make.conf.example
+       fi
+
+       if use elibc_FreeBSD; then
+               cd "${S}"/src/bsd-flags
+               ./setup.py install --root "${D}" || \
+                       die "Failed to install bsd-chflags module"
+       fi
+
+       dodir ${portage_base}/bin
+       exeinto ${portage_base}/bin
+       # BSD and OSX need a sed wrapper so that find/xargs work properly
+       if use userland_GNU; then
+               rm "${S}"/bin/sed || die "Failed to remove sed wrapper"
+       fi
+       cd "${S}"/bin
+       doexe *
+       doexe "${S}"/src/tbz2tool
+       dosym newins ${portage_base}/bin/donewins
+
+       for mydir in pym pym/cache pym/elog_modules; do
+               dodir ${portage_base}/${mydir}
+               insinto ${portage_base}/${mydir}
+               cd "${S}"/${mydir}
+               doins *.py
+       done
+
+       doman "${S}"/man/*.[0-9]
+       if use linguas_pl; then
+               doman -i18n=pl "${S_PL}"/man/pl/*.[0-9]
+               doman -i18n=pl_PL.UTF-8 "${S_PL}"/man/pl_PL.UTF-8/*.[0-9]
+       fi
+       dodoc "${S}"/ChangeLog
+       dodoc "${S}"/NEWS
+       dodoc "${S}"/RELEASE-NOTES
+
+       dodir /usr/bin
+       for x in ebuild emerge portageq repoman tbz2tool xpak; do
+               dosym ../lib/portage/bin/${x} /usr/bin/${x}
+       done
+
+       dodir /usr/sbin
+       local my_syms="archive-conf
+               dispatch-conf
+               emaint
+               emerge-webrsync
+               env-update
+               etc-update
+               fixpackages
+               quickpkg
+               regenworld"
+       local x
+       for x in ${my_syms}; do
+               dosym ../lib/portage/bin/${x} /usr/sbin/${x}
+       done
+
+       dodir /etc/portage
+       keepdir /etc/portage
+
+       doenvd "${FILESDIR}"/05portage.envd
+}
+
+pkg_preinst() {
+       local portage_base="/usr/lib/portage"
+       if has livecvsportage ${FEATURES} && [ "${ROOT}" = "/" ]; then
+               rm -rf "${IMAGE}"/${portage_base}/pym/*
+               mv "${IMAGE}"/${portage_base}/bin/tbz2tool "${T}"
+               rm -rf "${IMAGE}"/${portage_base}/bin/*
+               mv "${T}"/tbz2tool "${IMAGE}"/${portage_base}/bin/
+       else
+               for mydir in pym pym/cache pym/elog_modules; do
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyc >& /dev/null
+                       rm "${ROOT}"/${portage_base}/${mydir}/*.pyo >& /dev/null
+               done
+       fi
+}
+
+pkg_postinst() {
+       local x
+
+       if [ ! -f "${ROOT}/var/lib/portage/world" ] &&
+          [ -f "${ROOT}"/var/cache/edb/world ] &&
+          [ ! -h "${ROOT}"/var/cache/edb/world ]; then
+               mv "${ROOT}"/var/cache/edb/world "${ROOT}"/var/lib/portage/world
+               ln -s ../../lib/portage/world /var/cache/edb/world
+       fi
+
+       for x in "${ROOT}"/etc/._cfg????_make.globals; do
+               # Overwrite the globals file automatically.
+               [ -e "${x}" ] && mv -f "${x}" "${ROOT}etc/make.globals"
+       done
+
+       portage_docs
+}