app-arch/lbzip2: Run eautoreconf to fix tests
authorMatt Turner <mattst88@gentoo.org>
Fri, 21 Feb 2020 19:54:54 +0000 (11:54 -0800)
committerMatt Turner <mattst88@gentoo.org>
Fri, 21 Feb 2020 20:33:47 +0000 (12:33 -0800)
Closes: https://bugs.gentoo.org/708342
Signed-off-by: Matt Turner <mattst88@gentoo.org>
app-arch/lbzip2/lbzip2-2.5_p20181227-r1.ebuild

index ca3b9a2c4d92e8b4b50af634bb9538b68c3cc68f..fae4cd992c8d8010477eae6334e3c08035f9c0f9 100644 (file)
@@ -3,6 +3,8 @@
 
 EAPI="7"
 
+inherit autotools
+
 DESCRIPTION="Parallel bzip2 utility"
 HOMEPAGE="https://github.com/kjn/lbzip2/"
 SRC_URI="https://dev.gentoo.org/~whissi/dist/${PN}/${P}.tar.gz"
@@ -20,6 +22,11 @@ PATCHES=(
        "${FILESDIR}"/${P}-fix-unaligned.patch
 )
 
+src_prepare() {
+       default
+       eautoreconf
+}
+
 src_configure() {
        local myeconfargs=(
                --disable-silent-rules