sys-devel/parity: support x64; no more legacy MSVC by default
authorMichael Haubenwallner <haubi@gentoo.org>
Fri, 23 Aug 2019 14:52:34 +0000 (16:52 +0200)
committerMichael Haubenwallner <haubi@gentoo.org>
Fri, 23 Aug 2019 14:56:57 +0000 (16:56 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Michael Haubenwallner <haubi@gentoo.org>
sys-devel/parity/metadata.xml
sys-devel/parity/parity-9999.ebuild

index f6466ef21aa17e3cc72f3a77cd2d9c88d1f8c15a..b5ae82a3cc83b8c01559fbaa30d3133e709b30ae 100644 (file)
@@ -19,6 +19,7 @@
                <flag name="vc14_0">Enable support for Visual Studio 2015</flag>
                <flag name="vc15_0">Enable support for Visual Studio 2017</flag>
                <flag name="vc16_2">Enable support for Visual Studio 2019</flag>
+               <flag name="vc_x64">Enable support for 64bit Visual Studio compilers</flag>
                <flag name="vc_x86">Enable support for 32bit Visual Studio compilers</flag>
        </use>
 </pkgmetadata>
index 38577c8f86b1908cec0d38d3981df4ec593e080b..50ab4b1e491e86ce02ed81667b5ddce9ed31d34e 100644 (file)
@@ -14,14 +14,20 @@ fi
 DESCRIPTION="A POSIX to native Win32 Cross-Compiler Tool (requires Visual Studio)"
 HOMEPAGE="https://github.com/haubi/parity"
 
-parity-vcarchs() { echo x86 ; }
-parity-vcvers() { echo 7_0 7_1 8_0 9_0 10_0 11_0 12_0 14_0 15_0 16_2 ; }
+parity-vcarchs() { echo x64 x86 ; }
+parity-vcvers-legacy() { echo 7_0 7_1 8_0 9_0 ; }
+parity-vcvers-current() { echo 10_0 11_0 12_0 14_0 15_0 16_2 ; }
+parity-vcvers() {
+       parity-vcvers-legacy
+       parity-vcvers-current
+}
 
 LICENSE="LGPL-3"
 SLOT="0"
 IUSE="$(
        for a in $(parity-vcarchs); do echo "+vc_${a}"; done
-       for v in $(parity-vcvers); do echo "+vc${v}"; done
+       for v in $(parity-vcvers-legacy); do echo "vc${v}"; done
+       for v in $(parity-vcvers-current); do echo "+vc${v}"; done
 )"
 
 if [[ ${PV} == 9999 ]]; then