www-apps/cgisysinfo: removed -9999 logic. bump to eapi 7
authorRafael Martins <rafaelmartins@gentoo.org>
Mon, 23 Sep 2019 01:04:49 +0000 (03:04 +0200)
committerRafael Martins <rafaelmartins@gentoo.org>
Mon, 23 Sep 2019 01:10:52 +0000 (03:10 +0200)
Package-Manager: Portage-2.3.66, Repoman-2.3.11
Signed-off-by: Rafael Martins <rafaelmartins@gentoo.org>
www-apps/cgisysinfo/cgisysinfo-0.4.1.ebuild

index 0dc2dac982cdbe3f5aba90cf9f242ac709e2c692..15aea025958703ad7f03025a5b596d5214c3048c 100644 (file)
@@ -1,22 +1,11 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
-EAPI="5"
+EAPI="7"
 
 inherit autotools
 
-if [[ ${PV} = *9999* ]]; then
-       WANT_AUTOMAKE="1.10"
-       inherit git-r3
-       EGIT_REPO_URI="https://github.com/rafaelmartins/${PN}"
-       KEYWORDS=""
-       DOCS=( "README.md" "AUTHORS" "NEWS" )
-else
-       SRC_URI="https://github.com/rafaelmartins/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-       DOCS=( "README" "AUTHORS" "NEWS" )
-fi
-
+SRC_URI="https://github.com/rafaelmartins/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
 DESCRIPTION="A small cgi utility to show basic system information"
 HOMEPAGE="https://github.com/rafaelmartins/cgisysinfo"
 
@@ -24,10 +13,14 @@ LICENSE="GPL-2"
 SLOT="0"
 IUSE="fastcgi"
 
+KEYWORDS="~amd64 ~x86"
+DOCS=( "README" "AUTHORS" "NEWS" )
+
 DEPEND="fastcgi? ( dev-libs/fcgi )"
 RDEPEND="${DEPEND}"
 
 src_prepare() {
+       default
        eautoreconf
 }