app-emacs/google-c-style: New snapshot.
authorUlrich Müller <ulm@gentoo.org>
Fri, 23 Aug 2019 14:18:48 +0000 (16:18 +0200)
committerUlrich Müller <ulm@gentoo.org>
Fri, 23 Aug 2019 14:19:17 +0000 (16:19 +0200)
Package-Manager: Portage-2.3.71, Repoman-2.3.17
Signed-off-by: Ulrich Müller <ulm@gentoo.org>
app-emacs/google-c-style/Manifest
app-emacs/google-c-style/google-c-style-20140929.ebuild [new file with mode: 0644]

index e3711720f3a45d620cd5e528913343285eb15452..6624d86c74a4b7d757fe49992d91a6ad38ff0bb0 100644 (file)
@@ -1 +1,2 @@
 DIST google-c-style-20091009.tar.bz2 2178 BLAKE2B 72d7b430f9148589e8b4b1a57c9b4b96203c7ffddae3bbbc7aa9978e85c2c51510571f8617ac5d2bcaabe5688ed7799d5de597e96a2479d844a49e6661f93a05 SHA512 5d61d6e021643ffc1468c14cdbbde0b52dc9346330983c19bdb7f4d6fb8960c662ca6198658963ff6d2b4d7d2dc96853a8c58de48da77364a860f2f777855b5a
+DIST google-c-style-20140929.el.gz 2147 BLAKE2B c1e151e0aacac5fa39b4a293ab2663d9e784c15bb020ca4f46f09ea4736f84d7e33050632c6620d65cd45b5a631d2b08f5864096435bf9d58b321460e6a20518 SHA512 ad8682e06a2a607e4c7baa9177a03796afcbedc251281a53657fa44f718fee0416e6d60bdc9e0339ac95a0bac05389de0dd0616a6bb4577ff7b02e00c80d1df5
diff --git a/app-emacs/google-c-style/google-c-style-20140929.ebuild b/app-emacs/google-c-style/google-c-style-20140929.ebuild
new file mode 100644 (file)
index 0000000..74ea088
--- /dev/null
@@ -0,0 +1,20 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit elisp readme.gentoo-r1
+
+DESCRIPTION="Provides the google C/C++ coding style"
+HOMEPAGE="https://github.com/google/styleguide"
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.el.gz"
+
+LICENSE="|| ( GPL-1+ Artistic )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+S="${WORKDIR}"
+SITEFILE="50${PN}-gentoo.el"
+DOC_CONTENTS="Example usage (~/.emacs):
+       \n\t(add-hook 'c-mode-common-hook 'google-set-c-style)
+       \n\t(add-hook 'c-mode-common-hook 'google-make-newline-indent)"