games-rpg/manaplus: Bump to version 1.7.11.11
authorLars Wendler <polynomial-c@gentoo.org>
Wed, 29 Nov 2017 23:37:53 +0000 (00:37 +0100)
committerLars Wendler <polynomial-c@gentoo.org>
Wed, 29 Nov 2017 23:38:28 +0000 (00:38 +0100)
Package-Manager: Portage-2.3.16, Repoman-2.3.6

games-rpg/manaplus/Manifest
games-rpg/manaplus/manaplus-1.7.11.11.ebuild [new file with mode: 0644]

index 7f2c9006d44c8f11f6c666136fa35ad8738ec15e..bc9eacb419e7c7c5b5d3be78c72ee04a27b19819 100644 (file)
@@ -1,2 +1,3 @@
-DIST manaplus-1.7.10.14.tar.xz 14932496 SHA256 0a59af85953b1f73de8d1e2ff0be567167088ce8342e30537f49dc8784597f04 SHA512 9be54eeee2c0defb7affe7a01e071c152c854a9cc0a16179c967cb1980ebc3ee837004beb991fc9f603424797bf54146e04eee3221d233f448966afac4c784db WHIRLPOOL 7a311174b9c537c6964f519c6889348ccc929225d7466cfbd2a6b643155a2dbbb1cb8332ad8b9bcc7804d9dd0bf6d9b1cb1368692faa35e612f6a5a0575465be
-DIST manaplus-1.7.10.28.tar.xz 14931048 SHA256 381cbaeeff1295b48fd19b603c1c7c3094153da9ec71cb3f0405b73cee9d6b00 SHA512 8babb8c1f6a1870672a1058aa50435964a32c23dfa1227f645cae36e50e32bef8d3708ddc51f682368801026152035b624be7d0e60096b2a8025ef8b3aa2036e WHIRLPOOL b1f8e0b212f19409451ea5f338a400cf06ff52c5a33f4b060e192f139087d9ed8be76c17797697300224d216d5e4035cd3a8d089d06a7ac97598a2a608dff264
+DIST manaplus-1.7.10.14.tar.xz 14932496 BLAKE2B a6300bfcfa7f4f0598ed6c9dee4afeb3d1f437c13c0cee7585f1772c1a60a9dcae1f2c18139750e9357ea45b304ce1814c0805301aea062e9a335cbcd0653101 SHA512 9be54eeee2c0defb7affe7a01e071c152c854a9cc0a16179c967cb1980ebc3ee837004beb991fc9f603424797bf54146e04eee3221d233f448966afac4c784db
+DIST manaplus-1.7.10.28.tar.xz 14931048 BLAKE2B 30ab3de0f9675239142a04052f29c9bcea172102611d89308c09b9e0b9c8d3f4153af6b119ac9e65210f364b69fe8a35e9739a46ed09df068b38bc38a03b3482 SHA512 8babb8c1f6a1870672a1058aa50435964a32c23dfa1227f645cae36e50e32bef8d3708ddc51f682368801026152035b624be7d0e60096b2a8025ef8b3aa2036e
+DIST manaplus-1.7.11.11.tar.xz 14940736 BLAKE2B 42746df8f51808745e1e964419a6e5ad6d5f7e06adec2dc80956e4060fadb55f42150359637ea612919327c8fc4b5261d208b6837e47c310ec6e254cd99eee7f SHA512 d5b14cb0e9859a76abb9a6fb4e8761704e66ff145ba5e46b616aee43a58197bb2b28a4d81e9cdb49a9aaf295241d0730f123cfabd2a9a720d786826ee811ab40
diff --git a/games-rpg/manaplus/manaplus-1.7.11.11.ebuild b/games-rpg/manaplus/manaplus-1.7.11.11.ebuild
new file mode 100644 (file)
index 0000000..2d5897b
--- /dev/null
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+[[ ${PV} == 9999 ]] && inherit autotools git-r3
+
+DESCRIPTION="OpenSource 2D MMORPG client for Evol Online and The Mana World"
+HOMEPAGE="http://manaplus.evolonline.org"
+if [[ ${PV} == 9999 ]] ; then
+       EGIT_REPO_URI="https://github.com/ManaPlus/ManaPlus.git"
+else
+       SRC_URI="http://download.evolonline.org/manaplus/download/${PV}/${P}.tar.xz"
+       KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="mumble nls opengl pugixml +sdl2 test"
+
+RDEPEND="
+       >=dev-games/physfs-1.0.0
+       media-fonts/dejavu
+       media-fonts/liberation-fonts
+       media-fonts/mplus-outline-fonts
+       media-fonts/wqy-microhei
+       media-libs/libpng:0=
+       net-misc/curl
+       sys-libs/zlib
+       x11-apps/xmessage
+       x11-libs/libX11
+       x11-misc/xdg-utils
+       mumble? ( media-sound/mumble )
+       nls? ( virtual/libintl )
+       opengl? ( virtual/opengl )
+       pugixml? ( dev-libs/pugixml )
+       !pugixml? ( dev-libs/libxml2 )
+       sdl2? (
+               media-libs/libsdl2[X,opengl?,video]
+               media-libs/sdl2-gfx
+               media-libs/sdl2-image[png]
+               media-libs/sdl2-mixer[vorbis]
+               media-libs/sdl2-net
+               media-libs/sdl2-ttf
+       )
+       !sdl2? (
+               media-libs/libsdl[X,opengl?,video]
+               media-libs/sdl-gfx
+               media-libs/sdl-image[png]
+               media-libs/sdl-mixer[vorbis]
+               media-libs/sdl-net
+               media-libs/sdl-ttf
+       )"
+DEPEND="${RDEPEND}
+       virtual/pkgconfig
+       nls? ( sys-devel/gettext )"
+
+src_prepare() {
+       default
+       if [[ ${PV} == 9999 ]] ; then
+               eautoreconf
+       fi
+}
+
+src_configure() {
+       local myeconfargs=(
+               --localedir=/usr/share/locale
+               --without-internalsdlgfx
+               $(use_with mumble)
+               $(use_enable nls)
+               $(use_with opengl)
+               --enable-libxml=$(usex pugixml pugixml libxml)
+               $(use_with sdl2)
+               $(use_enable test unittests)
+       )
+       CONFIG_SHELL=/bin/bash econf "${myeconfargs[@]}"
+}
+
+src_install() {
+       default
+
+       local destpath="/usr/share/${PN}"
+       dosym /usr/share/fonts/dejavu/DejaVuSans-Bold.ttf "${destpath}"/data/fonts/dejavusans-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSans.ttf "${destpath}"/data/fonts/dejavusans.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono-Bold.ttf "${destpath}"/data/fonts/dejavusansmono-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSansMono.ttf "${destpath}"/data/fonts/dejavusansmono.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed-Bold.ttf "${destpath}"/data/fonts/dejavuserifcondensed-bold.ttf
+       dosym /usr/share/fonts/dejavu/DejaVuSerifCondensed.ttf "${destpath}"/data/fonts/dejavuserifcondensed.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Bold.ttf "${destpath}"/data/fonts/liberationsansmono-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationMono-Regular.ttf "${destpath}"/data/fonts/liberationsansmono.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Bold.ttf "${destpath}"/data/fonts/liberationsans-bold.ttf
+       dosym /usr/share/fonts/liberation-fonts/LiberationSans-Regular.ttf "${destpath}"/data/fonts/liberationsans.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-bold.ttf "${destpath}"/data/fonts/mplus-1p-bold.ttf
+       dosym /usr/share/fonts/mplus-outline-fonts/mplus-1p-regular.ttf "${destpath}"/data/fonts/mplus-1p-regular.ttf
+       dosym /usr/share/fonts/wqy-microhei/wqy-microhei.ttc "${destpath}"/data/fonts/wqy-microhei.ttf
+}
+
+src_test() {
+       make check
+}