net-irc/ngircd: cleanup old
authorSam James (sam_c) <sam@cmpct.info>
Tue, 21 Apr 2020 07:07:24 +0000 (07:07 +0000)
committerJoonas Niilola <juippis@gentoo.org>
Sun, 26 Apr 2020 13:36:49 +0000 (16:36 +0300)
Signed-off-by: Sam James (sam_c) <sam@cmpct.info>
Closes: https://github.com/gentoo/gentoo/pull/15361
Signed-off-by: Joonas Niilola <juippis@gentoo.org>
net-irc/ngircd/Manifest
net-irc/ngircd/ngircd-23-r1.ebuild [deleted file]

index a9321e747c20d4d574c045f123ab22ed473626fd..70e98c6c205fdf1ab1113b07c3a587d6fef89858 100644 (file)
@@ -1,3 +1,2 @@
-DIST ngircd-23.tar.gz 517686 BLAKE2B 1e1d7386a95f22917e6f69ec43bc48a8031543c48d6141a16d81fd935dab47ae89d8bbc91d9d71a26b0a1d2fd2040feb478e773fcc2a3049061fc0b21c8bad18 SHA512 714fbb4af12335e62c615fa1e8de9c7366c4c6da6af9b334019ba900dce072067f7b08199de8c96aad5dd4b9b786b57d536ba9dc92c62b37d2ae11960dbd01b1
 DIST ngircd-24.tar.gz 524968 BLAKE2B 8ec0518d54f43a4c42fbf9744d217eb2aae498fe4f0010bce6ad68164037c2e55dc2b9681babce8ca5f7e26bac60a91389c63dab397d349dd4bcbcce6c2e9839 SHA512 66d1b9576c03d0a70be17a235f2da50ee661646cd428d18a6c61975407671dd4a3a545069258536773b27d4fb63523527366bbbf4f35cb08111dc60842924395
 DIST ngircd-25.tar.gz 527886 BLAKE2B ab75c9a904fae8da4c89e07bd66bb000bc9b614e27269be3ac6f55254c77abeb2d6f7d0afc6d05630f7c548ea13d842d4c0376123035f9417eda55565a69dcec SHA512 0c96e97da312fe86c50007a72db03f85b9f79df053806f50badd07c7ca8e8bddd99adb478eab8be9630330707d7aa578b5d0bd3017b59bf4515319a64c29ea6c
diff --git a/net-irc/ngircd/ngircd-23-r1.ebuild b/net-irc/ngircd/ngircd-23-r1.ebuild
deleted file mode 100644 (file)
index 86154bf..0000000
+++ /dev/null
@@ -1,84 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="5"
-
-inherit autotools-utils eutils user
-
-DESCRIPTION="An IRC server written from scratch"
-HOMEPAGE="http://ngircd.barton.de/"
-SRC_URI="http://ngircd.barton.de/pub/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86 ~x64-macos"
-IUSE="debug gnutls iconv ident ipv6 libressl pam ssl tcpd zlib"
-
-RDEPEND="
-       iconv? ( virtual/libiconv )
-       ident? ( net-libs/libident )
-       pam? ( sys-libs/pam )
-       ssl? (
-               !gnutls? (
-                       !libressl? ( dev-libs/openssl:0 )
-               )
-               gnutls? ( net-libs/gnutls )
-               libressl? ( dev-libs/libressl )
-       )
-       tcpd? ( sys-apps/tcp-wrappers )
-       zlib? ( sys-libs/zlib )
-"
-DEPEND="${RDEPEND}
-       >=sys-apps/sed-4
-"
-
-RESTRICT="test"
-
-src_configure() {
-       if ! use prefix; then
-               sed -i \
-                       -e "s:;ServerUID = 65534:ServerUID = ngircd:" \
-                       -e "s:;ServerGID = 65534:ServerGID = nogroup:" \
-                       doc/sample-ngircd.conf.tmpl || die
-       fi
-
-       local myeconfargs=(
-               --docdir="${EPREFIX}"/usr/share/doc/${PF}
-               --sysconfdir="${EPREFIX}"/etc/ngircd
-               $(use_enable debug sniffer)
-               $(use_enable debug)
-               $(use_enable ipv6)
-               $(use_with iconv)
-               $(use_with ident)
-               $(use_with pam)
-               $(use_with tcpd tcp-wrappers)
-               $(use_with zlib)
-       )
-
-       if use ssl; then
-               myeconfargs+=(
-                       $(use_with !gnutls openssl)
-                       $(use_with gnutls)
-               )
-       else
-               myeconfargs+=(
-                       --without-gnutls
-                       --without-openssl
-               )
-       fi
-
-       autotools-utils_src_configure
-}
-
-src_install() {
-       autotools-utils_src_install
-
-       newinitd "${FILESDIR}"/ngircd.init-r1.d ngircd
-}
-
-pkg_postinst() {
-       if ! use prefix; then
-               enewuser ngircd
-               chown ngircd "${ROOT}"/etc/ngircd/ngircd.conf
-       fi
-}