dev-haskell/gtk3: bump up to 0.14.6
authorSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 22:03:33 +0000 (22:03 +0000)
committerSergei Trofimovich <slyfox@gentoo.org>
Thu, 16 Feb 2017 22:16:29 +0000 (22:16 +0000)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-haskell/gtk3/Manifest
dev-haskell/gtk3/gtk3-0.14.6.ebuild [new file with mode: 0644]

index 9d18123910ebfa205bf52b29f2762d9d306d06fc..8d68ad27570d13c1b73cfd66d0776ecdac9bb18e 100644 (file)
@@ -1 +1,2 @@
 DIST gtk3-0.13.7.tar.gz 673031 SHA256 29bf3dcdb39d01dbbced766ab1d72add67e73e01181668bc3423a71359d94f96 SHA512 c350ae55a7044684e6f2d94592decfcd01d3e96900a468cd417bad52713502c89c328f96cd4ff29647169a76287b8dada9654d46c4dc884c0dab0590ad57762e WHIRLPOOL 2045939ea93c510582a29b8427a607bcf931d8bd7cdaef9a3751fe3fa925bacebfa1ff4980c941470acfecd6b76fb08e99c3934b6b0577ab475bbf26c9e98e40
+DIST gtk3-0.14.6.tar.gz 675439 SHA256 f4c0d3c51a5e06e5f6a8fcfc2a1303e0a3ed0242309fc6c1b9603be9de1f4258 SHA512 d03930164fa117ebd6bcc79b79a9cfc0449c5ed0b3de6999f26ad63673a67a146f989245efa68b4e1484091689b350a5df95ed49bbbe9d4a30fbe418cbb37209 WHIRLPOOL f35bd46995f4340c3e640a3010569b2fc08542ad713aec0020302afa2352e5a52e303d82270c37c0264cfcd216eb1d97339dd6e203a363b8e93a70ec4af6263c
diff --git a/dev-haskell/gtk3/gtk3-0.14.6.ebuild b/dev-haskell/gtk3/gtk3-0.14.6.ebuild
new file mode 100644 (file)
index 0000000..db959c2
--- /dev/null
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.9999
+#hackport: flags: have-gio:gio,build-demos:examples
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Binding to the Gtk+ 3 graphical user interface library"
+HOMEPAGE="http://projects.haskell.org/gtk2hs/"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0/${PV}"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="+fmode-binary +gio"
+
+RDEPEND=">=dev-haskell/cairo-0.13.0.0:=[profile?] <dev-haskell/cairo-0.14:=[profile?]
+       >=dev-haskell/glib-0.13.0.0:=[profile?] <dev-haskell/glib-0.14:=[profile?]
+       dev-haskell/mtl:=[profile?]
+       >=dev-haskell/pango-0.13.0.0:=[profile?] <dev-haskell/pango-0.14:=[profile?]
+       >=dev-haskell/text-0.11.0.6:=[profile?] <dev-haskell/text-1.3:=[profile?]
+       >=dev-lang/ghc-7.4.1:=
+       dev-libs/glib:2
+       x11-libs/gtk+:3
+       gio? ( >=dev-haskell/gio-0.13.0:=[profile?] <dev-haskell/gio-0.14:=[profile?] )
+"
+DEPEND="${RDEPEND}
+       >=dev-haskell/cabal-1.24
+       virtual/pkgconfig
+"
+
+src_configure() {
+       haskell-cabal_src_configure \
+               $(cabal_flag fmode-binary fmode-binary) \
+               $(cabal_flag gio have-gio)
+}