dev-python/astroid: fix tests on py37
authorVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 02:59:57 +0000 (21:59 -0500)
committerVirgil Dupras <vdupras@gentoo.org>
Fri, 1 Feb 2019 03:06:25 +0000 (22:06 -0500)
Signed-off-by: Virgil Dupras <vdupras@gentoo.org>
Package-Manager: Portage-2.3.51, Repoman-2.3.11

dev-python/astroid/astroid-2.1.0.ebuild
dev-python/astroid/files/astroid-2.1.0-fix-tests.patch [new file with mode: 0644]

index 34044e6fa016bf3a8128d17102a7659cafe7a012..b23580f1816206916f67fdea862f0c1f925b628c 100644 (file)
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
 # Distributed under the terms of the GNU General Public License v2
 
 EAPI=7
@@ -32,6 +32,10 @@ DEPEND="
                dev-python/python-dateutil[${PYTHON_USEDEP}]
        )"
 
+PATCHES=(
+       "${FILESDIR}/${PN}-2.1.0-fix-tests.patch"
+)
+
 python_prepare_all() {
        # Disable failing tests
 
diff --git a/dev-python/astroid/files/astroid-2.1.0-fix-tests.patch b/dev-python/astroid/files/astroid-2.1.0-fix-tests.patch
new file mode 100644 (file)
index 0000000..32e7522
--- /dev/null
@@ -0,0 +1,16 @@
+typed_ast doesn't support py37 yet and disables its support under py37.
+However, when dev-python/types-ast is installed, the test suite mistakenly
+thinks that it has to test typed_ast-related things and fails.
+diff --git a/astroid/tests/unittest_nodes.py b/astroid/tests/unittest_nodes.py
+index 56b195c2..762f1af2 100644
+--- a/astroid/tests/unittest_nodes.py
++++ b/astroid/tests/unittest_nodes.py
+@@ -49,6 +49,8 @@ try:
+ except ImportError:
+     HAS_TYPED_AST = False
++if sys.version_info[:2] >= (3, 7):
++    HAS_TYPED_AST = False
+ class AsStringTest(resources.SysPathSetup, unittest.TestCase):
+     def test_tuple_as_string(self):