Fixing autotools wrt bug #153244
authorMarkus Ullmann <jokey@gentoo.org>
Tue, 31 Oct 2006 23:23:02 +0000 (23:23 +0000)
committerMarkus Ullmann <jokey@gentoo.org>
Tue, 31 Oct 2006 23:23:02 +0000 (23:23 +0000)
Package-Manager: portage-2.1.2_rc1-r1

net-analyzer/cacti-cactid/cacti-cactid-0.8.6e.ebuild
net-analyzer/cacti-cactid/cacti-cactid-0.8.6f_p1.ebuild
net-analyzer/cacti-cactid/cacti-cactid-0.8.6g.ebuild

index 21c80f6d59448f5585e43552ded00949cdb24f44..9e3f1d24252e9bac9865c32e47fefced04d5fc52 100644 (file)
@@ -1,6 +1,9 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6e.ebuild,v 1.4 2006/08/14 09:46:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6e.ebuild,v 1.5 2006/10/31 23:23:02 jokey Exp $
+
+WANT_AUTOCONF="latest"
+inherit autotools
 
 DESCRIPTION="Cactid is a poller for Cacti that primarily strives to be as fast
 as possible"
@@ -27,9 +30,8 @@ src_unpack() {
 }
 
 src_compile() {
-       export WANT_AUTOCONF=2.5
-       aclocal || die "aclocal failed"
-       autoconf || die "autoconf failed"
+       eaclocal
+       eautoconf
        econf || die "econf failed"
        emake || die "emake failed"
 }
index 5cfc25b747ed18f011a11cb01479cadfa55767ea..170f780c69df19cd89204f5ad5034f78b9a6d2e2 100644 (file)
@@ -1,6 +1,9 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6f_p1.ebuild,v 1.9 2006/08/14 09:46:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6f_p1.ebuild,v 1.10 2006/10/31 23:23:02 jokey Exp $
+
+WANT_AUTOCONF="latest"
+inherit autotools
 
 MY_PV=${PV/_p/-}
 DESCRIPTION="Cactid is a poller for Cacti that primarily strives to be as fast
@@ -30,9 +33,8 @@ src_unpack() {
 }
 
 src_compile() {
-       export WANT_AUTOCONF=2.5
-       aclocal || die "aclocal failed"
-       autoconf || die "autoconf failed"
+       eaclocal
+       eautoconf
        econf || die "econf failed"
        emake || die "emake failed"
 }
index df6393efa1a0720eb1310385af2778d2f94dc115..b48c0f1057bef5cf1c8396e1975b61c7f0805a74 100644 (file)
@@ -1,6 +1,9 @@
 # Copyright 1999-2006 Gentoo Foundation
 # Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6g.ebuild,v 1.2 2006/08/14 09:46:08 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/cacti-cactid/cacti-cactid-0.8.6g.ebuild,v 1.3 2006/10/31 23:23:02 jokey Exp $
+
+WANT_AUTOCONF="latest"
+inherit autotools
 
 MY_PV=${PV/_p/-}
 DESCRIPTION="Cactid is a poller for Cacti that primarily strives to be as fast
@@ -28,9 +31,8 @@ src_unpack() {
 }
 
 src_compile() {
-       export WANT_AUTOCONF=2.5
-       aclocal || die "aclocal failed"
-       autoconf || die "autoconf failed"
+       eaclocal
+       eautoconf
        econf || die "econf failed"
        emake || die "emake failed"
 }