dev-ml/cairo-ocaml: Remove support for non-existent deps
authorMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 09:09:18 +0000 (11:09 +0200)
committerMichał Górny <mgorny@gentoo.org>
Sun, 26 Aug 2018 09:09:18 +0000 (11:09 +0200)
dev-ml/cairo-ocaml/cairo-ocaml-1.2.0.ebuild

index 5a13b6957e17de8bcd77f227b3af93052e2ea846..c9c07c183718146b9028e8fafa889f502024d325 100644 (file)
@@ -12,13 +12,12 @@ SRC_URI="https://cgit.freedesktop.org/cairo-ocaml/snapshot/${P}.tar.bz2"
 LICENSE="LGPL-2.1"
 SLOT="0/${PV}"
 KEYWORDS="amd64 ~ppc x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples gtk pango svg"
+IUSE="doc examples gtk pango"
 
 RDEPEND="dev-lang/ocaml:=
        x11-libs/cairo
        gtk? ( dev-ml/lablgtk:2= )
-       pango? ( x11-libs/pango )
-       svg? ( x11-libs/libsvg-cairo )"
+       pango? ( x11-libs/pango )"
 DEPEND="${RDEPEND}"
 
 src_prepare() {
@@ -35,7 +34,7 @@ src_configure() {
        econf \
                $(use_with gtk) \
                $(use_with pango pango-cairo) \
-               $(use_with svg svg-cairo)
+               --without-svg-cairo
 }
 
 src_compile() {
@@ -77,15 +76,6 @@ src_install() {
                        )
                EOF
        fi
-       if use svg; then
-               cat <<-EOF >> META
-                       package "svg" (
-                               requires = "cairo"
-                               archive(byte) = "svg_cairo.cma"
-                               archive(native) = "svg_cairo.cmxa"
-                       )
-               EOF
-       fi
        insinto /usr/$(get_libdir)/ocaml/cairo
        doins META
 }