dev-util/clinfo: 2.2.18.04.06 version bump
authorCraig Andrews <candrews@gentoo.org>
Fri, 6 Apr 2018 14:32:36 +0000 (10:32 -0400)
committerCraig Andrews <candrews@gentoo.org>
Fri, 6 Apr 2018 14:33:45 +0000 (10:33 -0400)
Package-Manager: Portage-2.3.28, Repoman-2.3.9

dev-util/clinfo/Manifest
dev-util/clinfo/clinfo-2.2.18.04.06.ebuild [new file with mode: 0644]

index ac5723aade40cde096006832e1a9fc3e33d9d704..586b9a74ac1f6066ec67ba63fed96cf9e3e62e5b 100644 (file)
@@ -1 +1,2 @@
 DIST clinfo-2.2.18.03.26.tar.gz 38519 BLAKE2B 736036f4f84c170876b9b550bfe837c67a273cef9032af8734035edf5070d17d876d10f7d5c81889966df0a9ad4192c43c1501326188782cc674611ea57130ef SHA512 dec90a314e6c52e5501339dbe594cb57cfc8cae6855db7bb88b36984fd661e55f2cc8eb29fa546998862c806ec752bfc2b6a9e0d9d962370f84b0091605c1bcb
+DIST clinfo-2.2.18.04.06.tar.gz 41459 BLAKE2B e90a515fd9318aeced510cd97cc477e1925b37e2c389ffee0ec484563acc9f0f9a8880cb38575b299c4f63e1b4a6959064d7d0d45487f67d6fcf32ce91962a47 SHA512 4aa1623bd08602e2104b4ba3150f36a9e8e8fb25728d4a1792a9cc81a2a5952a4a78ccad0928f098ce4e8bc05f30d09267e01ccd81d541fdfb0bc7de46908faf
diff --git a/dev-util/clinfo/clinfo-2.2.18.04.06.ebuild b/dev-util/clinfo/clinfo-2.2.18.04.06.ebuild
new file mode 100644 (file)
index 0000000..3d01e88
--- /dev/null
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+if [[ ${PV} == "9999" ]] ; then
+       EGIT_REPO_URI="https://github.com/Oblomov/clinfo.git"
+       inherit git-r3
+       SRC_URI=""
+else
+       SRC_URI="https://github.com/Oblomov/clinfo/archive/${PV}.tar.gz -> ${P}.tar.gz"
+       KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A tool to display info about the system's OpenCL capabilities"
+HOMEPAGE="https://github.com/Oblomov/clinfo"
+LICENSE="CC0-1.0"
+SLOT="0"
+
+DEPEND=">=app-eselect/eselect-opencl-1.1.0-r4
+       virtual/opencl"
+RDEPEND="${DEPEND}"
+
+src_install() {
+       emake MANDIR="${ED}"/usr/share/man PREFIX="${ED}"/usr install
+}