dev-ml/alcotest: initial import; ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 07:34:00 +0000 (08:34 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 23 Feb 2017 09:15:48 +0000 (10:15 +0100)
Package-Manager: Portage-2.3.3, Repoman-2.3.1

dev-ml/alcotest/Manifest [new file with mode: 0644]
dev-ml/alcotest/alcotest-0.7.2.ebuild [new file with mode: 0644]
dev-ml/alcotest/metadata.xml [new file with mode: 0644]

diff --git a/dev-ml/alcotest/Manifest b/dev-ml/alcotest/Manifest
new file mode 100644 (file)
index 0000000..9a585ee
--- /dev/null
@@ -0,0 +1 @@
+DIST alcotest-0.7.2.tar.gz 24781 SHA256 75eac2c9b9c1f9e07d8c4de43ba8e852bd59ef1d7d322cd9c036a075335ef472 SHA512 3448c7d82c200f0cf2ac97f7f49060c350c0719124b24079b5babb48b1d3e0b0508ada0b273e1963dc07dc4cc072b0a589096c39b8b6d8a4adf7e011418dd4a3 WHIRLPOOL d1345d9c3481663fa29d99cf8483bc2e11251a088bd589472eb83f8483b7b3db6130098560de7cb3d00f0741c68c0d0060ae0b602a8f2af51950c0199b0ee612
diff --git a/dev-ml/alcotest/alcotest-0.7.2.ebuild b/dev-ml/alcotest/alcotest-0.7.2.ebuild
new file mode 100644 (file)
index 0000000..8b176af
--- /dev/null
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+DESCRIPTION="A lightweight and colourful test framework"
+HOMEPAGE="https://github.com/mirage/alcotest/"
+SRC_URI="https://github.com/mirage/alcotest/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+       dev-lang/ocaml:=[ocamlopt]
+       dev-ml/fmt:=
+       dev-ml/astring:=
+       dev-ml/cmdliner:=
+       dev-ml/result:=
+"
+DEPEND="${RDEPEND}
+       dev-ml/opam
+       dev-ml/topkg
+       dev-ml/ocamlbuild
+       dev-ml/findlib"
+
+src_compile() {
+       ocaml pkg/pkg.ml build --tests $(usex test true false) || die
+}
+
+src_test() {
+       ocaml pkg/pkg.ml test || die
+}
+
+src_install() {
+       opam-installer -i \
+               --prefix="${ED}/usr" \
+               --libdir="${D}/$(ocamlc -where)" \
+               --docdir="${ED}/usr/share/doc/${PF}" \
+               ${PN}.install || die
+       dodoc CHANGES.md README.md
+}
diff --git a/dev-ml/alcotest/metadata.xml b/dev-ml/alcotest/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>