fix $v bug and remove debug output
authoragriffis <agriffis@gentoo.org>
Fri, 19 Mar 2004 05:23:33 +0000 (05:23 -0000)
committeragriffis <agriffis@gentoo.org>
Fri, 19 Mar 2004 05:23:33 +0000 (05:23 -0000)
svn path=/; revision=93

trunk/src/echangelog/ChangeLog
trunk/src/echangelog/echangelog

index 5065bd85862e04ba8f5eb62b700a43f479efc753..5500d44e3fe6d0ad7eb25b5ef9a2659ec6abe568 100644 (file)
@@ -1,3 +1,7 @@
+19 Mar 2004 Aron Griffis <agriffis@gentoo.org>
+       * Remove debugging output
+       * Fix $v bug introduced in last commit
+
 16 Mar 2004 Aron Griffis <agriffis@gentoo.org>
        * Make Feb 17 behavior work without Feb 20 bug :-)
        * Release as version 0.2.0
index e2d6c73e12cbebde94a57f17b5bb8dc27a547ab7..5b1fc4caca156ccf374bd40c381476649009b919 100644 (file)
@@ -61,8 +61,6 @@ while (<C>) {
 # the changed files we have
 @ebuilds = grep /\.ebuild$/, @files;
 @files = grep !/\.ebuild$/, @files;
-print "files = @files\n";
-print "ebuilds = @ebuilds\n";
 if (@ebuilds) {
        open C, "cvs diff -U 0 @ebuilds 2>&1 |" or die "Can't run cvs diff: $!\n";
        $_ = <C>;
@@ -85,7 +83,7 @@ if (@ebuilds) {
                                last if /^[A-Za-z]/;
                                if (/^[-+](?!# Copyright)/) {
                                        push @files, $f;
-                                       $versions{$2} = $v;     # existing ebuild that has changed
+                                       $versions{$v} = $0;     # existing ebuild that has changed
                                        last;
                                }
                        }