dev-python/flask-paranoid: fix broken tests
authorVirgil Dupras <vdupras@gentoo.org>
Sun, 12 Aug 2018 16:20:04 +0000 (12:20 -0400)
committerVirgil Dupras <vdupras@gentoo.org>
Sun, 12 Aug 2018 16:20:04 +0000 (12:20 -0400)
Previously, tests would seemingly run, but they would actually run
nothing: tests aren't included in the PyPI tarball. We switch to github
releases so that we get tests.

Also, don't use tox. See
https://wiki.gentoo.org/wiki/Project:Python/Tests#Do_not_ever_use_tox.21

Package-Manager: Portage-2.3.46, Repoman-2.3.10

dev-python/flask-paranoid/Manifest
dev-python/flask-paranoid/flask-paranoid-0.2.0-r1.ebuild [new file with mode: 0644]

index da280cc297e9b47bb4d45294c75b3eda5f70bb4c..031f0a70a80ab56350e15864b40b741255c11a47 100644 (file)
@@ -1,2 +1,3 @@
 DIST Flask-Paranoid-0.1.0.tar.gz 2619 BLAKE2B d161f711a2b4b0164dbe6b85a8b650703f6154a23b271305a37fdfc5f938963a2135b3b20b66833d8a993175098cafebcdae70361405d59ec25e72030a03ce59 SHA512 435b679d7ad027d813b887bfa1211318aa122c6bded879dcb3e803535671e21f81e52fd5abb3b82c998d862441e6b5123290f4bb2da70a4dec391b05601eb639
 DIST Flask-Paranoid-0.2.0.tar.gz 2630 BLAKE2B d103651dee2560ff6dfd0014da5830848dafe92c7ad5857bc46fc88dd69ab37d4a9443f4682ce8e94b965de646406d4cfda2dda8719bdf767824bf9a2e20a1f9 SHA512 3a5c48815715d3188d12c779dd229cad5a97936832727d58277b0b717d0995ac1ea7cac6a8061a5bf656f8f976cb06b27654f6a4c06e2747a56f45ba92391f49
+DIST flask-paranoid-0.2.0.tar.gz 101084 BLAKE2B 5f1f92679da5f374699c8acc97300085840d47e57f48d935cba60e78782109f70651bb7f804410dbb241b48c96ec08498b8b2cc8c18573f14d0bc7972b746d19 SHA512 0d642999fa4d5b795c3dcecc586fc1600cdfceec4adb38bb87ca8be9825d9ddafabb07d98df573a89e61a44a0abd27cbbd21524237b0e23b337a7d5e32ddfdae
diff --git a/dev-python/flask-paranoid/flask-paranoid-0.2.0-r1.ebuild b/dev-python/flask-paranoid/flask-paranoid-0.2.0-r1.ebuild
new file mode 100644 (file)
index 0000000..25fe0e5
--- /dev/null
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1 eapi7-ver
+
+MY_PV=$(ver_cut 1-2)
+
+DESCRIPTION="Simple user session protection extension for Flask"
+HOMEPAGE="https://github.com/miguelgrinberg/flask-paranoid/"
+SRC_URI="https://github.com/miguelgrinberg/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+python_test() {
+       esetup.py test
+}