dev-ada/gnatmem: simplify using ada eclass
authorTupone Alfredo <tupone@gentoo.org>
Tue, 17 Sep 2019 07:19:03 +0000 (09:19 +0200)
committerTupone Alfredo <tupone@gentoo.org>
Tue, 17 Sep 2019 07:19:03 +0000 (09:19 +0200)
Package-Manager: Portage-2.3.69, Repoman-2.3.16
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
dev-ada/gnatmem/gnatmem-2019-r1.ebuild [new file with mode: 0644]

diff --git a/dev-ada/gnatmem/gnatmem-2019-r1.ebuild b/dev-ada/gnatmem/gnatmem-2019-r1.ebuild
new file mode 100644 (file)
index 0000000..c5bc8a4
--- /dev/null
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+ADA_COMPAT=( gnat_201{6,7,8,9} )
+inherit ada multiprocessing autotools
+
+MYP=${P}-20190429-19745-src
+
+DESCRIPTION="Monitors dynamic allocation and deallocation activity in a program"
+HOMEPAGE="http://libre.adacore.com/"
+SRC_URI="http://mirrors.cdn.adacore.com/art/5cdf8e1431e87a8f1d425089
+       -> ${MYP}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="${ADA_DEPS}"
+DEPEND="${RDEPEND}
+       dev-ada/gprbuild[${ADA_USEDEP}]
+       sys-libs/binutils-libs"
+
+REQUIRED_USE="${ADA_REQUIRED_USE}"
+
+S="${WORKDIR}"/${MYP}
+
+PATCHES=( "${FILESDIR}"/${PN}-2018-gentoo.patch )
+
+src_prepare() {
+       default
+       mv configure.in configure.ac
+       eautoreconf
+}
+
+src_compile() {
+       gprbuild -v -Pgnatmem.gpr -j$(makeopts_jobs) \
+               -cargs:C ${CFLAGS} -cargs:Ada ${ADAFLAGS}
+}
+
+src_install() {
+       dobin obj/gnatmem
+}