dev-python/numexpr: Remove redundant versions
authorMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:11:55 +0000 (12:11 +0100)
committerMichał Górny <mgorny@gentoo.org>
Sat, 28 Mar 2020 11:11:55 +0000 (12:11 +0100)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/numexpr/Manifest
dev-python/numexpr/numexpr-2.6.8.ebuild [deleted file]

index 904147a8678ce88cec0026439c7cb02926853da6..18504c4be5befea90bb7953c3bc70331a6e21101 100644 (file)
@@ -1,2 +1 @@
-DIST numexpr-2.6.8.tar.gz 94517 BLAKE2B b41593183d69cd98f81107da5abc3eb59b35c6e61c0dde213c9a201c2776e4684d8af4b1a88c59ca464a7755941de9baf2157af64e8662c4219ae8ece635aefb SHA512 e610a2e3891f12b3a9fd7acb14a0362e0f03084035aa274827ec5e7d2584f2c599493afaf406d8720d915c7ed834dca11b1fbf28c0645077eb63223a2bf52cf9
 DIST numexpr-2.6.9.tar.gz 94419 BLAKE2B 22492c1c59306fbd93174b5bab2ffaa32628c52cc570871bd6192a4589b65b6f679a77c8ec6f37b0a2ac09f004364a2ba87ecc26f459cb2d4b3b2705196b9fdc SHA512 d43845fb63c1e7b645b282d251f7f112784dbc04b61af1ffcbb9646cbe2e3a9f5d38aaa000f7d49880abe44c25205a6ef1e284577d36868220a197cdc0e55166
diff --git a/dev-python/numexpr/numexpr-2.6.8.ebuild b/dev-python/numexpr/numexpr-2.6.8.ebuild
deleted file mode 100644 (file)
index 525466c..0000000
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 flag-o-matic
-
-DESCRIPTION="Fast numerical array expression evaluator for Python and NumPy"
-HOMEPAGE="https://github.com/pydata/numexpr"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
-IUSE="mkl"
-
-RDEPEND="
-       >=dev-python/numpy-1.6[${PYTHON_USEDEP}]
-       mkl? ( sci-libs/mkl )"
-DEPEND="${RDEPEND}
-       dev-python/setuptools[${PYTHON_USEDEP}]"
-
-python_prepare_all() {
-       # TODO: mkl can be used but it fails for me
-       # only works with mkl in tree. newer mkl will use pkgconfig
-       if use mkl; then
-               use amd64 && local ext="_lp64"
-               cat > site.cfg <<- _EOF_ || die
-                       [mkl]
-                       library_dirs = ${MKLROOT}/lib/em64t
-                       include_dirs = ${MKLROOT}/include
-                       mkl_libs = mkl_solver${ext}, mkl_intel${ext}, \
-                       mkl_intel_thread, mkl_core, iomp5
-               _EOF_
-       fi
-
-       distutils-r1_python_prepare_all
-}
-
-python_compile() {
-       if ! python_is_python3; then
-               local -x CFLAGS="${CFLAGS}"
-               append-cflags -fno-strict-aliasing
-       fi
-
-       distutils-r1_python_compile
-}
-
-python_test() {
-       pushd "${BUILD_DIR}"/lib >/dev/null || die
-       "${EPYTHON}" \
-               -c "import sys;import numexpr;sys.exit(0 if numexpr.test() else 1)" \
-               || die
-       pushd >/dev/null || die
-}