net-im/spectrum2: add fix for boost-1.73 and gcc-10
authorConrad Kostecki <conikost@gentoo.org>
Thu, 14 May 2020 08:55:23 +0000 (10:55 +0200)
committerConrad Kostecki <conikost@gentoo.org>
Thu, 14 May 2020 08:57:43 +0000 (10:57 +0200)
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
net-im/spectrum2/files/spectrum2-2.0.12-boost-173-compatibility.patch [new file with mode: 0644]
net-im/spectrum2/files/spectrum2-2.0.12-gcc-10-compatibility.patch [new file with mode: 0644]
net-im/spectrum2/spectrum2-2.0.12-r2.ebuild

diff --git a/net-im/spectrum2/files/spectrum2-2.0.12-boost-173-compatibility.patch b/net-im/spectrum2/files/spectrum2-2.0.12-boost-173-compatibility.patch
new file mode 100644 (file)
index 0000000..b9a8ade
--- /dev/null
@@ -0,0 +1,21 @@
+From 1a6ede2dbf0f621e3e6864675befcbc32e02c8b6 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <kostecki@his.de>
+Date: Thu, 14 May 2020 10:34:43 +0200
+Subject: [PATCH] Fix compilation with boost-1.73
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ include/transport/ThreadPool.h | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/include/transport/ThreadPool.h b/include/transport/ThreadPool.h
+index 5902f965..ffd07c8e 100644
+--- a/include/transport/ThreadPool.h
++++ b/include/transport/ThreadPool.h
+@@ -1,5 +1,6 @@
+ #pragma once 
++#include <boost/bind.hpp>
+ #include <boost/thread.hpp>
+ #include <boost/thread/mutex.hpp>
+ #include <queue>
diff --git a/net-im/spectrum2/files/spectrum2-2.0.12-gcc-10-compatibility.patch b/net-im/spectrum2/files/spectrum2-2.0.12-gcc-10-compatibility.patch
new file mode 100644 (file)
index 0000000..ad13208
--- /dev/null
@@ -0,0 +1,54 @@
+From 95e6968c0f8c95f6bd817e5081e0b10dea9d4269 Mon Sep 17 00:00:00 2001
+From: Conrad Kostecki <kostecki@his.de>
+Date: Wed, 13 May 2020 14:22:27 +0200
+Subject: [PATCH] Fix dfrotz compilation with GCC >= 10
+
+Since GCC enables by default -fno-common,
+the compilation of dfrotz due multiple definitions will fail.
+
+Signed-off-by: Conrad Kostecki <conrad@kostecki.com>
+---
+ backends/frotz/dfrotz/dumb/dumb_init.c   | 2 +-
+ backends/frotz/dfrotz/dumb/dumb_input.c  | 2 +-
+ backends/frotz/dfrotz/dumb/dumb_output.c | 2 +-
+ 3 files changed, 3 insertions(+), 3 deletions(-)
+
+diff --git a/backends/frotz/dfrotz/dumb/dumb_init.c b/backends/frotz/dfrotz/dumb/dumb_init.c
+index 4b9c6704..35295b74 100644
+--- a/backends/frotz/dfrotz/dumb/dumb_init.c
++++ b/backends/frotz/dfrotz/dumb/dumb_init.c
+@@ -7,7 +7,7 @@
+ #include "dumb_frotz.h"
+-f_setup_t f_setup;
++extern f_setup_t f_setup;
+ #define INFORMATION "\
+ An interpreter for all Infocom and other Z-Machine games.\n\
+diff --git a/backends/frotz/dfrotz/dumb/dumb_input.c b/backends/frotz/dfrotz/dumb/dumb_input.c
+index 4149b2b0..88fc8ae5 100644
+--- a/backends/frotz/dfrotz/dumb/dumb_input.c
++++ b/backends/frotz/dfrotz/dumb/dumb_input.c
+@@ -5,7 +5,7 @@
+  */
+ #include "dumb_frotz.h"
+-f_setup_t f_setup;
++extern f_setup_t f_setup;
+ static char runtime_usage[] =
+   "DUMB-FROTZ runtime help:\n"
+diff --git a/backends/frotz/dfrotz/dumb/dumb_output.c b/backends/frotz/dfrotz/dumb/dumb_output.c
+index 9e505167..6dc7db82 100644
+--- a/backends/frotz/dfrotz/dumb/dumb_output.c
++++ b/backends/frotz/dfrotz/dumb/dumb_output.c
+@@ -7,7 +7,7 @@
+ #include "dumb_frotz.h"
+-f_setup_t f_setup;
++extern f_setup_t f_setup;
+ static bool show_line_numbers = FALSE;
+ static bool show_line_types = -1;
index 0bc829465f948174ac1e0615003fc1b47284a037..e2a557eb711339d99d0f82da2481f8fb93fe8328 100644 (file)
@@ -64,6 +64,11 @@ DEPEND="
 # Tests are currently restricted, as they do completly fail
 RESTRICT="test"
 
+PATCHES="
+       "${FILESDIR}/${P}-boost-173-compatibility.patch"
+       "${FILESDIR}/${P}-gcc-10-compatibility.patch"
+"
+
 python_check_deps() {
        has_version "dev-python/sleekxmpp[${PYTHON_USEDEP}]"
 }