dev-ruby/addressable: cleanup
authorHans de Graaff <graaff@gentoo.org>
Sat, 18 Apr 2020 05:43:28 +0000 (07:43 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sat, 18 Apr 2020 05:43:28 +0000 (07:43 +0200)
Package-Manager: Portage-2.3.89, Repoman-2.3.20
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/addressable/Manifest
dev-ruby/addressable/addressable-2.5.2.ebuild [deleted file]

index c93f376d4ed983211fb50ea8fbd68bc5c60d3229..1025493d0264fd6f9653e040dc8410acff252696 100644 (file)
@@ -1,3 +1,2 @@
-DIST addressable-2.5.2.gem 103936 BLAKE2B c6677a2b5e9a7a1b279b2e3f1816cda40c0797254970ecaed2350d4d4739dee5a51580a8e2f94fc6bb87b9fe2a535d0a68b62eb672f8e91ff4da02e15e8dffcc SHA512 ddd5aeb4b241efa897a636fd85bd227bd5c6a8ae56129b6bbbdfaad85cdbb74e3d0db4bb6693f7df148b66f68ca1f557ac17a1fb0ea7698d25d883ab0b690bc4
 DIST addressable-2.6.0.gem 104448 BLAKE2B 664365962533d31786e2a362b61879fee544867b7aadc2ceb1ae6709374015a7f0f5c0bd32a81c8f2ae711a4ce1a07cd8f84821e74c3b6aa56b7474800567737 SHA512 71aa0ce8b61a07c1d01298dcd29cb2ba73d06ed1578908cae60351214f7d0bc6c9b8b0db7a78044fb1bed258bf00f2f093aa4e2bcb32575f4db2a79ee36b2648
 DIST addressable-2.7.0.gem 104960 BLAKE2B 4bca65d54ef1d3556cf4017ae68082635c0398b6f604eb3edc18da8f8e1e49e38b46485a8716da3c407fe0605dcc9a12c7a95be49a91c4198c2e2b1cab568805 SHA512 4c438bbfa8874fdcf11eef1d1f7cceb1855ea85948daff13615a0af129d35f92cc918f4bd5bbe4cd6ebccc67a86fc582265f915dc39831ec64209de0bdeeb732
diff --git a/dev-ruby/addressable/addressable-2.5.2.ebuild b/dev-ruby/addressable/addressable-2.5.2.ebuild
deleted file mode 100644 (file)
index 8dd64c7..0000000
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-USE_RUBY="ruby23 ruby24 ruby25 ruby26"
-
-RUBY_FAKEGEM_RECIPE_DOC="rdoc"
-RUBY_FAKEGEM_RECIPE_TEST="rspec3"
-
-RUBY_FAKEGEM_EXTRADOC="README.md CHANGELOG.md"
-
-RUBY_FAKEGEM_EXTRAINSTALL="data"
-
-inherit ruby-fakegem
-
-DESCRIPTION="A replacement for the URI implementation that is part of Ruby's standard library"
-HOMEPAGE="https://rubygems.org/gems/addressable https://github.com/sporkmonger/addressable"
-
-LICENSE="Apache-2.0"
-
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris ~x86-solaris"
-IUSE="doc test"
-
-ruby_add_rdepend ">=dev-ruby/public_suffix-2.0.2:* <dev-ruby/public_suffix-4:*"
-
-ruby_add_bdepend "test? ( dev-ruby/rspec-its )"
-
-all_ruby_prepare() {
-       # Remove spec-related tasks so that we don't need to require rspec
-       # just to build the documentation, bug 383611.
-       sed -i -e '/spectask/d' Rakefile || die
-       rm -f tasks/rspec.rake || die
-       sed -i -e '/bundler/ s:^:#:' \
-               -e '/^begin/,/^end/ s:^:#:' \
-               spec/spec_helper.rb || die
-
-       # Remove specs requiring network connectivity
-       rm -f spec/addressable/net_http_compat_spec.rb || die
-
-       # Remove spec that tests against an unreleased github fork
-       rm -f spec/addressable/rack_mount_compat_spec.rb || die
-}