dev-ml/ppx_compare: initial import; ebuild by me
authorAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 15:32:37 +0000 (16:32 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Fri, 5 Feb 2016 20:59:02 +0000 (21:59 +0100)
Package-Manager: portage-2.2.27
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ml/ppx_compare/Manifest [new file with mode: 0644]
dev-ml/ppx_compare/metadata.xml [new file with mode: 0644]
dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild [new file with mode: 0644]

diff --git a/dev-ml/ppx_compare/Manifest b/dev-ml/ppx_compare/Manifest
new file mode 100644 (file)
index 0000000..9173c3c
--- /dev/null
@@ -0,0 +1 @@
+DIST ppx_compare-113.24.00.tar.gz 57732 SHA256 1a7ce91dd28a1fdf0498949a7c2edf5850715fa7a7c4d2c8f80a88443df16ccf SHA512 ede556a29f77d8da4b0cdb5a97d6b298a0a2a8afd2a612f546587808a8a211d9c4aed86e7a33cd5357c130fba9a2d716e6c2cc4381ebe44564aa4a4eedabaecb WHIRLPOOL a45f05f967726620fcc413cdc4a9641c282af442b555c9f244346b6caba469e5f7060970e3985012babf66d78122b7a4034c8859d35b34277f734fc51242f16c
diff --git a/dev-ml/ppx_compare/metadata.xml b/dev-ml/ppx_compare/metadata.xml
new file mode 100644 (file)
index 0000000..ffac4d7
--- /dev/null
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+       <email>ml@gentoo.org</email>
+       <name>Gentoo ML Project</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild b/dev-ml/ppx_compare/ppx_compare-113.24.00.ebuild
new file mode 100644 (file)
index 0000000..7a7398f
--- /dev/null
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit oasis
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="Generation of comparison functions from types"
+HOMEPAGE="http://www.janestreet.com/ocaml"
+SRC_URI="http://ocaml.janestreet.com/ocaml-core/${PV%.*}/files/${MY_P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-ml/ppx_tools:=
+       dev-ml/ppx_driver:=
+       dev-ml/ppx_type_conv:=
+       dev-ml/ppx_core:="
+
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+DOCS=( CHANGES.md )