fixed bug #31002, used debian patches
authorRobin H. Johnson <robbat2@gentoo.org>
Mon, 13 Oct 2003 11:50:33 +0000 (11:50 +0000)
committerRobin H. Johnson <robbat2@gentoo.org>
Mon, 13 Oct 2003 11:50:33 +0000 (11:50 +0000)
sys-apps/acpi/Manifest
sys-apps/acpi/acpi-0.06-r5.ebuild [new file with mode: 0644]
sys-apps/acpi/files/digest-acpi-0.06-r5 [new file with mode: 0644]

index f23ac0685f6d2633c162db006775efebe81f5973..4c2cfe30d6ebe4e099cb6fed380477f448f8f392 100644 (file)
@@ -1,9 +1,6 @@
-MD5 94e1da7fdab883fc45edb96d812cb1f1 acpi_0.06-5.diff.gz 2627
-MD5 1cb43dcf13e8f72edf4dbbe736473252 acpi-0.06-r5.ebuild 1107
+MD5 32dfc1f0656092d5038ae0d149284619 acpi-0.06-r5.ebuild 1095
 MD5 f9e0d1bbae9f4ae5168039686da8a23b acpi-0.06.ebuild 808
-MD5 665c76a5f88b1726820e69fe89e8d019 ChangeLog 508
+MD5 30066202e5bb52b70be3fff22939421c ChangeLog 656
 MD5 d992d28bec4a3bfd72b441145091a58e metadata.xml 244
-MD5 8e141e7b67b1b6b168f4761059ff6561 files/acpi-0.06-gcc33.patch 3469
-MD5 d5499098810baf74f92a8a2265ef531c files/digest-acpi-0.06-r1 65
 MD5 110e12e115d1d3af995c88fa9db2639b files/digest-acpi-0.06-r5 127
 MD5 d5499098810baf74f92a8a2265ef531c files/digest-acpi-0.06 65
diff --git a/sys-apps/acpi/acpi-0.06-r5.ebuild b/sys-apps/acpi/acpi-0.06-r5.ebuild
new file mode 100644 (file)
index 0000000..8672c69
--- /dev/null
@@ -0,0 +1,37 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-apps/acpi/acpi-0.06-r5.ebuild,v 1.1 2003/10/13 11:50:30 robbat2 Exp $
+
+DESCRIPTION="Attempts to replicate the functionality of the 'old' apm command on ACPI systems, including battery and thermal information."
+HOMEPAGE="http://packages.debian.org/unstable/utils/acpi.html"
+
+SRC_URI_BASE="http://ftp.debian.org/debian/pool/main/${PN:0:1}/${PN}"
+SRC_URI_TGZ="${PN}_${PV}.orig.tar.gz"
+SRC_URI_PATCH="${PN}_${PV}-${PR/r}.diff.gz"
+SRC_URI="${SRC_URI_BASE}/${SRC_URI_TGZ} ${SRC_URI_BASE}/${SRC_URI_PATCH}"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-alpha -arm -hppa -mips -sparc x86"
+IUSE=""
+RDEPEND="virtual/glibc"
+DEPEND="${RDEPEND} sys-apps/help2man sys-devel/gcc"
+S=${WORKDIR}/${P}
+
+src_unpack() {
+       unpack ${SRC_URI_TGZ}
+       mv ${PN} ${P}
+       epatch ${DISTDIR}/${SRC_URI_PATCH}
+}
+
+src_compile() {
+       econf || die
+       emake || die
+       # build docs
+       emake -C doc || die
+}
+
+src_install() {
+       einstall || die
+       doman doc/acpi.1
+       dodoc AUTHORS CREDITS ChangeLog README
+}
diff --git a/sys-apps/acpi/files/digest-acpi-0.06-r5 b/sys-apps/acpi/files/digest-acpi-0.06-r5
new file mode 100644 (file)
index 0000000..ad9386f
--- /dev/null
@@ -0,0 +1,2 @@
+MD5 062a77b38b929fe34120c3f258fd01ba acpi_0.06.orig.tar.gz 42907
+MD5 94e1da7fdab883fc45edb96d812cb1f1 acpi_0.06-5.diff.gz 2627