version bump wrt bug #173074
authorWolfram Schlich <wschlich@gentoo.org>
Mon, 16 Apr 2007 16:47:03 +0000 (16:47 +0000)
committerWolfram Schlich <wschlich@gentoo.org>
Mon, 16 Apr 2007 16:47:03 +0000 (16:47 +0000)
Package-Manager: portage-2.1.2.3

net-analyzer/zabbix-agent/ChangeLog
net-analyzer/zabbix-agent/files/1.1.7/init.d/zabbix-agentd [new file with mode: 0644]
net-analyzer/zabbix-agent/files/1.1.7/zabbix_agent.conf [new file with mode: 0644]
net-analyzer/zabbix-agent/files/1.1.7/zabbix_agentd.conf [new file with mode: 0644]
net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.7 [new file with mode: 0644]
net-analyzer/zabbix-agent/zabbix-agent-1.1.7.ebuild [new file with mode: 0644]
net-analyzer/zabbix-frontend/ChangeLog
net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1.7 [new file with mode: 0644]
net-analyzer/zabbix-frontend/files/postinstall-en-1.1.7.txt [new file with mode: 0644]
net-analyzer/zabbix-frontend/zabbix-frontend-1.1.7.ebuild [new file with mode: 0644]

index 8e5391c6e6cb6a27f3edfec3aad4b4a6249e29fc..8ce5515d449a8614ed3874c04d07963403f16c47 100644 (file)
@@ -1,6 +1,13 @@
 # ChangeLog for net-analyzer/zabbix-agent
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.9 2007/02/12 00:14:43 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/ChangeLog,v 1.10 2007/04/16 16:44:11 wschlich Exp $
+
+*zabbix-agent-1.1.7 (16 Apr 2007)
+
+  16 Apr 2007; Wolfram Schlich <wschlich@gentoo.org>
+  +files/1.1.7/init.d/zabbix-agentd, +files/1.1.7/zabbix_agent.conf,
+  +files/1.1.7/zabbix_agentd.conf, +zabbix-agent-1.1.7.ebuild:
+  version bump wrt bug #173074
 
 *zabbix-agent-1.1.6 (12 Feb 2007)
 
diff --git a/net-analyzer/zabbix-agent/files/1.1.7/init.d/zabbix-agentd b/net-analyzer/zabbix-agent/files/1.1.7/init.d/zabbix-agentd
new file mode 100644 (file)
index 0000000..1eb69cb
--- /dev/null
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/files/1.1.7/init.d/zabbix-agentd,v 1.1 2007/04/16 16:44:11 wschlich Exp $
+
+depend() {
+       need net
+       provide zabbix-agent
+       use zabbix-server
+}
+
+start() {
+       ebegin "Starting Zabbix agent"
+       start-stop-daemon --start -c zabbix:zabbix --exec /usr/sbin/zabbix_agentd
+       eend $?
+}
+
+stop() {
+       ebegin "Stopping Zabbix agent"
+       start-stop-daemon  --stop -u zabbix --pidfile /var/run/zabbix/zabbix_agentd.pid
+       eend $?
+}
diff --git a/net-analyzer/zabbix-agent/files/1.1.7/zabbix_agent.conf b/net-analyzer/zabbix-agent/files/1.1.7/zabbix_agent.conf
new file mode 100644 (file)
index 0000000..4299738
--- /dev/null
@@ -0,0 +1,25 @@
+# This is config file for zabbix_agent
+# To get more information about ZABBIX, 
+# go http://www.zabbix.com
+
+# IP address of ZABBIX server
+# Connections from other hosts will be denied
+Server=127.0.0.1
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/1.1.7/zabbix_agentd.conf b/net-analyzer/zabbix-agent/files/1.1.7/zabbix_agentd.conf
new file mode 100644 (file)
index 0000000..e040f17
--- /dev/null
@@ -0,0 +1,70 @@
+# This is config file for zabbix_agentd
+# To get more information about ZABBIX, go http://www.zabbix.com
+
+############ GENERAL PARAMETERS #################
+
+# List of comma delimited IP addresses (or hostnames) of ZABBIX servers. 
+# No spaces allowed. First entry is used for sending active checks.
+# Note that hostnames must resolve hostname->IP address and
+# IP address->hostname.
+Server=127.0.0.1
+
+# Server port for sending active checks
+ServerPort=10051
+
+# Unique hostname. Required for active checks.
+Hostname=localhost
+
+# Listen port. Default is 10050
+ListenPort=10050
+
+# IP address to bind agent
+# If missing, bind to all available IPs
+ListenIP=127.0.0.1
+
+# Number of pre-forked instances of zabbix_agentd.
+# Default value is 5
+# This parameter must be between 1 and 16
+StartAgents=5
+
+# How often refresh list of active checks. 2 minutes by default.
+#RefreshActiveChecks=120
+
+# Disable active checks. The agent will work in passive mode listening server.
+#DisableActive=1
+
+# Enable remote commands for ZABBIX agent. By default remote commands disabled.
+#EnableRemoteCommands=1
+
+# Specifies debug level
+# 0 - debug is not created
+# 1 - critical information
+# 2 - error information
+# 3 - warnings (default)
+# 4 - for debugging (produces lots of information)
+DebugLevel=3
+
+# Name of PID file
+PidFile=/var/run/zabbix/zabbix_agentd.pid
+
+# Name of log file.
+# If not set, syslog will be used
+LogFile=/var/log/zabbix/zabbix_agentd.log
+
+# Spend no more than Timeout seconds on processing
+# Must be between 1 and 30
+Timeout=3
+
+####### USER-DEFINED MONITORED PARAMETERS #######
+# Format: UserParameter=<key>,<shell command>
+# Note that shell command must not return empty string or EOL only
+#UserParameter=system.test,who|wc -l
+### Set of parameter for monitoring MySQL server (v3.23.42 and later)
+### Change -u<username> and add -p<password> if required
+#UserParameter=mysql.ping,mysqladmin -uroot ping|grep alive|wc -l
+#UserParameter=mysql.uptime,mysqladmin -uroot status|cut -f2 -d":"|cut -f1 -d"T"
+#UserParameter=mysql.threads,mysqladmin -uroot status|cut -f3 -d":"|cut -f1 -d"Q"
+#UserParameter=mysql.questions,mysqladmin -uroot status|cut -f4 -d":"|cut -f1 -d"S"
+#UserParameter=mysql.slowqueries,mysqladmin -uroot status|cut -f5 -d":"|cut -f1 -d"O"
+#UserParameter=mysql.qps,mysqladmin -uroot status|cut -f9 -d":"
+#UserParameter=mysql.version,mysql -V
diff --git a/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.7 b/net-analyzer/zabbix-agent/files/digest-zabbix-agent-1.1.7
new file mode 100644 (file)
index 0000000..2926f2e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ac24ab58ef1a985c1e2a5217386d5dba zabbix-1.1.7.tar.gz 1515333
+RMD160 f09833ec59639dce6d83a7739f7a626ec6f8df0b zabbix-1.1.7.tar.gz 1515333
+SHA256 6354cd7ab311212f027e71ca78ff607f50b6323fe044d50ec1b76dc6b2878f20 zabbix-1.1.7.tar.gz 1515333
diff --git a/net-analyzer/zabbix-agent/zabbix-agent-1.1.7.ebuild b/net-analyzer/zabbix-agent/zabbix-agent-1.1.7.ebuild
new file mode 100644 (file)
index 0000000..923f994
--- /dev/null
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-agent/zabbix-agent-1.1.7.ebuild,v 1.1 2007/04/16 16:44:11 wschlich Exp $
+
+inherit eutils
+
+MY_P=${PN//-agent/}
+MY_PV=${PV//_/}
+DESCRIPTION="ZABBIX is software for monitoring of your applications, network and servers. Agent part."
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/libc"
+
+S=${WORKDIR}/${MY_P}-${MY_PV}
+
+pkg_setup() {
+       enewgroup zabbix
+       enewuser zabbix -1 -1 /dev/null zabbix
+}
+pkg_postinst() {
+       # repeat fowners/fperms functionality from src_install()
+       # here to catch wrong permissions on existing files in
+       # the live filesystem (yeah, that sucks).
+       chown zabbix:zabbix \
+               ${ROOT}etc/zabbix \
+               ${ROOT}etc/zabbix/zabbix_agent.conf \
+               ${ROOT}etc/zabbix/zabbix_agentd.conf \
+               ${ROOT}var/log/zabbix \
+               ${ROOT}var/run/zabbix
+       chmod 0750 \
+               ${ROOT}etc/zabbix \
+               ${ROOT}var/log/zabbix \
+               ${ROOT}var/run/zabbix
+       chmod 0640 \
+               ${ROOT}etc/zabbix/zabbix_agent.conf \
+               ${ROOT}etc/zabbix/zabbix_agentd.conf
+}
+
+src_compile() {
+       econf --enable-agent || die "econf failed"
+       emake || die "emake failed"
+}
+
+src_install() {
+       dodir \
+               /etc/zabbix \
+               /var/log/zabbix \
+               /var/run/zabbix
+       keepdir \
+               /etc/zabbix \
+               /var/log/zabbix \
+               /var/run/zabbix
+       insinto /etc/zabbix
+       doins \
+               ${FILESDIR}/${PV}/zabbix_agent.conf \
+               ${FILESDIR}/${PV}/zabbix_agentd.conf
+       doinitd ${FILESDIR}/${PV}/init.d/zabbix-agentd
+       dosbin \
+               src/zabbix_agent/zabbix_agent \
+               src/zabbix_agent/zabbix_agentd
+       dobin \
+               src/zabbix_sender/zabbix_sender \
+               src/zabbix_get/zabbix_get
+       fowners zabbix:zabbix \
+               /etc/zabbix \
+               /etc/zabbix/zabbix_agent.conf \
+               /etc/zabbix/zabbix_agentd.conf \
+               /var/log/zabbix \
+               /var/run/zabbix
+       fperms 0750 \
+               /etc/zabbix \
+               /var/log/zabbix \
+               /var/run/zabbix
+       fperms 0640 \
+               /etc/zabbix/zabbix_agent.conf \
+               /etc/zabbix/zabbix_agentd.conf
+}
index 69d527eb9ee3bf5a460104e2bca51957c72464ad..ef518ccdef6aba1622f837d493f72f4b526e0e29 100644 (file)
@@ -1,6 +1,12 @@
 # ChangeLog for net-analyzer/zabbix-frontend
 # Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/ChangeLog,v 1.6 2007/02/12 01:01:01 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/ChangeLog,v 1.7 2007/04/16 16:47:03 wschlich Exp $
+
+*zabbix-frontend-1.1.7 (16 Apr 2007)
+
+  16 Apr 2007; Wolfram Schlich <wschlich@gentoo.org>
+  +files/postinstall-en-1.1.7.txt, +zabbix-frontend-1.1.7.ebuild:
+  version bump wrt bug #173074
 
 *zabbix-frontend-1.1.6 (12 Feb 2007)
 
diff --git a/net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1.7 b/net-analyzer/zabbix-frontend/files/digest-zabbix-frontend-1.1.7
new file mode 100644 (file)
index 0000000..2926f2e
--- /dev/null
@@ -0,0 +1,3 @@
+MD5 ac24ab58ef1a985c1e2a5217386d5dba zabbix-1.1.7.tar.gz 1515333
+RMD160 f09833ec59639dce6d83a7739f7a626ec6f8df0b zabbix-1.1.7.tar.gz 1515333
+SHA256 6354cd7ab311212f027e71ca78ff607f50b6323fe044d50ec1b76dc6b2878f20 zabbix-1.1.7.tar.gz 1515333
diff --git a/net-analyzer/zabbix-frontend/files/postinstall-en-1.1.7.txt b/net-analyzer/zabbix-frontend/files/postinstall-en-1.1.7.txt
new file mode 100644 (file)
index 0000000..9d13a9f
--- /dev/null
@@ -0,0 +1,8 @@
+Please change the values of the following variables in
+${MY_HTDOCSDIR}/include/db.inc.php:
+
+       DB_TYPE
+       DB_SERVER
+       DB_DATABASE
+       DB_USER
+       DB_PASSWORD
diff --git a/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.7.ebuild b/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.7.ebuild
new file mode 100644 (file)
index 0000000..d13dd5d
--- /dev/null
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-analyzer/zabbix-frontend/zabbix-frontend-1.1.7.ebuild,v 1.1 2007/04/16 16:47:03 wschlich Exp $
+
+inherit eutils webapp depend.php
+
+MY_P=${PN//-frontend/}
+MY_PV=${PV//_/}
+DESCRIPTION="Zabbix PHP web-frontend"
+
+HOMEPAGE="http://www.zabbix.com/"
+SRC_URI="mirror://sourceforge/zabbix/${MY_P}-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+need_php_httpd
+
+S=${WORKDIR}/${MY_P}-${MY_PV}/frontends
+
+pkg_setup() {
+       webapp_pkg_setup
+       require_gd
+}
+
+src_install() {
+       webapp_src_preinst
+       cp -R php/* "${D}/${MY_HTDOCSDIR}"
+       webapp_postinst_txt en ${FILESDIR}/postinstall-en-${MY_PV}.txt
+       webapp_configfile ${MY_HTDOCSDIR}/include/db.inc.php
+       webapp_src_install
+}