dev-ros/ament_cmake_core: initial import
authorAlexis Ballier <aballier@gentoo.org>
Wed, 11 Dec 2019 16:47:39 +0000 (17:47 +0100)
committerAlexis Ballier <aballier@gentoo.org>
Thu, 12 Dec 2019 10:41:59 +0000 (11:41 +0100)
Package-Manager: Portage-2.3.81, Repoman-2.3.20
Signed-off-by: Alexis Ballier <aballier@gentoo.org>
dev-ros/ament_cmake_core/Manifest [new file with mode: 0644]
dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild [new file with mode: 0644]
dev-ros/ament_cmake_core/metadata.xml [new file with mode: 0644]

diff --git a/dev-ros/ament_cmake_core/Manifest b/dev-ros/ament_cmake_core/Manifest
new file mode 100644 (file)
index 0000000..ed522b7
--- /dev/null
@@ -0,0 +1 @@
+DIST ament_cmake-0.8.1.tar.gz 57078 BLAKE2B 4c6d5c821ffef6288cdd400aa9b084fcbfb33d6c9accddd1349bd656d3b3de9e779603bdad256e3f74a292e3805f06e00ba85719f09fe441f6eecdbd236cc878 SHA512 ae6bfe95585a331055ae159f8b4363f237602ece929877766a8c8bd5bfc0b423379dee38e9fe2707f92ed9753564281be13af1202ec4e9b545d293485884f35e
diff --git a/dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild b/dev-ros/ament_cmake_core/ament_cmake_core-0.8.1.ebuild
new file mode 100644 (file)
index 0000000..da964f3
--- /dev/null
@@ -0,0 +1,36 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{3_6,3_7} )
+
+inherit cmake-utils python-r1
+
+ROS_PN="ament_cmake"
+DESCRIPTION="The core of the ament buildsystem in CMake"
+HOMEPAGE="https://github.com/ament/ament_cmake"
+SRC_URI="https://github.com/ament/ament_cmake/archive/${PV}.tar.gz -> ${ROS_PN}-${PV}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+DEPEND="
+       dev-python/ament_package[${PYTHON_USEDEP}]
+       dev-python/catkin_pkg[${PYTHON_USEDEP}]
+"
+RDEPEND="${DEPEND}"
+BDEPEND="${PYTHON_DEPS}"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+S="${WORKDIR}/${ROS_PN}-${PV}/${PN}"
+
+src_configure() {
+       # This is a build tool that does not install python-related files
+       # ... but we need to propagate the deps and use python3 to build it.
+       local pyimpl="${PYTHON_COMPAT[0]}"
+       python_export "${pyimpl}" EPYTHON PYTHON
+       python_wrapper_setup
+       cmake-utils_src_configure
+}
diff --git a/dev-ros/ament_cmake_core/metadata.xml b/dev-ros/ament_cmake_core/metadata.xml
new file mode 100644 (file)
index 0000000..d1baaf5
--- /dev/null
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+       <maintainer type="project">
+               <email>ros@gentoo.org</email>
+               <name>Gentoo ROS Project</name>
+       </maintainer>
+       <upstream>
+               <remote-id type="github">ament/ament_cmake</remote-id>
+       </upstream>
+</pkgmetadata>