app-admin/salt: Clean out vunlerable versions (bug #720056)
authorPatrick McLean <patrick.mclean@sony.com>
Thu, 30 Apr 2020 17:58:03 +0000 (10:58 -0700)
committerPatrick McLean <chutzpah@gentoo.org>
Thu, 30 Apr 2020 17:58:03 +0000 (10:58 -0700)
Bug: https://bugs.gentoo.org/720056
Copyright: Sony Interactive Entertainment Inc.
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
app-admin/salt/Manifest
app-admin/salt/files/salt-2018.3.2-skip-zeromq-test-that-hangs.patch [deleted file]
app-admin/salt/files/salt-2018.3.4-tests.patch [deleted file]
app-admin/salt/salt-2018.3.4.ebuild [deleted file]

index 1e5653bb58c24dbe76b4593cb22f7936fc5f094a..64303c5476b1b3cb8adcafcab440dfa459ea8611 100644 (file)
@@ -1,3 +1,2 @@
-DIST salt-2018.3.4.tar.gz 14404085 BLAKE2B 932b30b1ba60aefd3a6874a8ebe4cb6c469d82e31f6acdbe8a5641d09e3316796b5403ef803a355cec6255c1aede8bac3b66af179bd1bbaa5418c7076229cef9 SHA512 f17e06fdbf4741f231d9e769be57de4f6079e9283881b4bafa0d23928d7626a1f9c02b9f49c654b29c3e6ee8ed3d3ddf42c21baecef158ad63a97dc87895b21b
 DIST salt-2019.2.4.tar.gz 14572556 BLAKE2B a1057baa5ab6c0a07f34ce658a1d5bc644f968600663d28d084eb712b55faaee93b8410d81c4b5324944e6e1f2067ffb102200088832e1b0076fed78c8542ae6 SHA512 9e621cbd78ead1060a2b0c07e7ef02e8c4590360a95c51ac29fa8c1add34f617e4407dd28b67cae3b0fd68b333782185edcf1159edd2db08e8b4e79b6b07a63f
 DIST salt-3000.2.tar.gz 15231513 BLAKE2B 2090d0f52f953a42f1685ad190750e9c76ad6e862a3272444fef063a7605f69a6c542f04165a41fb9cdaa126a878cc133d4857faa70edc5eac4bf49bdde937ab SHA512 88e8876ed8cd18e942c2194686cda68f40fa49e69e317ca488bf58e095bcf6cdf8771d93eba7960038941cc5863e13a4eea4dad5256c12da7cd8288a2c61f59d
diff --git a/app-admin/salt/files/salt-2018.3.2-skip-zeromq-test-that-hangs.patch b/app-admin/salt/files/salt-2018.3.2-skip-zeromq-test-that-hangs.patch
deleted file mode 100644 (file)
index 7b94faf..0000000
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/tests/unit/transport/test_zeromq.py b/tests/unit/transport/test_zeromq.py
-index ccb337462e..97d2962e5e 100644
---- a/tests/unit/transport/test_zeromq.py
-+++ b/tests/unit/transport/test_zeromq.py
-@@ -45,6 +45,10 @@ ON_SUSE = False
- if 'SuSE' in linux_distribution(full_distribution_name=False):
-     ON_SUSE = True
-+ON_GENTOO = False
-+if 'Gentoo' in linux_distribution(full_distribution_name=False):
-+    ON_GENTOO = True
-+
- class BaseZMQReqCase(TestCase, AdaptedConfigurationTestCaseMixin):
-     '''
-@@ -122,63 +126,6 @@ class BaseZMQReqCase(TestCase, AdaptedConfigurationTestCaseMixin):
-         return payload, {'fun': 'send_clear'}
--class ClearReqTestCases(BaseZMQReqCase, ReqChannelMixin):
--    '''
--    Test all of the clear msg stuff
--    '''
--    def setUp(self):
--        self.channel = salt.transport.client.ReqChannel.factory(self.minion_config, crypt='clear')
--
--    def tearDown(self):
--        del self.channel
--
--    @classmethod
--    @tornado.gen.coroutine
--    def _handle_payload(cls, payload):
--        '''
--        TODO: something besides echo
--        '''
--        raise tornado.gen.Return((payload, {'fun': 'send_clear'}))
--
--
--@flaky
--@skipIf(ON_SUSE, 'Skipping until https://github.com/saltstack/salt/issues/32902 gets fixed')
--class AESReqTestCases(BaseZMQReqCase, ReqChannelMixin):
--    def setUp(self):
--        self.channel = salt.transport.client.ReqChannel.factory(self.minion_config)
--
--    def tearDown(self):
--        del self.channel
--
--    @classmethod
--    @tornado.gen.coroutine
--    def _handle_payload(cls, payload):
--        '''
--        TODO: something besides echo
--        '''
--        raise tornado.gen.Return((payload, {'fun': 'send'}))
--
--    # TODO: make failed returns have a specific framing so we can raise the same exception
--    # on encrypted channels
--    #
--    #!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
--    #
--    # WARNING: This test will fail randomly on any system with > 1 CPU core!!!
--    #
--    #!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!
--    def test_badload(self):
--        '''
--        Test a variety of bad requests, make sure that we get some sort of error
--        '''
--        # TODO: This test should be re-enabled when Jenkins moves to C7.
--        # Once the version of salt-testing is increased to something newer than the September
--        # release of salt-testing, the @flaky decorator should be applied to this test.
--        msgs = ['', [], tuple()]
--        for msg in msgs:
--            with self.assertRaises(salt.exceptions.AuthenticationError):
--                ret = self.channel.send(msg, timeout=5)
--
--
- class BaseZMQPubCase(AsyncTestCase, AdaptedConfigurationTestCaseMixin):
-     '''
-     Test the req server/client pair
diff --git a/app-admin/salt/files/salt-2018.3.4-tests.patch b/app-admin/salt/files/salt-2018.3.4-tests.patch
deleted file mode 100644 (file)
index ac3dbb8..0000000
+++ /dev/null
@@ -1,76 +0,0 @@
-diff --git a/tests/unit/grains/test_core.py b/tests/unit/grains/test_core.py
-index 3874b0001c..40304075eb 100644
---- a/tests/unit/grains/test_core.py
-+++ b/tests/unit/grains/test_core.py
-@@ -685,22 +685,6 @@ class CoreGrainsTestCase(TestCase, LoaderModuleMockMixin):
-                                 'Docker'
-                             )
--    @skipIf(salt.utils.platform.is_windows(), 'System is Windows')
--    def test_xen_virtual(self):
--        '''
--        Test if OS grains are parsed correctly in Ubuntu Xenial Xerus
--        '''
--        with patch.object(os.path, 'isfile', MagicMock(return_value=False)):
--            with patch.dict(core.__salt__, {'cmd.run': MagicMock(return_value='')}), \
--                patch.object(os.path,
--                             'isfile',
--                             MagicMock(side_effect=lambda x: True if x == '/sys/bus/xen/drivers/xenconsole' else False)):
--                log.debug('Testing Xen')
--                self.assertEqual(
--                    core._virtual({'kernel': 'Linux'}).get('virtual_subtype'),
--                    'Xen PV DomU'
--                )
--
-     def _check_ipaddress(self, value, ip_v):
-         '''
-         check if ip address in a list is valid
-diff --git a/tests/unit/utils/test_asynchronous.py b/tests/unit/utils/test_asynchronous.py
-index 694a7aebfe..9e22c278e9 100644
---- a/tests/unit/utils/test_asynchronous.py
-+++ b/tests/unit/utils/test_asynchronous.py
-@@ -35,19 +35,6 @@ class HelperB(object):
- class TestSyncWrapper(AsyncTestCase):
--    @tornado.testing.gen_test
--    def test_helpers(self):
--        '''
--        Test that the helper classes do what we expect within a regular asynchronous env
--        '''
--        ha = HelperA()
--        ret = yield ha.sleep()
--        self.assertTrue(ret)
--
--        hb = HelperB()
--        ret = yield hb.sleep()
--        self.assertFalse(ret)
--
-     def test_basic_wrap(self):
-         '''
-         Test that we can wrap an asynchronous caller.
-@@ -55,24 +42,3 @@ class TestSyncWrapper(AsyncTestCase):
-         sync = asynchronous.SyncWrapper(HelperA)
-         ret = sync.sleep()
-         self.assertTrue(ret)
--
--    def test_double(self):
--        '''
--        Test when the asynchronous wrapper object itself creates a wrap of another thing
--
--        This works fine since the second wrap is based on the first's IOLoop so we
--        don't have to worry about complex start/stop mechanics
--        '''
--        sync = asynchronous.SyncWrapper(HelperB)
--        ret = sync.sleep()
--        self.assertFalse(ret)
--
--    def test_double_sameloop(self):
--        '''
--        Test asynchronous wrappers initiated from the same IOLoop, to ensure that
--        we don't wire up both to the same IOLoop (since it causes MANY problems).
--        '''
--        a = asynchronous.SyncWrapper(HelperA)
--        sync = asynchronous.SyncWrapper(HelperB, (a,))
--        ret = sync.sleep()
--        self.assertFalse(ret)
diff --git a/app-admin/salt/salt-2018.3.4.ebuild b/app-admin/salt/salt-2018.3.4.ebuild
deleted file mode 100644 (file)
index 20f68c6..0000000
+++ /dev/null
@@ -1,147 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_6 )
-
-inherit eutils systemd distutils-r1
-
-DESCRIPTION="Salt is a remote execution and configuration manager"
-HOMEPAGE="https://www.saltstack.com/resources/community/
-       https://github.com/saltstack"
-
-if [[ ${PV} == 9999* ]]; then
-       inherit git-r3
-       EGIT_REPO_URI="git://github.com/${PN}stack/${PN}.git"
-       EGIT_BRANCH="develop"
-       SRC_URI=""
-       KEYWORDS=""
-else
-       SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-       KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="Apache-2.0"
-SLOT="0"
-IUSE="cherrypy ldap libcloud libvirt gnupg keyring mako mongodb neutron nova"
-IUSE+=" openssl portage profile redis selinux test raet +zeromq vim-syntax"
-
-RDEPEND="sys-apps/pciutils
-       dev-python/jinja[${PYTHON_USEDEP}]
-       dev-python/libnacl[${PYTHON_USEDEP}]
-       >=dev-python/msgpack-0.3[${PYTHON_USEDEP}]
-       dev-python/pyyaml[${PYTHON_USEDEP}]
-       dev-python/markupsafe[${PYTHON_USEDEP}]
-       >=dev-python/requests-1.0.0[${PYTHON_USEDEP}]
-       dev-python/setuptools[${PYTHON_USEDEP}]
-       >=www-servers/tornado-4.2.1[${PYTHON_USEDEP}]
-       <www-servers/tornado-5.0[${PYTHON_USEDEP}]
-       libcloud? ( >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}] )
-       mako? ( dev-python/mako[${PYTHON_USEDEP}] )
-       ldap? ( dev-python/python-ldap[${PYTHON_USEDEP}] )
-       libvirt? ( dev-python/libvirt-python[${PYTHON_USEDEP}] )
-       openssl? (
-               dev-libs/openssl:0=[-bindist]
-               dev-python/pyopenssl[${PYTHON_USEDEP}]
-       )
-       raet? (
-               >=dev-python/libnacl-1.0.0[${PYTHON_USEDEP}]
-               >=dev-python/ioflo-1.1.7[${PYTHON_USEDEP}]
-               >=dev-python/raet-0.6.0[${PYTHON_USEDEP}]
-       )
-       zeromq? (
-               >=dev-python/pyzmq-2.2.0[${PYTHON_USEDEP}]
-               dev-python/pycryptodome[${PYTHON_USEDEP}]
-       )
-       cherrypy? ( >=dev-python/cherrypy-3.2.2[${PYTHON_USEDEP}] )
-       mongodb? ( dev-python/pymongo[${PYTHON_USEDEP}] )
-       portage? ( sys-apps/portage[${PYTHON_USEDEP}] )
-       keyring? ( dev-python/keyring[${PYTHON_USEDEP}] )
-       redis? ( dev-python/redis-py[${PYTHON_USEDEP}] )
-       selinux? ( sec-policy/selinux-salt )
-       nova? ( >=dev-python/python-novaclient-2.17.0[${PYTHON_USEDEP}] )
-       neutron? ( >=dev-python/python-neutronclient-2.3.6[${PYTHON_USEDEP}] )
-       gnupg? ( dev-python/python-gnupg[${PYTHON_USEDEP}] )
-       profile? ( dev-python/yappi[${PYTHON_USEDEP}] )
-       vim-syntax? ( app-vim/salt-vim )"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
-       test? (
-               dev-python/pytest-salt[${PYTHON_USEDEP}]
-               dev-python/psutil[${PYTHON_USEDEP}]
-               dev-python/pytest[${PYTHON_USEDEP}]
-               dev-python/pytest-catchlog[${PYTHON_USEDEP}]
-               dev-python/pip[${PYTHON_USEDEP}]
-               dev-python/virtualenv[${PYTHON_USEDEP}]
-               >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
-               >=dev-python/boto-2.32.1[${PYTHON_USEDEP}]
-               !x86? ( >=dev-python/boto3-1.2.1[${PYTHON_USEDEP}] )
-               >=dev-python/moto-0.3.6[${PYTHON_USEDEP}]
-               >=dev-python/SaltTesting-2016.5.11[${PYTHON_USEDEP}]
-               >=dev-python/libcloud-0.14.0[${PYTHON_USEDEP}]
-               ${RDEPEND}
-       )"
-
-DOCS=( README.rst AUTHORS )
-
-REQUIRED_USE="|| ( raet zeromq )"
-RESTRICT="!test? ( test ) x86? ( test )"
-
-PATCHES=(
-       "${FILESDIR}/${PN}-2017.7.0-dont-realpath-tmpdir.patch"
-       "${FILESDIR}/${PN}-2018.3.4-tests.patch"
-       "${FILESDIR}/${PN}-2018.3.2-skip-zeromq-test-that-hangs.patch"
-)
-
-python_prepare() {
-       # remove tests with external dependencies that may not be available
-       rm tests/unit/{test_zypp_plugins.py,utils/test_extend.py} || die
-       rm tests/unit/modules/test_{file,boto_{vpc,secgroup,elb}}.py || die
-       rm tests/unit/states/test_boto_vpc.py || die
-       rm tests/unit/modules/test_{kubernetes,vsphere}.py || die
-
-       # allow the use of the renamed msgpack
-       sed -i '/^msgpack/d' requirements/base.txt || die
-}
-
-python_install_all() {
-       local svc
-       USE_SETUPTOOLS=1 distutils-r1_python_install_all
-
-       for svc in minion master syndic api; do
-               newinitd "${FILESDIR}"/${svc}-initd-4 salt-${svc}
-               newconfd "${FILESDIR}"/${svc}-confd-1 salt-${svc}
-               systemd_dounit "${FILESDIR}"/salt-${svc}.service
-       done
-
-       insinto /etc/${PN}
-       doins -r conf/*
-}
-
-python_test() {
-       local tempdir
-       # testsuite likes lots of files
-       ulimit -n 3072 || die
-
-       # ${T} is too long a path for the tests to work
-       tempdir="$(mktemp -du --tmpdir=/tmp salt-XXX)"
-       mkdir "${T}/$(basename "${tempdir}")"
-       mkdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-
-       (
-               cleanup() {
-                       rm -f "${tempdir}"
-                       rmdir "${BUILD_DIR}"/../{templates,conf/cloud.{providers,profiles,maps}.d} || die
-               }
-
-               trap cleanup EXIT
-
-               addwrite "${tempdir}"
-               ln -s "$(realpath --relative-to=/tmp "${T}/$(basename "${tempdir}")")" "${tempdir}"
-
-               USE_SETUPTOOLS=1 SHELL="/bin/bash" \
-                       TMPDIR="${tempdir}" \
-                       ${EPYTHON} tests/runtests.py \
-                       --unit-tests --no-report --verbose
-
-       ) || die "testing failed"
-}