dev-python/qtconsole: Version bump to 4.3.0
authorMarius Brehler <marbre@linux.sungazer.de>
Wed, 5 Apr 2017 07:26:41 +0000 (09:26 +0200)
committerDavid Seifert <soap@gentoo.org>
Sun, 16 Apr 2017 19:05:06 +0000 (21:05 +0200)
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Closes: https://github.com/gentoo/gentoo/pull/4362

dev-python/qtconsole/Manifest
dev-python/qtconsole/qtconsole-4.3.0.ebuild [new file with mode: 0644]

index 890375671e7a947527e13597f002b302e99ba2a3..19d8b8521ca0213faeb2b8ac7de0d3ee1099b811 100644 (file)
@@ -1,2 +1,3 @@
 DIST qtconsole-4.1.1.tar.gz 406257 SHA256 741906acae9e02c0df9138ac88b621ef22e438565aa96d783a9ef88faec3de46 SHA512 2848eb8d3a8816a47ca422b24837372899864e750336509f3d8444333d0783bae46b9917258cab14d4e09d91d5068a7772fb849a267e1a7d6e282c7c75e9f4e9 WHIRLPOOL 1a3a638be2bdea3f9ab6d625edd110ef698a84cfdf3b1f4101375faf8ed60a0e8e9ab6e297575dab8e2e6389107ba62a6bb338c78934780e19dd4c498aee9eb9
 DIST qtconsole-4.2.1.tar.gz 408430 SHA256 25ec7d345528b3e8f3c91be349dd3c699755f206dc4b6ec668e2e5dd60ea18ef SHA512 f207e55be159d32cff25d017e12a598564ce106394382c9ac5277f8025aa9201ac4be13711a9a991a2877280f17490e40a6a90649983ca586f25091d62a2848d WHIRLPOOL ab6dece8c1bbf49a23ab14b3911e019f636a7ab46003866943313881d9fcead75391114dd726684347ea880d55f0c47df8266154b04bf8954a56080f186044c6
+DIST qtconsole-4.3.0.tar.gz 416877 SHA256 2821ccf85853b83e4958521f82e36325208787eaf79b19b83905a99cc41aa209 SHA512 50e8d04152b90e85989ee6f1f182ae0f788d5f231311fcd61170b7a7c20a9a32d35918810ccb85e38be6b2092791c7fa9ac8726524100bca12d9ae6a949acc54 WHIRLPOOL 239686bea6e5db6c926b5e4d38e36e8e644df44c3de3a6c4756d9345713586e9e8b3cdf4cbe605aaca3fd77ca502abcd4a3e745955a20e23ab67d934c2f46f7b
diff --git a/dev-python/qtconsole/qtconsole-4.3.0.ebuild b/dev-python/qtconsole/qtconsole-4.3.0.ebuild
new file mode 100644 (file)
index 0000000..4ab1876
--- /dev/null
@@ -0,0 +1,71 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Qt-based console for Jupyter with support for rich media output"
+HOMEPAGE="http://jupyter.org"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+       dev-python/ipykernel[${PYTHON_USEDEP}]
+       dev-python/ipython_genutils[${PYTHON_USEDEP}]
+       >=dev-python/jupyter_client-4.1.1[${PYTHON_USEDEP}]
+       "
+DEPEND="${RDEPEND}
+       doc? (
+               >=dev-python/ipython-4.0.0-r2[${PYTHON_USEDEP}]
+               >=dev-python/sphinx-1.3.1-r1[${PYTHON_USEDEP}]
+       )
+       test? (
+               >=dev-python/nose-0.10.1[${PYTHON_USEDEP}]
+               || (
+                       dev-python/pyside[${PYTHON_USEDEP},svg]
+                       dev-python/PyQt5[${PYTHON_USEDEP},svg,testlib]
+                       dev-python/PyQt4[${PYTHON_USEDEP},svg,testlib]
+               )
+       )
+       || (
+               dev-python/pyside[${PYTHON_USEDEP},svg]
+               dev-python/PyQt5[${PYTHON_USEDEP},svg]
+               dev-python/PyQt4[${PYTHON_USEDEP},svg]
+       )
+       dev-python/pygments[${PYTHON_USEDEP}]
+       >=dev-python/pyzmq-13[${PYTHON_USEDEP}]
+       "
+PDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+
+python_prepare_all() {
+       # Prevent un-needed download during build
+       if use doc; then
+               sed -e "/^    'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
+       fi
+
+       distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+       if use doc; then
+               emake -C docs html
+               HTML_DOCS=( docs/build/html/. )
+       fi
+}
+
+python_test() {
+       # jupyter qtconsole --generate-config ... jupyter-qtconsole: cannot connect to X server
+       # ERROR
+       sed \
+               -e 's:test_generate_config:_&:g' \
+               -i qtconsole/tests/test_app.py || die
+       virtx nosetests --verbosity=2 qtconsole
+}