projects
/
gentoo.git
/ commitdiff
commit
grep
author
committer
pickaxe
?
search:
re
summary
|
shortlog
|
log
|
commit
| commitdiff |
tree
raw
|
patch
| inline |
side by side
(parent:
cd67c54
)
dev-python/zstandard: Backport parallel build workaround to 0.12.0
author
Michał Górny
<mgorny@gentoo.org>
Wed, 12 Feb 2020 10:36:37 +0000
(11:36 +0100)
committer
Michał Górny
<mgorny@gentoo.org>
Wed, 12 Feb 2020 10:43:46 +0000
(11:43 +0100)
Closes: https://bugs.gentoo.org/709296
Signed-off-by: Michał Górny <mgorny@gentoo.org>
dev-python/zstandard/zstandard-0.12.0.ebuild
patch
|
blob
|
history
diff --git
a/dev-python/zstandard/zstandard-0.12.0.ebuild
b/dev-python/zstandard/zstandard-0.12.0.ebuild
index cad7581663c903bf15f37097b38b7b3d96fc4cd0..54dced7cd69c0af19ba99cd135fbc8b40a57a65d 100644
(file)
--- a/
dev-python/zstandard/zstandard-0.12.0.ebuild
+++ b/
dev-python/zstandard/zstandard-0.12.0.ebuild
@@
-22,6
+22,11
@@
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/hypothesis[${PYTHON_USEDEP}] )"
+python_compile() {
+ local MAKEOPTS=-j1
+ distutils-r1_python_compile
+}
+
python_test() {
esetup.py test
}