dev-ros/nodelet_topic_tools: Initial import. Ebuild by me.
authorAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:33:06 +0000 (17:33 +0200)
committerAlexis Ballier <aballier@gentoo.org>
Tue, 22 Sep 2015 15:52:46 +0000 (17:52 +0200)
Package-Manager: portage-2.2.21

dev-ros/nodelet_topic_tools/Manifest [new file with mode: 0644]
dev-ros/nodelet_topic_tools/metadata.xml [new file with mode: 0644]
dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3.ebuild [new file with mode: 0644]
dev-ros/nodelet_topic_tools/nodelet_topic_tools-9999.ebuild [new file with mode: 0644]

diff --git a/dev-ros/nodelet_topic_tools/Manifest b/dev-ros/nodelet_topic_tools/Manifest
new file mode 100644 (file)
index 0000000..d215469
--- /dev/null
@@ -0,0 +1 @@
+DIST nodelet_core-1.9.3.tar.gz 33825 SHA256 26256ff83c92db88b941e5d85ab2162fbcaa0f19ea066732c2de83255eed0001 SHA512 d2560ef2c973aae297ffc5f139ed12308a0e4ac4477407e533402fbaf127c5aa4105548d01438b3bb17636df9587018a953bb6c0ae810996445bb1368c97f190 WHIRLPOOL 88bb8ef3a0b2138f2f1d5ff95c4328e22da4fc23313ba52447d5156b13c452284a9953f89de1d48838b96e226ff9ab929d6482c8b0ad847676aaa13e9b1f596d
diff --git a/dev-ros/nodelet_topic_tools/metadata.xml b/dev-ros/nodelet_topic_tools/metadata.xml
new file mode 100644 (file)
index 0000000..c42ea5b
--- /dev/null
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>ros</herd>
+</pkgmetadata>
diff --git a/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3.ebuild b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-1.9.3.ebuild
new file mode 100644 (file)
index 0000000..444b0ac
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       dev-ros/dynamic_reconfigure
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/pluginlib
+       dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"
diff --git a/dev-ros/nodelet_topic_tools/nodelet_topic_tools-9999.ebuild b/dev-ros/nodelet_topic_tools/nodelet_topic_tools-9999.ebuild
new file mode 100644 (file)
index 0000000..444b0ac
--- /dev/null
@@ -0,0 +1,25 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+ROS_REPO_URI="https://github.com/ros/nodelet_core"
+KEYWORDS="~amd64 ~arm"
+ROS_SUBDIR=${PN}
+
+inherit ros-catkin
+
+DESCRIPTION="Common nodelet tools such as a mux, demux and throttle"
+LICENSE="BSD"
+SLOT="0"
+IUSE=""
+
+RDEPEND="
+       dev-libs/boost:=[threads]
+       dev-ros/dynamic_reconfigure
+       dev-ros/message_filters
+       dev-ros/nodelet
+       dev-ros/pluginlib
+       dev-ros/roscpp
+"
+DEPEND="${RDEPEND}"