dev-libs/openssl: Remove compat slots (moved to *-compat)
authorMichał Górny <mgorny@gentoo.org>
Tue, 28 May 2019 19:00:54 +0000 (21:00 +0200)
committerThomas Deutschmann <whissi@gentoo.org>
Fri, 14 Jun 2019 17:46:34 +0000 (19:46 +0200)
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Bug: https://bugs.gentoo.org/687984
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
dev-libs/openssl/Manifest
dev-libs/openssl/files/gentoo.config-0.9.8 [deleted file]
dev-libs/openssl/files/openssl-0.9.8e-bsd-sparc64.patch [deleted file]
dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch [deleted file]
dev-libs/openssl/files/openssl-0.9.8m-binutils.patch [deleted file]
dev-libs/openssl/files/openssl-0.9.8z_p8-perl-5.26.patch [deleted file]
dev-libs/openssl/openssl-0.9.8z_p8-r1.ebuild [deleted file]
dev-libs/openssl/openssl-1.0.2r-r200.ebuild [deleted file]

index 26e97789fdece6cf1c1e83b9dc0b7a15db23bb5c..ae40847f77dc91e9be604ab22f605f1ecb12d941 100644 (file)
@@ -1,4 +1,3 @@
-DIST openssl-0.9.8zh.tar.gz 3818524 BLAKE2B 610bb4858900983cf4519fa8b63f1e03b3845e39e68884fd8bebd738cd5cd6c2c75513643af49bf9e2294adc446a6516480fe9b62de55d9b6379bf9e7c5cd364 SHA512 b97fa2468211f86c0719c68ad1781eff84f772c479ed5193d6da14bac086b4ca706e7d851209d9df3f0962943b5e5333ab0def00110fb2e517caa73c0c6674c6
 DIST openssl-1.0.2-patches-1.5.tar.xz 12404 BLAKE2B 6c1b8c28f339f539b2ab8643379502a24cf62bffde00041dce54d5dd9e8d2620b181362ee5464b0ab32ba4948e209697bfabadbea2944a409a1009100d298f24 SHA512 5725e2d9d1ee8cc074bcef3bed61c71bdab2ff1c114362110c3fb8da11ad5bc8f2ff28e90a293f5f3a5cf96ecda54dffdb7ab3fb3f8b23ef6472250dc3037659
 DIST openssl-1.0.2r.tar.gz 5348369 BLAKE2B 9f9c2d2fe6eaf9acacab29b394a318f30c38e831a5f9c193b2da660f9d04acbf407d8b752274783765416c0f5ba557c24ee293ad7fb7d727771db289e6acc901 SHA512 6eb2211f3ad56d7573ac26f388338592c37e5faaf5e2d44c0fa9062c12186e56a324f135d1c956a89b55fcce047e6428bec2756658d103e7275e08b46f741235
 DIST openssl-1.0.2r_ec_curve.c 17254 BLAKE2B d40d8d6e770443f07abe70e2c4ddda6aec1cc8e37dc1f226a3fdd9ed5d228f09c6d372e8956b1948b55ee1d57d1429493e7288d0f54d9466a37fec805c85aacb SHA512 8e92fb100bcf4bd918c82b9a6cbd75a55abe1a2c08230a007e441c51577f974f8cc336e9ac8a672b32641480428ca8cead5380da1fe81bacb088145a1b754a15
diff --git a/dev-libs/openssl/files/gentoo.config-0.9.8 b/dev-libs/openssl/files/gentoo.config-0.9.8
deleted file mode 100644 (file)
index 0269825..0000000
+++ /dev/null
@@ -1,144 +0,0 @@
-#!/usr/bin/env bash
-# Copyright 1999-2009 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-#
-# Openssl doesn't play along nicely with cross-compiling
-# like autotools based projects, so let's teach it new tricks.
-#
-# Review the bundled 'config' script to see why kind of targets
-# we can pass to the 'Configure' script.
-
-
-# Testing routines
-if [[ $1 == "test" ]] ; then
-       for c in \
-               "arm-gentoo-linux-uclibc      |linux-generic32 -DL_ENDIAN" \
-               "armv5b-linux-gnu             |linux-generic32 -DB_ENDIAN" \
-               "x86_64-pc-linux-gnu          |linux-x86_64" \
-               "alphaev56-unknown-linux-gnu  |linux-alpha+bwx-gcc" \
-               "i686-pc-linux-gnu            |linux-elf" \
-               "whatever-gentoo-freebsdX.Y   |BSD-generic32" \
-               "i686-gentoo-freebsdX.Y       |BSD-x86-elf" \
-               "sparc64-alpha-freebsdX.Y     |BSD-sparc64" \
-               "ia64-gentoo-freebsd5.99234   |BSD-ia64" \
-               "x86_64-gentoo-freebsdX.Y     |BSD-x86_64" \
-               "hppa64-aldsF-linux-gnu5.3    |linux-generic32 -DB_ENDIAN" \
-               "powerpc-gentOO-linux-uclibc  |linux-ppc" \
-               "powerpc64-unk-linux-gnu      |linux-ppc64" \
-               "x86_64-apple-darwinX         |darwin64-x86_64-cc" \
-               "powerpc64-apple-darwinX      |darwin64-ppc-cc" \
-               "i686-apple-darwinX           |darwin-i386-cc" \
-               "i386-apple-darwinX           |darwin-i386-cc" \
-               "powerpc-apple-darwinX        |darwin-ppc-cc" \
-               "i586-pc-winnt                |winnt-parity" \
-       ;do
-               CHOST=${c/|*}
-               ret_want=${c/*|}
-               ret_got=$(CHOST=${CHOST} "$0")
-
-               if [[ ${ret_want} == "${ret_got}" ]] ; then
-                       echo "PASS: ${CHOST}"
-               else
-                       echo "FAIL: ${CHOST}"
-                       echo -e "\twanted: ${ret_want}"
-                       echo -e "\twe got: ${ret_got}"
-               fi
-       done
-       exit 0
-fi
-[[ -z ${CHOST} && -n $1 ]] && CHOST=$1
-
-
-# Detect the operating system
-case ${CHOST} in
-       *-aix*)      system="aix";;
-       *-darwin*)   system="darwin";;
-       *-freebsd*)  system="BSD";;
-       *-hpux*)     system="hpux";;
-       *-linux*)    system="linux";;
-       *-solaris*)  system="solaris";;
-       *-winnt*)    system="winnt";;
-       *)           exit 0;;
-esac
-
-
-# Compiler munging
-compiler="gcc"
-if [[ ${CC} == "ccc" ]] ; then
-       compiler=${CC}
-fi
-
-
-# Detect target arch
-machine=""
-chost_machine=${CHOST%%-*}
-case ${system} in
-linux)
-       case ${chost_machine} in
-               alphaev56*)   machine=alpha+bwx-${compiler};;
-               alphaev[678]*)machine=alpha+bwx-${compiler};;
-               alpha*)       machine=alpha-${compiler};;
-               arm*b*)       machine="generic32 -DB_ENDIAN";;
-               arm*)         machine="generic32 -DL_ENDIAN";;
-       #       hppa64*)      machine=parisc64;;
-               hppa*)        machine="generic32 -DB_ENDIAN";;
-               i[0-9]86*)    machine=elf;;
-               ia64*)        machine=ia64;;
-               m68*)         machine="generic32 -DB_ENDIAN";;
-               mips*el*)     machine="generic32 -DL_ENDIAN";;
-               mips*)        machine="generic32 -DB_ENDIAN";;
-               powerpc64*)   machine=ppc64;;
-               powerpc*)     machine=ppc;;
-       #       sh64*)        machine=elf;;
-               sh*b*)        machine="generic32 -DB_ENDIAN";;
-               sh*)          machine="generic32 -DL_ENDIAN";;
-               sparc*v7*)    machine="generic32 -DB_ENDIAN";;
-               sparc64*)     machine=sparcv9;;
-               sparc*)       machine=sparcv8;;
-               s390x*)       machine="generic64 -DB_ENDIAN";;
-               s390*)        machine="generic32 -DB_ENDIAN";;
-               x86_64*)      machine=x86_64;;
-       esac
-       ;;
-BSD)
-       case ${chost_machine} in
-               alpha*)       machine=generic64;;
-               i[6-9]86*)    machine=x86-elf;;
-               ia64*)        machine=ia64;;
-               sparc64*)     machine=sparc64;;
-               x86_64*)      machine=x86_64;;
-               *)            machine=generic32;;
-       esac
-       ;;
-aix)
-       machine=${compiler}
-       ;;
-darwin)
-       case ${chost_machine} in
-               powerpc64)    machine=ppc-cc; system=${system}64;;
-               powerpc)      machine=ppc-cc;;
-               i?86*)        machine=i386-cc;;
-               x86_64)       machine=x86_64-cc; system=${system}64;;
-       esac
-       ;;
-hpux)
-       case ${chost_machine} in
-               ia64)   machine=ia64-${compiler} ;;
-       esac
-       ;;
-solaris)
-       case ${chost_machine} in
-               i386)         machine=x86-${compiler} ;;
-               x86_64*)      machine=x86_64-${compiler}; system=${system}64;;
-               sparcv9*)     machine=sparcv9-${compiler}; system=${system}64;;
-               sparc*)       machine=sparcv8-${compiler};;
-       esac
-       ;;
-winnt)
-       machine=parity
-       ;;
-esac
-
-
-# If we have something, show it
-[[ -n ${machine} ]] && echo ${system}-${machine}
diff --git a/dev-libs/openssl/files/openssl-0.9.8e-bsd-sparc64.patch b/dev-libs/openssl/files/openssl-0.9.8e-bsd-sparc64.patch
deleted file mode 100644 (file)
index a798164..0000000
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/Configure
-+++ b/Configure
-@@ -365,7 +365,7 @@
- # -DMD32_REG_T=int doesn't actually belong in sparc64 target, it
- # simply *happens* to work around a compiler bug in gcc 3.3.3,
- # triggered by RIPEMD160 code.
--"BSD-sparc64",        "gcc:-DB_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC2 BF_PTR:::des_enc-sparc.o fcrypt_b.o:::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
-+"BSD-sparc64",        "gcc:-DB_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall::${BSDthreads}:ULTRASPARC::SIXTY_FOUR_BIT_LONG RC2_CHAR RC4_CHUNK DES_INT DES_PTR DES_RISC2 BF_PTR:::des_enc-sparc.o fcrypt_b.o:::::::::dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "BSD-ia64",   "gcc:-DL_ENDIAN -DTERMIOS -O3 -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK:${ia64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
- "BSD-x86_64", "gcc:-DL_ENDIAN -DTERMIOS -O3 -DMD32_REG_T=int -Wall::${BSDthreads}:::SIXTY_FOUR_BIT_LONG RC4_CHUNK DES_INT DES_UNROLL:${x86_64_asm}:dlfcn:bsd-gcc-shared:-fPIC::.so.\$(SHLIB_MAJOR).\$(SHLIB_MINOR)",
-
-the -B flag is a no-op nowadays
-
---- a/crypto/des/Makefile
-+++ b/crypto/des/Makefile
-@@ -62,7 +62,7 @@
-       $(CC) $(CFLAGS) -o des des.o cbc3_enc.o $(LIB)
- des_enc-sparc.S:      asm/des_enc.m4
--      m4 -B 8192 asm/des_enc.m4 > des_enc-sparc.S
-+      m4 asm/des_enc.m4 > des_enc-sparc.S
- # ELF
- dx86-elf.s:   asm/des-586.pl ../perlasm/x86asm.pl ../perlasm/cbc.pl
diff --git a/dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch b/dev-libs/openssl/files/openssl-0.9.8h-ldflags.patch
deleted file mode 100644 (file)
index 64cc7bd..0000000
+++ /dev/null
@@ -1,29 +0,0 @@
-http://bugs.gentoo.org/181438
-http://bugs.gentoo.org/327421
-https://rt.openssl.org/Ticket/Display.html?id=3332&user=guest&pass=guest
-
-make sure we respect LDFLAGS
-
-also make sure we don't add useless -rpath flags to the system libdir
-
---- openssl-0.9.8h/Makefile.org
-+++ openssl-0.9.8h/Makefile.org
-@@ -180,6 +181,7 @@
-               MAKEDEPEND='$$$${TOP}/util/domd $$$${TOP} -MD ${MAKEDEPPROG}' \
-               DEPFLAG='-DOPENSSL_NO_DEPRECATED ${DEPFLAG}'    \
-               MAKEDEPPROG='${MAKEDEPPROG}'                    \
-+              LDFLAGS='${LDFLAGS}'            \
-               SHARED_LDFLAGS='${SHARED_LDFLAGS}'              \
-               KRB5_INCLUDES='${KRB5_INCLUDES}' LIBKRB5='${LIBKRB5}'   \
-               EXE_EXT='${EXE_EXT}' SHARED_LIBS='${SHARED_LIBS}'       \
---- openssl-0.9.8h/Makefile.shared
-+++ openssl-0.9.8h/Makefile.shared
-@@ -153,7 +153,7 @@
-       NOALLSYMSFLAGS='-Wl,--no-whole-archive'; \
-       SHAREDFLAGS="$(CFLAGS) $(SHARED_LDFLAGS) -shared -Wl,-Bsymbolic -Wl,-soname=$$SHLIB$$SHLIB_SOVER$$SHLIB_SUFFIX"
--DO_GNU_APP=LDFLAGS="$(CFLAGS) -Wl,-rpath,$(LIBRPATH)"
-+DO_GNU_APP=LDFLAGS="$(LDFLAGS) $(CFLAGS)"
- #This is rather special.  It's a special target with which one can link
- #applications without bothering with any features that have anything to
diff --git a/dev-libs/openssl/files/openssl-0.9.8m-binutils.patch b/dev-libs/openssl/files/openssl-0.9.8m-binutils.patch
deleted file mode 100644 (file)
index 9fa79b9..0000000
+++ /dev/null
@@ -1,24 +0,0 @@
-http://bugs.gentoo.org/289130
-
-Ripped from Fedora
-
---- openssl-1.0.0-beta4/crypto/sha/asm/sha1-x86_64.pl.binutils 2009-11-12 15:17:29.000000000 +0100
-+++ openssl-1.0.0-beta4/crypto/sha/asm/sha1-x86_64.pl  2009-11-12 17:24:18.000000000 +0100
-@@ -150,7 +150,7 @@ ___
- sub BODY_20_39 {
- my ($i,$a,$b,$c,$d,$e,$f)=@_;
- my $j=$i+1;
--my $K=($i<40)?0x6ed9eba1:0xca62c1d6;
-+my $K=($i<40)?0x6ed9eba1:-0x359d3e2a;
- $code.=<<___ if ($i<79);
-       lea     $K($xi,$e),$f
-       mov     `4*($j%16)`(%rsp),$xi
-@@ -187,7 +187,7 @@ sub BODY_40_59 {
- my ($i,$a,$b,$c,$d,$e,$f)=@_;
- my $j=$i+1;
- $code.=<<___;
--      lea     0x8f1bbcdc($xi,$e),$f
-+      lea     -0x70e44324($xi,$e),$f
-       mov     `4*($j%16)`(%rsp),$xi
-       mov     $b,$t0
-       mov     $b,$t1
diff --git a/dev-libs/openssl/files/openssl-0.9.8z_p8-perl-5.26.patch b/dev-libs/openssl/files/openssl-0.9.8z_p8-perl-5.26.patch
deleted file mode 100644 (file)
index c932b82..0000000
+++ /dev/null
@@ -1,13 +0,0 @@
-https://bugs.gentoo.org/639876
-
---- a/crypto/des/asm/des-586.pl
-+++ b/crypto/des/asm/des-586.pl
-@@ -4,7 +4,7 @@
- # Svend Olaf Mikkelsen <svolaf@inet.uni-c.dk>
- #
--push(@INC,"perlasm","../../perlasm");
-+push(@INC,".","perlasm","../../perlasm");
- require "x86asm.pl";
- require "cbc.pl";
- require "desboth.pl";
diff --git a/dev-libs/openssl/openssl-0.9.8z_p8-r1.ebuild b/dev-libs/openssl/openssl-0.9.8z_p8-r1.ebuild
deleted file mode 100644 (file)
index c64a38b..0000000
+++ /dev/null
@@ -1,163 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-# this ebuild is only for the libcrypto.so.0.9.8 and libssl.so.0.9.8 SONAME for ABI compat
-
-EAPI="6"
-
-inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
-
-#PLEVEL=$(printf "\\$(printf '%03o' $((${PV##*_p} + 96)))")
-PLEVEL='h' # _p8 -> tr '[1-9]' '[a-i]' -> 'h'
-MY_PV=${PV/_p*/${PLEVEL}}
-MY_P=${PN}-${MY_PV}
-S="${WORKDIR}/${MY_P}"
-DESCRIPTION="Toolkit for SSL v2/v3 and TLS v1"
-HOMEPAGE="https://www.openssl.org/"
-SRC_URI="mirror://openssl/source/${MY_P}.tar.gz"
-
-LICENSE="openssl"
-SLOT="0.9.8"
-KEYWORDS="~alpha amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~x86-fbsd"
-IUSE="bindist gmp kerberos cpu_flags_x86_sse2 test zlib"
-RESTRICT="!bindist? ( bindist )"
-
-RDEPEND="gmp? ( >=dev-libs/gmp-5.1.3-r1[${MULTILIB_USEDEP}] )
-       zlib? ( >=sys-libs/zlib-1.2.8-r1[${MULTILIB_USEDEP}] )
-       kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )
-       !=dev-libs/openssl-0.9.8*:0"
-DEPEND="${RDEPEND}
-       >=dev-lang/perl-5
-       test? (
-               sys-apps/diffutils
-               sys-devel/bc
-       )"
-
-# Do not install any docs
-DOCS=()
-
-PATCHES=(
-       "${FILESDIR}"/${PN}-0.9.8e-bsd-sparc64.patch
-       "${FILESDIR}"/${PN}-0.9.8h-ldflags.patch #181438
-       "${FILESDIR}"/${PN}-0.9.8m-binutils.patch #289130
-       "${FILESDIR}"/${PN}-0.9.8z_p8-perl-5.26.patch
-)
-
-src_prepare() {
-       default
-
-       # disable fips in the build
-       # make sure the man pages are suffixed #302165
-       # don't bother building man pages if they're disabled
-       sed -i \
-               -e '/DIRS/s: fips : :g' \
-               -e '/^MANSUFFIX/s:=.*:=ssl:' \
-               -e '/^MAKEDEPPROG/s:=.*:=$(CC):' \
-               -e $(has noman FEATURES \
-                       && echo '/^install:/s:install_docs::' \
-                       || echo '/^MANDIR=/s:=.*:=/usr/share/man:') \
-               Makefile{,.org} \
-               || die
-       # show the actual commands in the log
-       sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared || die
-       # update the enginedir path.
-       # punt broken config we don't care about as it fails sanity check.
-       sed -i \
-               -e '/^"debug-ben-debug-64"/d' \
-               -e "/foo.*engines/s|/lib/engines|/$(get_libdir)/engines|" \
-               Configure || die
-
-       # since we're forcing $(CC) as makedep anyway, just fix
-       # the conditional as always-on
-       # helps clang (#417795), and versioned gcc (#499818)
-       sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
-
-       # quiet out unknown driver argument warnings since openssl
-       # doesn't have well-split CFLAGS and we're making it even worse
-       # and 'make depend' uses -Werror for added fun (#417795 again)
-       [[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
-
-       # allow openssl to be cross-compiled
-       cp "${FILESDIR}"/gentoo.config-0.9.8 gentoo.config || die "cp cross-compile failed"
-       chmod a+rx gentoo.config || die
-
-       append-flags -fno-strict-aliasing
-       append-flags -Wa,--noexecstack
-
-       sed -i '1s,^:$,#!/usr/bin/perl,' Configure || die #141906
-       sed -i '/^"debug-bodo/d' Configure || die # 0.9.8za shipped broken
-       ./config --test-sanity || die "I AM NOT SANE"
-
-       multilib_copy_sources
-}
-
-multilib_src_configure() {
-       unset APPS #197996
-       unset SCRIPTS #312551
-
-       tc-export CC AR RANLIB
-
-       # Clean out patent-or-otherwise-encumbered code
-       # Camellia: Royalty Free            https://en.wikipedia.org/wiki/Camellia_(cipher)
-       # IDEA:     Expired                 https://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm
-       # EC:       ????????? ??/??/2015    https://en.wikipedia.org/wiki/Elliptic_Curve_Cryptography
-       # MDC2:     Expired                 https://en.wikipedia.org/wiki/MDC-2
-       # RC5:      5,724,428 03/03/2015    https://en.wikipedia.org/wiki/RC5
-
-       use_ssl() { use $1 && echo "enable-${2:-$1} ${*:3}" || echo "no-${2:-$1}" ; }
-       echoit() { echo "$@" ; "$@" ; }
-
-       local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
-
-       local sslout=$(./gentoo.config)
-       einfo "Use configuration ${sslout:-(openssl knows best)}"
-       local config="Configure"
-       [[ -z ${sslout} ]] && config="config"
-
-       echoit \
-       ./${config} \
-               ${sslout} \
-               $(use cpu_flags_x86_sse2 || echo "no-sse2") \
-               enable-camellia \
-               $(use_ssl !bindist ec) \
-               enable-idea \
-               enable-mdc2 \
-               $(use_ssl !bindist rc5) \
-               enable-tlsext \
-               $(use_ssl gmp gmp -lgmp) \
-               $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
-               $(use_ssl zlib) \
-               --prefix=/usr \
-               --openssldir=/etc/ssl \
-               shared threads \
-               || die "Configure failed"
-
-       # Clean out hardcoded flags that openssl uses
-       local CFLAG=$(grep ^CFLAG= Makefile | LC_ALL=C sed \
-               -e 's:^CFLAG=::' \
-               -e 's:-fomit-frame-pointer ::g' \
-               -e 's:-O[0-9] ::g' \
-               -e 's:-march=[-a-z0-9]* ::g' \
-               -e 's:-mcpu=[-a-z0-9]* ::g' \
-               -e 's:-m[a-z0-9]* ::g' \
-       )
-       sed -i \
-               -e "/^LIBDIR=/s|=.*|=$(get_libdir)|" \
-               -e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
-               -e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
-               Makefile || die
-}
-
-multilib_src_compile() {
-       # depend is needed to use $confopts
-       emake -j1 depend
-       emake -j1 build_libs
-}
-
-multilib_src_test() {
-       emake -j1 test
-}
-
-multilib_src_install() {
-       dolib.so lib{crypto,ssl}.so.0.9.8
-}
diff --git a/dev-libs/openssl/openssl-1.0.2r-r200.ebuild b/dev-libs/openssl/openssl-1.0.2r-r200.ebuild
deleted file mode 100644 (file)
index 44b9547..0000000
+++ /dev/null
@@ -1,248 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-inherit eutils flag-o-matic toolchain-funcs multilib multilib-minimal
-
-# openssl-1.0.2-patches-1.6 contain additional CVE patches
-# which got fixed with this release.
-# Please use 1.7 version number when rolling a new tarball!
-PATCH_SET="openssl-1.0.2-patches-1.5"
-MY_P=${P/_/-}
-DESCRIPTION="full-strength general purpose cryptography library (including SSL and TLS)"
-HOMEPAGE="https://www.openssl.org/"
-SRC_URI="mirror://openssl/source/${MY_P}.tar.gz
-       !vanilla? (
-               mirror://gentoo/${PATCH_SET}.tar.xz
-               https://dev.gentoo.org/~chutzpah/dist/${PN}/${PATCH_SET}.tar.xz
-               https://dev.gentoo.org/~whissi/dist/${PN}/${PATCH_SET}.tar.xz
-               https://dev.gentoo.org/~polynomial-c/dist/${PATCH_SET}.tar.xz
-       )"
-
-LICENSE="openssl"
-SLOT="1.0.0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-linux"
-IUSE="+asm bindist gmp kerberos rfc3779 sctp cpu_flags_x86_sse2 sslv2 +sslv3 static-libs test +tls-heartbeat vanilla zlib"
-RESTRICT="!bindist? ( bindist )"
-
-RDEPEND=">=app-misc/c_rehash-1.7-r1
-       gmp? ( >=dev-libs/gmp-5.1.3-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
-       zlib? ( >=sys-libs/zlib-1.2.8-r1[static-libs(+)?,${MULTILIB_USEDEP}] )
-       kerberos? ( >=app-crypt/mit-krb5-1.11.4[${MULTILIB_USEDEP}] )
-       !=dev-libs/openssl-1.0.2*:0"
-DEPEND="${RDEPEND}
-       >=dev-lang/perl-5
-       sctp? ( >=net-misc/lksctp-tools-1.0.12 )
-       test? (
-               sys-apps/diffutils
-               sys-devel/bc
-       )"
-
-RESTRICT="test"
-
-# Do not install any docs
-DOCS=()
-
-# This does not copy the entire Fedora patchset, but JUST the parts that
-# are needed to make it safe to use EC with RESTRICT=bindist.
-# See openssl.spec for the matching numbering of SourceNNN, PatchNNN
-SOURCE1=hobble-openssl
-SOURCE12=ec_curve.c
-SOURCE13=ectest.c
-# These are ported instead
-#PATCH1=openssl-1.1.0-build.patch # Fixes EVP testcase for EC
-#PATCH37=openssl-1.1.0-ec-curves.patch
-FEDORA_GIT_BASE='https://src.fedoraproject.org/cgit/rpms/openssl.git/plain/'
-FEDORA_GIT_BRANCH='f25'
-FEDORA_SRC_URI=()
-FEDORA_SOURCE=( $SOURCE1 $SOURCE12 $SOURCE13 )
-FEDORA_PATCH=( $PATCH1 $PATCH37 )
-for i in "${FEDORA_SOURCE[@]}" ; do
-       FEDORA_SRC_URI+=( "${FEDORA_GIT_BASE}/${i}?h=${FEDORA_GIT_BRANCH} -> ${P}_${i}" )
-done
-for i in "${FEDORA_PATCH[@]}" ; do # Already have a version prefix
-       FEDORA_SRC_URI+=( "${FEDORA_GIT_BASE}/${i}?h=${FEDORA_GIT_BRANCH} -> ${i}" )
-done
-SRC_URI+=" bindist? ( ${FEDORA_SRC_URI[@]} )"
-
-S="${WORKDIR}/${MY_P}"
-
-MULTILIB_WRAPPED_HEADERS=(
-       usr/include/openssl/opensslconf.h
-)
-
-src_prepare() {
-       if use bindist; then
-               # This just removes the prefix, and puts it into WORKDIR like the RPM.
-               for i in "${FEDORA_SOURCE[@]}" ; do
-                       cp -f "${DISTDIR}"/"${P}_${i}" "${WORKDIR}"/"${i}" || die
-               done
-               # .spec %prep
-               bash "${WORKDIR}"/"${SOURCE1}" || die
-               cp -f "${WORKDIR}"/"${SOURCE12}" "${S}"/crypto/ec/ || die
-               cp -f "${WORKDIR}"/"${SOURCE13}" "${S}"/crypto/ec/ || die # Moves to test/ in OpenSSL-1.1
-               for i in "${FEDORA_PATCH[@]}" ; do
-                       eapply "${DISTDIR}"/"${i}"
-               done
-               eapply "${FILESDIR}"/openssl-1.0.2p-hobble-ecc.patch
-               # Also see the configure parts below:
-               # enable-ec \
-               # $(use_ssl !bindist ec2m) \
-               # $(use_ssl !bindist srp) \
-       fi
-
-       # keep this in sync with app-misc/c_rehash
-       SSL_CNF_DIR="/etc/ssl"
-
-       # Make sure we only ever touch Makefile.org and avoid patching a file
-       # that gets blown away anyways by the Configure script in src_configure
-       rm -f Makefile
-
-       if ! use vanilla ; then
-               eapply "${WORKDIR}"/patch/*.patch
-       fi
-
-       eapply_user
-
-       # disable fips in the build
-       # make sure the man pages are suffixed #302165
-       # don't bother building man pages if they're disabled
-       sed -i \
-               -e '/DIRS/s: fips : :g' \
-               -e '/^MANSUFFIX/s:=.*:=ssl:' \
-               -e '/^MAKEDEPPROG/s:=.*:=$(CC):' \
-               -e $(has noman FEATURES \
-                       && echo '/^install:/s:install_docs::' \
-                       || echo '/^MANDIR=/s:=.*:='${EPREFIX%/}'/usr/share/man:') \
-               Makefile.org \
-               || die
-       # show the actual commands in the log
-       sed -i '/^SET_X/s:=.*:=set -x:' Makefile.shared
-
-       # since we're forcing $(CC) as makedep anyway, just fix
-       # the conditional as always-on
-       # helps clang (#417795), and versioned gcc (#499818)
-       # this breaks build with 1.0.2p, not sure if it is needed anymore
-       #sed -i 's/expr.*MAKEDEPEND.*;/true;/' util/domd || die
-
-       # quiet out unknown driver argument warnings since openssl
-       # doesn't have well-split CFLAGS and we're making it even worse
-       # and 'make depend' uses -Werror for added fun (#417795 again)
-       [[ ${CC} == *clang* ]] && append-flags -Qunused-arguments
-
-       # allow openssl to be cross-compiled
-       cp "${FILESDIR}"/gentoo.config-1.0.2 gentoo.config || die
-       chmod a+rx gentoo.config || die
-
-       append-flags -fno-strict-aliasing
-       append-flags $(test-flags-CC -Wa,--noexecstack)
-       append-cppflags -DOPENSSL_NO_BUF_FREELISTS
-
-       sed -i '1s,^:$,#!'${EPREFIX%/}'/usr/bin/perl,' Configure #141906
-       # The config script does stupid stuff to prompt the user.  Kill it.
-       sed -i '/stty -icanon min 0 time 50; read waste/d' config || die
-       ./config --test-sanity || die "I AM NOT SANE"
-
-       multilib_copy_sources
-}
-
-multilib_src_configure() {
-       unset APPS #197996
-       unset SCRIPTS #312551
-       unset CROSS_COMPILE #311473
-
-       tc-export CC AR RANLIB RC
-
-       # Clean out patent-or-otherwise-encumbered code
-       # Camellia: Royalty Free            https://en.wikipedia.org/wiki/Camellia_(cipher)
-       # IDEA:     Expired                 https://en.wikipedia.org/wiki/International_Data_Encryption_Algorithm
-       # EC:       ????????? ??/??/2015    https://en.wikipedia.org/wiki/Elliptic_Curve_Cryptography
-       # MDC2:     Expired                 https://en.wikipedia.org/wiki/MDC-2
-       # RC5:      Expired                 https://en.wikipedia.org/wiki/RC5
-
-       use_ssl() { usex $1 "enable-${2:-$1}" "no-${2:-$1}" " ${*:3}" ; }
-       echoit() { echo "$@" ; "$@" ; }
-
-       local krb5=$(has_version app-crypt/mit-krb5 && echo "MIT" || echo "Heimdal")
-
-       # See if our toolchain supports __uint128_t.  If so, it's 64bit
-       # friendly and can use the nicely optimized code paths. #460790
-       local ec_nistp_64_gcc_128
-       # Disable it for now though #469976
-       #if ! use bindist ; then
-       #       echo "__uint128_t i;" > "${T}"/128.c
-       #       if ${CC} ${CFLAGS} -c "${T}"/128.c -o /dev/null >&/dev/null ; then
-       #               ec_nistp_64_gcc_128="enable-ec_nistp_64_gcc_128"
-       #       fi
-       #fi
-
-       # https://github.com/openssl/openssl/issues/2286
-       if use ia64 ; then
-               replace-flags -g3 -g2
-               replace-flags -ggdb3 -ggdb2
-       fi
-
-       local sslout=$(./gentoo.config)
-       einfo "Use configuration ${sslout:-(openssl knows best)}"
-       local config="Configure"
-       [[ -z ${sslout} ]] && config="config"
-
-       # Fedora hobbled-EC needs 'no-ec2m', 'no-srp'
-       echoit \
-       ./${config} \
-               ${sslout} \
-               $(use cpu_flags_x86_sse2 || echo "no-sse2") \
-               enable-camellia \
-               enable-ec \
-               $(use_ssl !bindist ec2m) \
-               $(use_ssl !bindist srp) \
-               ${ec_nistp_64_gcc_128} \
-               enable-idea \
-               enable-mdc2 \
-               enable-rc5 \
-               enable-tlsext \
-               $(use_ssl asm) \
-               $(use_ssl gmp gmp -lgmp) \
-               $(use_ssl kerberos krb5 --with-krb5-flavor=${krb5}) \
-               $(use_ssl rfc3779) \
-               $(use_ssl sctp) \
-               $(use_ssl sslv2 ssl2) \
-               $(use_ssl sslv3 ssl3) \
-               $(use_ssl tls-heartbeat heartbeats) \
-               $(use_ssl zlib) \
-               --prefix="${EPREFIX%/}"/usr \
-               --openssldir="${EPREFIX%/}"${SSL_CNF_DIR} \
-               --libdir=$(get_libdir) \
-               shared threads \
-               || die
-
-       # Clean out hardcoded flags that openssl uses
-       local CFLAG=$(grep ^CFLAG= Makefile | LC_ALL=C sed \
-               -e 's:^CFLAG=::' \
-               -e 's:-fomit-frame-pointer ::g' \
-               -e 's:-O[0-9] ::g' \
-               -e 's:-march=[-a-z0-9]* ::g' \
-               -e 's:-mcpu=[-a-z0-9]* ::g' \
-               -e 's:-m[a-z0-9]* ::g' \
-       )
-       sed -i \
-               -e "/^CFLAG/s|=.*|=${CFLAG} ${CFLAGS}|" \
-               -e "/^SHARED_LDFLAGS=/s|$| ${LDFLAGS}|" \
-               Makefile || die
-}
-
-multilib_src_compile() {
-       # depend is needed to use $confopts; it also doesn't matter
-       # that it's -j1 as the code itself serializes subdirs
-       emake -j1 V=1 depend
-       emake build_libs
-}
-
-multilib_src_test() {
-       emake -j1 test
-}
-
-multilib_src_install() {
-       dolib.so lib{crypto,ssl}.so.${SLOT}
-}