mail-client/thunderbird: force stderr for ewarn in llvm_check_deps()
authorThomas Deutschmann <whissi@gentoo.org>
Thu, 31 Oct 2019 15:51:57 +0000 (16:51 +0100)
committerThomas Deutschmann <whissi@gentoo.org>
Thu, 31 Oct 2019 15:56:28 +0000 (16:56 +0100)
Closes: https://bugs.gentoo.org/695668
Package-Manager: Portage-2.3.78, Repoman-2.3.17
Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
mail-client/thunderbird/thunderbird-68.2.1.ebuild

index e96e0a6bf23348780d09276d786d9c1086ffc311..7d71069196c974d51ebf0654c1d4b70ff9c62041 100644 (file)
@@ -182,37 +182,36 @@ fi
 
 llvm_check_deps() {
        if ! has_version --host-root "sys-devel/clang:${LLVM_SLOT}" ; then
-               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+               ewarn "sys-devel/clang:${LLVM_SLOT} is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                return 1
        fi
 
-       if use pgo ; then
-               if ! has usersandbox $FEATURES ; then
-                       eerror "You must enable usersandbox as X server can not run as root!"
-               fi
-       fi
-
        if use clang ; then
                if ! has_version --host-root "=sys-devel/lld-${LLVM_SLOT}*" ; then
-                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                       ewarn "=sys-devel/lld-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                        return 1
                fi
 
                if use pgo ; then
                        if ! has_version --host-root "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}*" ; then
-                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..."
+                               ewarn "=sys-libs/compiler-rt-sanitizers-${LLVM_SLOT}* is missing! Cannot use LLVM slot ${LLVM_SLOT} ..." >&2
                                return 1
                        fi
                fi
        fi
 
-       # <EAPI 7 workaround, #695668
        einfo "Will use LLVM slot ${LLVM_SLOT}!" >&2
 }
 
 pkg_setup() {
        moz_pkgsetup
 
+       if use pgo ; then
+               if ! has usersandbox $FEATURES ; then
+                       die "You must enable usersandbox as X server can not run as root!"
+               fi
+       fi
+
        # Avoid PGO profiling problems due to enviroment leakage
        # These should *always* be cleaned up anyway
        unset DBUS_SESSION_BUS_ADDRESS \