app-portage/pfl: Revision bump to pfl-3.0.1-r1.
authorDaniel Pielmeier <billie@gentoo.org>
Sat, 13 Jul 2019 12:44:28 +0000 (14:44 +0200)
committerDaniel Pielmeier <billie@gentoo.org>
Sat, 13 Jul 2019 12:44:28 +0000 (14:44 +0200)
Fixes bug #689728. Thanks to Ilya Trukhanov for the report.

Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Package-Manager: Portage-2.3.66, Repoman-2.3.11

app-portage/pfl/files/e-file-function.patch [new file with mode: 0644]
app-portage/pfl/pfl-3.0.1-r1.ebuild [new file with mode: 0644]

diff --git a/app-portage/pfl/files/e-file-function.patch b/app-portage/pfl/files/e-file-function.patch
new file mode 100644 (file)
index 0000000..2f554c9
--- /dev/null
@@ -0,0 +1,15 @@
+--- pfl-3.0.1/bin/e-file.old   2019-06-22 20:32:10.437137086 +0200
++++ pfl-3.0.1/bin/e-file       2019-07-13 14:19:47.383823446 +0200
+@@ -3,10 +3,10 @@
+ #License: GPL
+ #e-file is like apt-file in debian,it's used to search package name via filename for gentoo
+ #thanks for portagefilelist.de and Daniel
+-VERSION=20110906
++VERSION=20190713
+ coloropt=always
+-function usage () {
++usage () {
+       echo "This is e-file ($VERSION)"
+       echo "Usage: $(basename ${0})   [-c] [-h] filename"
+       echo "  -c color output could be either [always|never|auto]"
diff --git a/app-portage/pfl/pfl-3.0.1-r1.ebuild b/app-portage/pfl/pfl-3.0.1-r1.ebuild
new file mode 100644 (file)
index 0000000..e766bbb
--- /dev/null
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+PYTHON_REQ_USE="xml"
+
+inherit distutils-r1
+
+DESCRIPTION="Searchable online file/package database for Gentoo"
+HOMEPAGE="http://www.portagefilelist.de"
+SRC_URI="https://dev.gentoo.org/~billie/distfiles/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+network-cron"
+
+DEPEND=""
+RDEPEND="
+       ${DEPEND}
+       net-misc/curl
+       sys-apps/portage[${PYTHON_USEDEP}]
+       >=dev-python/ssl-fetch-0.4[${PYTHON_USEDEP}]
+"
+
+PATCHES=(
+       "${FILESDIR}/e-file-function.patch"
+)
+
+python_install_all() {
+       if use network-cron ; then
+               exeinto /etc/cron.weekly
+               doexe cron/pfl
+       fi
+
+       keepdir /var/lib/${PN}
+       distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+       if [[ ! -e "${EROOT}/var/lib/${PN}/pfl.info" ]]; then
+               touch "${EROOT}/var/lib/${PN}/pfl.info" || die
+       fi
+       chown -R portage:portage "${EROOT}/var/lib/${PN}" || die
+       chmod 775 "${EROOT}/var/lib/${PN}" || die
+}