dev-ruby/tzinfo: skip "safe" tests
authorHans de Graaff <graaff@gentoo.org>
Sun, 13 Oct 2019 09:14:36 +0000 (11:14 +0200)
committerHans de Graaff <graaff@gentoo.org>
Sun, 13 Oct 2019 09:14:36 +0000 (11:14 +0200)
We cannot guarantee that these tests will pass since they
depend on the permissions of the directory hierarchy.

Fixes: https://bugs.gentoo.org/693828
Package-Manager: Portage-2.3.76, Repoman-2.3.16
Signed-off-by: Hans de Graaff <graaff@gentoo.org>
dev-ruby/tzinfo/tzinfo-1.2.5.ebuild

index 1b36cf383f9397b803c2bc51107acc0e5c94c1da..37433640300f7324e378bcf048e588221768a08a 100644 (file)
@@ -29,4 +29,7 @@ ruby_add_bdepend "test? ( dev-ruby/minitest:5 )"
 all_ruby_prepare() {
        # Set the secure permissions that tests expect.
        chmod 0755 "${HOME}" || die "Failed to fix permissions on home"
+
+       # Avoid taint tests that throw SecurityErrors on newer ruby versions.
+       sed -i -e '/_info_tainted/askip"SecurityError"' test/tc_ruby_data_source.rb || die
 }