dev-perl/Chart: -r bump for EAPI7 + license fixes
authorKent Fredric <kentnl@gentoo.org>
Fri, 22 May 2020 15:05:49 +0000 (03:05 +1200)
committerKent Fredric <kentnl@gentoo.org>
Fri, 22 May 2020 15:57:38 +0000 (03:57 +1200)
- EAPI7
- Rectify license mess as much as possible

Bug: https://bugs.gentoo.org/724570
Package-Manager: Portage-2.3.99, Repoman-2.3.22
Signed-off-by: Kent Fredric <kentnl@gentoo.org>
dev-perl/Chart/Chart-2.4.10-r1.ebuild [new file with mode: 0644]

diff --git a/dev-perl/Chart/Chart-2.4.10-r1.ebuild b/dev-perl/Chart/Chart-2.4.10-r1.ebuild
new file mode 100644 (file)
index 0000000..75caa8c
--- /dev/null
@@ -0,0 +1,24 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=CHARTGRP
+DIST_VERSION=2.4.10
+inherit perl-module
+
+DESCRIPTION="The Perl Chart Module"
+# bundles lots of things in jquery.js
+# https://bugs.gentoo.org/724570
+LICENSE="|| ( Artistic GPL-1+ ) || ( MIT ( GPL-1 GPL-2 ) )"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND=">=dev-perl/GD-2.0.36"
+BDEPEND="${RDEPEND}
+       test? (
+               dev-perl/GD[png,jpeg]
+       )
+"